dev-util/bless: Fix rarian dep, bump eapi.
authorPacho Ramos <pacho@gentoo.org>
Fri, 4 Nov 2016 09:01:42 +0000 (10:01 +0100)
committerPacho Ramos <pacho@gentoo.org>
Fri, 4 Nov 2016 09:15:44 +0000 (10:15 +0100)
Package-Manager: portage-2.3.2

dev-util/bless/bless-0.6.0-r2.ebuild
dev-util/bless/files/bless-0.6.0-pixmap.patch

index 3f0a08736ddd1c2f1b5a587d1eb0c75f651789ca..c65b564214d9c1201c1cc733eaaaa53209cc8c3c 100644 (file)
@@ -1,11 +1,9 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
-EAPI=5
-GCONF_DEBUG="no"
-
-inherit autotools eutils gnome2 mono-env
+EAPI=6
+inherit autotools gnome2 mono-env
 
 DESCRIPTION="GTK# Hex Editor"
 HOMEPAGE="http://home.gna.org/bless/"
@@ -23,7 +21,7 @@ RDEPEND="
             >=dev-dotnet/glade-sharp-2.12 )
 "
 DEPEND="${RDEPEND}
-       app-text/scrollkeeper
+       app-text/rarian
        >=sys-devel/gettext-0.15
        virtual/pkgconfig
 "
@@ -41,9 +39,9 @@ pkg_setup() {
 src_prepare() {
        einfo "Running gettextize -f --no-changelog..."
        ( "${T}/gettextize" -f --no-changelog > /dev/null ) || die "gettexize failed"
-       epatch "${FILESDIR}/${P}-pixmap.patch"
-       epatch "${FILESDIR}/${P}-docpath.patch"
-       epatch "${FILESDIR}/${P}-mono-4.patch"
+       eapply "${FILESDIR}/${P}-pixmap.patch"
+       eapply "${FILESDIR}/${P}-docpath.patch"
+       eapply "${FILESDIR}/${P}-mono-4.patch"
        eautoreconf
        gnome2_src_prepare
 }
index 441a9e2bfb79f0377b9fec7e316284f7fc90c1fe..de77cb84e75019250a905735e62761e284a6027f 100644 (file)
@@ -1,6 +1,6 @@
 === modified file 'src/gui/drawers/HexDrawer.cs'
---- src/gui/drawers/HexDrawer.cs       2007-06-13 12:20:53 +0000
-+++ src/gui/drawers/HexDrawer.cs       2009-04-10 23:21:41 +0000
+--- a/src/gui/drawers/HexDrawer.cs     2007-06-13 12:20:53 +0000
++++ b/src/gui/drawers/HexDrawer.cs     2009-04-10 23:21:41 +0000
 @@ -57,11 +57,14 @@
  
                //System.Console.WriteLine(s);