dev-python/python-ironicclient: cleanup
authorMatthew Thode <prometheanfire@gentoo.org>
Tue, 11 Feb 2020 18:51:22 +0000 (12:51 -0600)
committerMatthew Thode <prometheanfire@gentoo.org>
Tue, 11 Feb 2020 19:06:23 +0000 (13:06 -0600)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
dev-python/python-ironicclient/Manifest
dev-python/python-ironicclient/python-ironicclient-1.17.0.ebuild [deleted file]
dev-python/python-ironicclient/python-ironicclient-2.2.1.ebuild [deleted file]
dev-python/python-ironicclient/python-ironicclient-2.7.1.ebuild [deleted file]
dev-python/python-ironicclient/python-ironicclient-2.7.2.ebuild

index 812ac2393580cafe5ef8e60d7b9905b35e6d5ebf..23cfd5c96294d396900a146e708ee9b98b2996e6 100644 (file)
@@ -1,4 +1 @@
-DIST python-ironicclient-1.17.0.tar.gz 206742 BLAKE2B 8fb92acb02e146916dfebd677ac1c179e78b0c16af80fe59361de6def1435d58466a1b9aef9798a05e0ed2ddc30e860e7da7579c2e6a336ff5f220d41b93b51e SHA512 3a1594d499dbfb508a87e87459308cdeb3eac9987116c8a7a250c5751fc1d4785056033e521ec5d99514a2b6c84362e7576dfec9c4941970422cf2757262c651
-DIST python-ironicclient-2.2.1.tar.gz 220436 BLAKE2B b36a5d0b2c297f52a121aa96007ce03556199d7d6139198e39114f2931fd7004bdf76fc5eca369247975bb9eb6d853a2fb4be133976de0ddfeb5767ead6c3c1a SHA512 1827dba991c59cea8a43dd11d0f8f0f1dd6ae41a7f1f28d9d200bac61ae9a4901ac280107fa91a95ebf24072634eadee2e0140f5e1cf5962496f34997815aa04
-DIST python-ironicclient-2.7.1.tar.gz 246190 BLAKE2B c31a439d9175a1915e34988e6e22fe2f05c722925928e30316a3f87023e393a8ee98ca1dbcca19760c009b28c7815478648259865316fac493e1c674cf70fce5 SHA512 654fa4f20b258094d4b05c34f059fa06f12638a210283b6821f6be5acf54bd15a03c73960a7a94d14635a1361370976d86e6b233bd1868c89d9aa82fc1fe7a8f
 DIST python-ironicclient-2.7.2.tar.gz 246413 BLAKE2B 28c71f619baa539a2d82b8aa1e2462de092a385f0b6efd88fa3f5c676aab5603b1060e671b7fd93c2f69a83e6ce4c065fe0492483dd93cdf0af6633403775cab SHA512 6a41ccc0e811fae571652837244ed7f23ec9a7ccf512a71519315406abe7fe0117013765c4d6c1e3c75daa21346b1f94881a32217b3a5829bf473d0b18470c0e
diff --git a/dev-python/python-ironicclient/python-ironicclient-1.17.0.ebuild b/dev-python/python-ironicclient/python-ironicclient-1.17.0.ebuild
deleted file mode 100644 (file)
index 7eaa3ac..0000000
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="Python bindings for the Ironic API"
-HOMEPAGE="https://www.openstack.org/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-CDEPEND="
-       >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
-       !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
-"
-CRDEPEND="
-       >=dev-python/appdirs-1.3.0[${PYTHON_USEDEP}]
-       >=dev-python/dogpile-cache-0.6.2[${PYTHON_USEDEP}]
-       >=dev-python/jsonschema-2.0.0[${PYTHON_USEDEP}]
-       !~dev-python/jsonschema-2.5.0[${PYTHON_USEDEP}]
-       <dev-python/jsonschema-3.0.0[${PYTHON_USEDEP}]
-       >=dev-python/keystoneauth-3.1.0[${PYTHON_USEDEP}]
-       >=dev-python/osc-lib-1.7.0[${PYTHON_USEDEP}]
-       >=dev-python/oslo-i18n-2.1.0[${PYTHON_USEDEP}]
-       !~dev-python/oslo-i18n-3.15.2[${PYTHON_USEDEP}]
-       >=dev-python/oslo-serialization-1.10.0[${PYTHON_USEDEP}]
-       !~dev-python/oslo-serialization-2.19.1[${PYTHON_USEDEP}]
-       >=dev-python/oslo-utils-3.20.0[${PYTHON_USEDEP}]
-       >=dev-python/prettytable-0.7.1[${PYTHON_USEDEP}]
-       <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
-       >=dev-python/python-openstackclient-3.3.0[${PYTHON_USEDEP}]
-       !~dev-python/python-openstackclient-3.10.0[${PYTHON_USEDEP}]
-       >=dev-python/pyyaml-3.10.0[${PYTHON_USEDEP}]
-       >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
-       >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
-"
-DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       ${CDEPEND}
-       test? (
-               ${CRDEPEND}
-               >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
-               !~dev-python/coverage-4.4[${PYTHON_USEDEP}]
-               dev-python/doc8[${PYTHON_USEDEP}]
-               >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
-               >=dev-python/requests-mock-1.1[${PYTHON_USEDEP}]
-               >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
-               >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
-               !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
-               >=dev-python/openstackdocstheme-1.16.0[${PYTHON_USEDEP}]
-               >=dev-python/reno-1.8.0[${PYTHON_USEDEP}]
-               !~dev-python/reno-2.3.1[${PYTHON_USEDEP}]
-               >=dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
-               >=dev-python/subunit-0.0.18[${PYTHON_USEDEP}]
-               >=dev-python/sphinx-1.6.2[${PYTHON_USEDEP}]
-               >=dev-python/testtools-1.4.0[${PYTHON_USEDEP}]
-               >=dev-python/os-testr-0.8.0[${PYTHON_USEDEP}]
-               >=dev-python/ddt-1.0.1[${PYTHON_USEDEP}]
-       )
-"
-RDEPEND="
-       ${CDEPEND}
-       ${CRDEPEND}
-"
-python_prepare_all() {
-       sed -i '/^hacking/d' test-requirements.txt || die
-       sed -i '/^tempest/d' test-requirements.txt || die
-       distutils-r1_python_prepare_all
-}
-
-python_test() {
-       #rm -rf .testrepository || die "couldn't remove '.testrepository' under ${EPYTHON}"
-
-       testr init || die "testr init failed under ${EPYTHON}"
-       testr run || die "testr run failed under ${EPYTHON}"
-}
diff --git a/dev-python/python-ironicclient/python-ironicclient-2.2.1.ebuild b/dev-python/python-ironicclient/python-ironicclient-2.2.1.ebuild
deleted file mode 100644 (file)
index f4aaf2b..0000000
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="Python bindings for the Ironic API"
-HOMEPAGE="https://www.openstack.org/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-CDEPEND="
-       >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
-       !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
-"
-CRDEPEND="
-       >=dev-python/appdirs-1.3.0[${PYTHON_USEDEP}]
-       >=dev-python/dogpile-cache-0.6.2[${PYTHON_USEDEP}]
-       >=dev-python/jsonschema-2.6.0[${PYTHON_USEDEP}]
-       <dev-python/jsonschema-3.0.0[${PYTHON_USEDEP}]
-       >=dev-python/keystoneauth-3.3.0[${PYTHON_USEDEP}]
-       >=dev-python/osc-lib-1.8.0[${PYTHON_USEDEP}]
-       >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
-       >=dev-python/oslo-serialization-2.18.0[${PYTHON_USEDEP}]
-       !~dev-python/oslo-serialization-2.19.1[${PYTHON_USEDEP}]
-       >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
-       >=dev-python/prettytable-0.7.1[${PYTHON_USEDEP}]
-       <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
-       >=dev-python/pyyaml-3.10.0[${PYTHON_USEDEP}]
-       >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
-       >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
-"
-DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       ${CDEPEND}
-       test? (
-               ${CRDEPEND}
-               >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
-               !~dev-python/coverage-4.4[${PYTHON_USEDEP}]
-               >=dev-python/doc8-0.6.0[${PYTHON_USEDEP}]
-               >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
-               >=dev-python/requests-mock-1.1.0[${PYTHON_USEDEP}]
-               >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
-               >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
-               !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
-               >=dev-python/openstackdocstheme-1.18.1[${PYTHON_USEDEP}]
-               >=dev-python/reno-2.5.0[${PYTHON_USEDEP}]
-               >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
-               >=dev-python/sphinx-1.6.2[${PYTHON_USEDEP}]
-               !~dev-python/sphinx-1.6.6[${PYTHON_USEDEP}]
-               >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
-               >=dev-python/os-testr-1.0.0[${PYTHON_USEDEP}]
-               >=dev-python/ddt-1.0.1[${PYTHON_USEDEP}]
-               >=dev-python/python-openstackclient-3.12.0[${PYTHON_USEDEP}]
-       )
-"
-RDEPEND="
-       ${CDEPEND}
-       ${CRDEPEND}
-"
-python_prepare_all() {
-       sed -i '/^hacking/d' test-requirements.txt || die
-       sed -i '/^tempest/d' test-requirements.txt || die
-       distutils-r1_python_prepare_all
-}
-
-python_test() {
-       #rm -rf .testrepository || die "couldn't remove '.testrepository' under ${EPYTHON}"
-
-       testr init || die "testr init failed under ${EPYTHON}"
-       testr run || die "testr run failed under ${EPYTHON}"
-}
diff --git a/dev-python/python-ironicclient/python-ironicclient-2.7.1.ebuild b/dev-python/python-ironicclient/python-ironicclient-2.7.1.ebuild
deleted file mode 100644 (file)
index fcd5ed6..0000000
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="Python bindings for the Ironic API"
-HOMEPAGE="https://www.openstack.org/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-CDEPEND="
-       >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
-       !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
-"
-CRDEPEND="
-       >=dev-python/appdirs-1.3.0[${PYTHON_USEDEP}]
-       >=dev-python/dogpile-cache-0.6.2[${PYTHON_USEDEP}]
-       >=dev-python/jsonschema-2.6.0[${PYTHON_USEDEP}]
-       <dev-python/jsonschema-3.0.0[${PYTHON_USEDEP}]
-       >=dev-python/keystoneauth-3.4.0[${PYTHON_USEDEP}]
-       >=dev-python/osc-lib-1.10.0[${PYTHON_USEDEP}]
-       >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
-       >=dev-python/oslo-serialization-2.18.0[${PYTHON_USEDEP}]
-       !~dev-python/oslo-serialization-2.19.1[${PYTHON_USEDEP}]
-       >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
-       >=dev-python/prettytable-0.7.1[${PYTHON_USEDEP}]
-       <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
-       >=dev-python/pyyaml-3.12.0[${PYTHON_USEDEP}]
-       >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
-       >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
-"
-DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       ${CDEPEND}
-       test? (
-               ${CRDEPEND}
-               >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
-               !~dev-python/coverage-4.4[${PYTHON_USEDEP}]
-               >=dev-python/doc8-0.6.0[${PYTHON_USEDEP}]
-               >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
-               >=dev-python/requests-mock-1.2.0[${PYTHON_USEDEP}]
-               >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
-               >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
-               !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
-               >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
-               >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
-               >=dev-python/stestr-1.0.0[${PYTHON_USEDEP}]
-               >=dev-python/ddt-1.0.1[${PYTHON_USEDEP}]
-               >=dev-python/python-openstackclient-3.12.0[${PYTHON_USEDEP}]
-       )
-"
-RDEPEND="
-       ${CDEPEND}
-       ${CRDEPEND}
-"
-python_prepare_all() {
-       sed -i '/^hacking/d' test-requirements.txt || die
-       sed -i '/^tempest/d' test-requirements.txt || die
-       distutils-r1_python_prepare_all
-}
-
-python_test() {
-       #rm -rf .testrepository || die "couldn't remove '.testrepository' under ${EPYTHON}"
-
-       testr init || die "testr init failed under ${EPYTHON}"
-       testr run || die "testr run failed under ${EPYTHON}"
-}
index fcd5ed68f034b7002b3681e448ae08ada9c2e572..ba0ca14114b0217c733a3352bf60ebda4a32668a 100644 (file)
@@ -1,8 +1,8 @@
 # Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
-PYTHON_COMPAT=( python3_6 )
+EAPI=7
+PYTHON_COMPAT=( python3_6 python3_7 )
 
 inherit distutils-r1
 
@@ -12,7 +12,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
 
 LICENSE="Apache-2.0"
 SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux"
 IUSE="test"
 RESTRICT="!test? ( test )"