dev-python/python-ethtool: EAPI7, fix Homepage and SRC_URI
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>
Tue, 29 Jan 2019 13:51:07 +0000 (14:51 +0100)
committerGeorgy Yakovlev <gyakovlev@gentoo.org>
Sat, 2 Feb 2019 23:42:18 +0000 (15:42 -0800)
Closes: https://bugs.gentoo.org/676784
Closes: https://github.com/gentoo/gentoo/pull/10930
Signed-off-by: Michael Mair-Keimberger <m.mairkeimberger@gmail.com>
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
dev-python/python-ethtool/Manifest
dev-python/python-ethtool/python-ethtool-0.11-r1.ebuild [new file with mode: 0644]

index 8e5f0451c7af074d9398398e7c77a22e4d6f1d4c..b472e3a2229f069cb189282da399adf3e16e2bad 100644 (file)
@@ -1 +1,2 @@
 DIST python-ethtool-0.11.tar.bz2 34487 BLAKE2B bdb5eced32c508a593bbbc80fc287ece547c34504bbdf36877f4b62dea1239a33c5ea23dcecdd8b0f8104eea3ec7d5418a3ee5a1697930ea24a51da42f3ddc24 SHA512 b260e608e1024c48eedb72327b704b01fb42396219ca3d942fe42f22d3e8018fc74bfeffd96e37abd4efd2ce49a73915e0e2af5841a537a02e247d4ba5548f20
+DIST python-ethtool-0.11.tar.gz 37326 BLAKE2B b2345f5aece60c3b418d9fcd61220ab77fb49b9995a23b0ed6d97135dee61e4ffa177059869a8702430703b9f6518ffdcb8d690c868d0f8338ab16fdc36c58ea SHA512 227a9248dfdd36a9018a441d3ef4680691c23dac52972fe1ecc67ff30991f3de4cd71af0e48669ca382d6f177d1b3ebc97596e5a5ae4b4c80371456effe637b5
diff --git a/dev-python/python-ethtool/python-ethtool-0.11-r1.ebuild b/dev-python/python-ethtool/python-ethtool-0.11-r1.ebuild
new file mode 100644 (file)
index 0000000..8feab87
--- /dev/null
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 )
+
+# TODO: install scripts and their man pages
+
+inherit distutils-r1
+
+DESCRIPTION="Ethernet settings python bindings"
+HOMEPAGE="https://pypi.org/project/ethtool/
+       https://github.com/fedora-python/python-ethtool"
+SRC_URI="https://github.com/fedora-python/python-ethtool/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~amd64"
+
+DEPEND="dev-libs/libnl:3"
+RDEPEND="${DEPEND}"
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+PATCHES=(
+       "${FILESDIR}/${P}_include-net-if.h-for-IFF_-macros.patch"
+)