x11-libs/dnd: EAPI 6 bump.
authorPatrice Clement <monsieurp@gentoo.org>
Fri, 24 Feb 2017 23:42:07 +0000 (00:42 +0100)
committerPatrice Clement <monsieurp@gentoo.org>
Sat, 25 Feb 2017 00:04:17 +0000 (01:04 +0100)
Package-Manager: portage-2.3.3

x11-libs/dnd/dnd-1.1-r2.ebuild [new file with mode: 0644]

diff --git a/x11-libs/dnd/dnd-1.1-r2.ebuild b/x11-libs/dnd/dnd-1.1-r2.ebuild
new file mode 100644 (file)
index 0000000..d90dac9
--- /dev/null
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="OffiX' Drag'n'drop library"
+HOMEPAGE="http://leb.net/offix"
+SRC_URI="http://leb.net/offix/${PN}.${PV}.tgz"
+SLOT="0"
+LICENSE="GPL-2 LGPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+       x11-libs/libXt
+       x11-libs/libSM
+       x11-libs/libX11
+       x11-libs/libXmu
+       x11-libs/libICE
+       x11-libs/libXaw
+       x11-proto/xproto"
+
+DEPEND="
+       ${RDEPEND}"
+
+PATCHES=(
+       "${FILESDIR}"/${P}-gentoo.diff
+       "${FILESDIR}"/Makefile-fix.patch
+)
+
+S="${WORKDIR}/DND/DNDlib"
+
+src_configure() {
+       tc-export CC CXX RANLIB AR
+       econf --with-x
+}
+
+src_install () {
+       emake DESTDIR="${D}" install
+}