www-client/chromium: fix build with icu-65
authorStephan Hartmann <stephan.hartmann@tu-dresden.de>
Sat, 26 Oct 2019 21:31:37 +0000 (23:31 +0200)
committerMike Gilbert <floppym@gentoo.org>
Sun, 27 Oct 2019 14:38:48 +0000 (10:38 -0400)
Closes: https://bugs.gentoo.org/698564
Closes: https://github.com/gentoo/gentoo/pull/13455
Package-Manager: Portage-2.3.76, Repoman-2.3.16
Signed-off-by: Stephan Hartmann <stha09@googlemail.com>
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
www-client/chromium/chromium-79.0.3941.4.ebuild
www-client/chromium/files/chromium-79-icu-65.patch [new file with mode: 0644]

index 1cb2a50a73e4525eb626bfaa23f8d65fad099171..9e2a2c461308eef5593384729523f9483cc61b7f 100644 (file)
@@ -150,6 +150,7 @@ PATCHES=(
        "${FILESDIR}/chromium-79-swiftshader-linux.patch"
        "${FILESDIR}/chromium-79-system-hb.patch"
        "${FILESDIR}/chromium-79-include.patch"
+       "${FILESDIR}/chromium-79-icu-65.patch"
        "${FILESDIR}/chromium-79-gcc-ambiguous-nodestructor.patch"
        "${FILESDIR}/chromium-79-gcc-permissive.patch"
        "${FILESDIR}/chromium-79-gcc-alignas.patch"
diff --git a/www-client/chromium/files/chromium-79-icu-65.patch b/www-client/chromium/files/chromium-79-icu-65.patch
new file mode 100644 (file)
index 0000000..e0732b6
--- /dev/null
@@ -0,0 +1,13 @@
+diff --git a/third_party/blink/renderer/core/dom/document.cc b/third_party/blink/renderer/core/dom/document.cc
+index 5a62770..1fae2aa 100644
+--- a/third_party/blink/renderer/core/dom/document.cc
++++ b/third_party/blink/renderer/core/dom/document.cc
+@@ -6192,7 +6192,7 @@ static ParseQualifiedNameResult ParseQualifiedNameInternal(
+   for (unsigned i = 0; i < length;) {
+     UChar32 c;
+-    U16_NEXT(characters, i, length, c)
++    U16_NEXT(characters, i, length, c);
+     if (c == ':') {
+       if (saw_colon)
+         return ParseQualifiedNameResult(kQNMultipleColons);