media-plugins/kodi-audiodecoder-nosefart: 2.0.1 version bump
authorCraig Andrews <candrews@gentoo.org>
Fri, 20 Sep 2019 16:33:24 +0000 (12:33 -0400)
committerCraig Andrews <candrews@gentoo.org>
Fri, 20 Sep 2019 16:34:03 +0000 (12:34 -0400)
Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Craig Andrews <candrews@gentoo.org>
media-plugins/kodi-audiodecoder-nosefart/Manifest
media-plugins/kodi-audiodecoder-nosefart/kodi-audiodecoder-nosefart-2.0.1.ebuild [new file with mode: 0644]
media-plugins/kodi-audiodecoder-nosefart/kodi-audiodecoder-nosefart-9999.ebuild

index 85d81a9402cc0310981d85b7fc24407f062582d9..93e0302dcf72be153c6f5b0ca0f4cdd8364b2a85 100644 (file)
@@ -1 +1,2 @@
 DIST kodi-audiodecoder-nosefart-2.0.0.tar.gz 61006 BLAKE2B 8c3499b8820eb124f6532f722fae39c10880b31d58dce81a1170ae18005047b2ecdb7f9963e1a957de61beaf4a89d682580ea62e739bdc3045e0cd6402685394 SHA512 8dfcae6e81553bccb093dac2aefdbea6e405ebcf3c3505b4647a4970f46ec8aa2f45690a0fd73ff356d074c86c670ab0a60ff5a049dd1e54de3100457fbae935
+DIST kodi-audiodecoder-nosefart-2.0.1.tar.gz 92746 BLAKE2B 0af1578e0f09c4dfbbbddec834522c433922deccbc7f55c4faa4b5b5a7b4fb5563daea77faf745f5f8c61f4d49f168b1e5dee37a2e7d19f2f7d4aa9d685d69ef SHA512 78abac0d6ff2458e5bd3c976d432d5029c07d738dc03f861e068407b60d5ef2f94d7870d803436e8eacd87fdbd47b274e0bdc3367201772cd05084c1ebc8a67c
diff --git a/media-plugins/kodi-audiodecoder-nosefart/kodi-audiodecoder-nosefart-2.0.1.ebuild b/media-plugins/kodi-audiodecoder-nosefart/kodi-audiodecoder-nosefart-2.0.1.ebuild
new file mode 100644 (file)
index 0000000..abec4e0
--- /dev/null
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils kodi-addon
+
+DESCRIPTION="Nosefart decoder addon for Kodi"
+HOMEPAGE="https://github.com/notspiff/audiodecoder.nosefart"
+SRC_URI=""
+
+case ${PV} in
+9999)
+       SRC_URI=""
+       EGIT_REPO_URI="https://github.com/notspiff/audiodecoder.nosefart"
+       inherit git-r3
+       ;;
+*)
+       CODENAME="Leia"
+       KEYWORDS="~amd64 ~x86"
+       SRC_URI="https://github.com/notspiff/audiodecoder.nosefart/archive/${PV}-${CODENAME}.tar.gz -> ${P}.tar.gz"
+       S="${WORKDIR}/audiodecoder.nosefart-${PV}-${CODENAME}"
+       ;;
+esac
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+       =media-tv/kodi-18*
+       "
+RDEPEND="
+       ${DEPEND}
+       "
index d52c566cfceb4aea6d1d574f59d0484567a67f32..b9bf148c43e8fe4b399bfa0d1068e4fe651cc0e9 100644 (file)
@@ -29,7 +29,6 @@ IUSE=""
 
 DEPEND="
        ~media-tv/kodi-9999
-       ~media-libs/kodi-platform-9999
        "
 RDEPEND="
        ${DEPEND}