net-wireless/kismet: bump
authorRick Farina <zerochaos@gentoo.org>
Mon, 9 Mar 2020 20:00:01 +0000 (16:00 -0400)
committerRick Farina <zerochaos@gentoo.org>
Mon, 9 Mar 2020 20:00:01 +0000 (16:00 -0400)
Package-Manager: Portage-2.3.93, Repoman-2.3.20
Signed-off-by: Rick Farina <zerochaos@gentoo.org>
net-wireless/kismet/Manifest
net-wireless/kismet/kismet-2020.03.1.ebuild [new file with mode: 0644]

index c0260b51a5795808015dd0b1c715ef136eddfb9f..9ec3e67b55f25fd6727ee512610bdeed2eb2b55f 100644 (file)
@@ -1,3 +1,4 @@
 DIST kismet-2016-07-R1.tar.xz 709364 BLAKE2B 5b667a02b517bd413d569f40df1f2a2e1158357c602fa807d712870543a7fade25077f449c07c023ad1d2150870352aa754484846d8c2a0d9f027113bb57c1fc SHA512 88891a0cd5ef94a4815d259e433f946f52552c125e05a5d8ac447d04e6090f2bd92f8bd8573440f0dfe446b29233bef81d9889e53170757ad0116ddfc2cb8416
 DIST kismet-2019-09-R1.tar.xz 3034832 BLAKE2B 9f7818549e5260dc081ac39ea8323c70f2e4d0b959bc42dacc253c9d72bf72c2547f7c6d65d84ee7d0ca4a41068f5973028e48f6f9f3c5a7cd50c35246570814 SHA512 eeaf069718206f2b6d292c41792217afc9c72c10ffa014c8c670de64195bd28d44f33364dba7d338610f17a5af2be3c125ccd1297cce362159a4968c9ddabb88
 DIST kismet-2019-12-R2.tar.xz 3127064 BLAKE2B b7ffac6a6a4d7d7893d3564f9471080e055798c325b102f98fa0e86db37bcbab33422afae9c2694b747ae0c369259b62c218a77c673d0e0c05969a56e42311c2 SHA512 b1e3de74a6d314150d849ac3d95c8b99324bba14522dc4f00244d1c09acb690cce40d35dbe33845ffb1060a69cd38f036d59a0283ed9b1a70b022e3d57cde5a0
+DIST kismet-2020-03-R1.tar.xz 3137312 BLAKE2B c20137677f598c0856e21e3c34b52b1edea1262cc0049638f31554a78780d37860200dae85ac65e35cda8425be6798fe98ac3de08e8dcbff33ea0b7b9fdb945f SHA512 a237d31ef953729571232693cc51029add808002dfcb350e6dbb0a5360f85b3c608e4d49273d4b377e91ba83feff198527a13930f1976b2182eee7e5185471a2
diff --git a/net-wireless/kismet/kismet-2020.03.1.ebuild b/net-wireless/kismet/kismet-2020.03.1.ebuild
new file mode 100644 (file)
index 0000000..73b8a86
--- /dev/null
@@ -0,0 +1,175 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_6 )
+
+inherit autotools eutils multilib user python-single-r1
+
+if [[ ${PV} == "9999" ]] ; then
+       EGIT_REPO_URI="https://www.kismetwireless.net/git/${PN}.git"
+       inherit git-r3
+       RESTRICT="strip"
+else
+       MY_P=${P/\./-}
+       MY_P=${MY_P/_beta/-BETA}
+       MY_P=${MY_P/./-R}
+       S=${WORKDIR}/${MY_P/BETA/beta}
+
+       #normally we want an official release
+       SRC_URI="https://www.kismetwireless.net/code/${MY_P}.tar.xz"
+
+       #but sometimes we want a git commit
+       #COMMIT="6d6d486831c0f7ac712ffb8a3ff122c5063c3b2a"
+       #SRC_URI="https://github.com/kismetwireless/kismet/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+       #S="${WORKDIR}/${PN}-${COMMIT}"
+
+       KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+fi
+
+DESCRIPTION="IEEE 802.11 wireless LAN sniffer"
+HOMEPAGE="https://www.kismetwireless.net"
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+IUSE="libusb lm-sensors networkmanager +pcre rtlsdr selinux +suid ubertooth"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+CDEPEND="
+       ${PYTHON_DEPS}
+       networkmanager? ( net-misc/networkmanager:= )
+       dev-libs/glib:=
+       dev-libs/elfutils:=
+       sys-libs/zlib:=
+       dev-db/sqlite:=
+       net-libs/libmicrohttpd
+       kernel_linux? ( sys-libs/libcap
+                       dev-libs/libnl:3
+                       net-libs/libpcap
+                       )
+       libusb? ( virtual/libusb:1 )
+       dev-libs/protobuf-c:=
+       dev-libs/protobuf:=
+       $(python_gen_cond_dep '
+               dev-python/protobuf-python[${PYTHON_MULTI_USEDEP}]
+       ')
+       sys-libs/ncurses:=
+       lm-sensors? ( sys-apps/lm-sensors )
+       pcre? ( dev-libs/libpcre )
+       suid? ( sys-libs/libcap )
+       ubertooth? ( net-wireless/ubertooth:= )
+       "
+
+DEPEND="${CDEPEND}
+       virtual/pkgconfig
+"
+
+RDEPEND="${CDEPEND}
+       $(python_gen_cond_dep '
+               dev-python/pyserial[${PYTHON_MULTI_USEDEP}]
+       ')
+       selinux? ( sec-policy/selinux-kismet )
+"
+PDEPEND="
+       rtlsdr? (
+               $(python_gen_cond_dep '
+                       dev-python/numpy[${PYTHON_MULTI_USEDEP}]
+               ')
+               net-wireless/rtl-sdr
+       )"
+
+src_prepare() {
+       sed -i -e "s:^\(logtemplate\)=\(.*\):\1=/tmp/\2:" \
+               conf/kismet_logging.conf || die
+
+       # Don't strip and set correct mangrp
+       sed -i -e 's| -s||g' \
+               -e 's|@mangrp@|root|g' Makefile.in
+
+       eapply_user
+
+       #just use set to fix setup.py
+       find . -name "Makefile.in" -exec sed -i 's#setup.py install#setup.py install --root=$(DESTDIR)#' {} + || die
+       find . -name "Makefile" -exec sed -i 's#setup.py install#setup.py install --root=$(DESTDIR)#' {} + || die
+
+       if [ "${PV}" = "9999" ]; then
+               eautoreconf
+       fi
+}
+
+src_configure() {
+       econf \
+               $(use_enable libusb libusb) \
+               $(use_enable pcre) \
+               $(use_enable lm-sensors lmsensors) \
+               $(use_enable networkmanager libnm) \
+               $(use_enable ubertooth) \
+               --sysconfdir=/etc/kismet \
+               --disable-optimization
+}
+
+src_install() {
+       emake DESTDIR="${D}" commoninstall
+       python_optimize
+       emake DESTDIR="${D}" forceconfigs
+
+       insinto /usr/share/${PN}
+       doins Makefile.inc
+
+       dodoc CHANGELOG README*
+       newinitd "${FILESDIR}"/${PN}.initd-r3 kismet
+       newconfd "${FILESDIR}"/${PN}.confd-r2 kismet
+}
+
+pkg_preinst() {
+       if use suid; then
+               enewgroup kismet
+               fowners root:kismet /usr/bin/kismet_cap_linux_bluetooth
+               fowners root:kismet /usr/bin/kismet_cap_linux_wifi
+               fowners root:kismet /usr/bin/kismet_cap_pcapfile
+               # Need to set the permissions after chowning.
+               # See chown(2)
+               fperms 4550 /usr/bin/kismet_cap_linux_bluetooth
+               fperms 4550 /usr/bin/kismet_cap_linux_wifi
+               fperms 4550 /usr/bin/kismet_cap_pcapfile
+               elog "Kismet has been installed with a setuid-root helper binary"
+               elog "to enable minimal-root operation.  Users need to be part of"
+               elog "the 'kismet' group to perform captures from physical devices."
+       fi
+       if ! use suid; then
+               ewarn "It is highly discouraged to run a sniffer as root,"
+               ewarn "Please consider enabling the suid use flag and adding"
+               ewarn "your user to the kismet group."
+       fi
+}
+
+migrate_config() {
+       einfo "Kismet Configuration files are now read from /etc/kismet/"
+       ewarn "Please keep user specific settings in /etc/kismet/kismet_site.conf"
+       if [ -n "$(ls ${EROOT}/etc/kismet_*.conf 2> /dev/null)" ]; then
+               ewarn "Files at /etc/kismet_*.conf will not be read and should be removed"
+       fi
+       if [ -f "${EROOT}/etc/kismet_site.conf" ] && [ ! -f "${EROOT}/etc/kismet/kismet_site.conf" ]; then
+               mv /etc/kismet_site.conf /etc/kismet/kismet_site.conf || die "Failed to migrate kismet_site.conf to new location"
+               ewarn "Your /etc/kismet_site.conf file has been automatically moved to /etc/kismet/kismet_site.conf"
+       elif [ -f "${EROOT}/etc/kismet_site.conf" ] && [ -f "${EROOT}/etc/kismet/kismet_site.conf" ]; then
+               ewarn "Both /etc/kismet_site.conf and /etc/kismet/kismet_site.conf exist, please migrate needed bits"
+               ewarn "into /etc/kismet/kismet_site.conf and remove /etc/kismet_site.conf"
+       fi
+}
+
+pkg_postinst() {
+       if [ -n "${REPLACING_VERSIONS}" ]; then
+               for v in ${REPLACING_VERSIONS}; do
+                       if ver_test ${v} -lt 2019.07.2 ; then
+                               migrate_config
+                               break
+                       fi
+                       if ver_test ${v} -eq 9999 ; then
+                               migrate_config
+                               break
+                       fi
+               done
+       fi
+}