app-backup/burp: Version bump
authorAmadeusz Żołnowski <aidecoe@gentoo.org>
Mon, 17 Aug 2015 21:41:56 +0000 (22:41 +0100)
committerAmadeusz Żołnowski <aidecoe@gentoo.org>
Mon, 17 Aug 2015 21:47:56 +0000 (22:47 +0100)
Package-Manager: portage-2.2.20.1

app-backup/burp/Manifest
app-backup/burp/burp-1.4.40.ebuild [new file with mode: 0644]
app-backup/burp/files/1.4.40-bedup-conf-path.patch [new file with mode: 0644]
app-backup/burp/files/1.4.40-tinfo.patch [new file with mode: 0644]

index 274658aa00ed33ec4a321eb722027f67be6a4c87..cc324b0d8c7bb9aaff04c810e5759a5b43a500d0 100644 (file)
@@ -1,3 +1,4 @@
 DIST burp-1.3.48.tar.bz2 683509 SHA256 bb456c208998d2f5806828357934e794cd9675448cb6545473364fd9e6d73509 SHA512 08de252f25ff7aa448dd6768272a9a14622902347445313b570c857b4e690374e92956379d5b388f446a88427fc4924f9c0df83cba390aa15fd040b8e92f1946 WHIRLPOOL ac99abddd74bcc753037841afc78c74c7af23ad550334f0585540f056ce93243b8958cbdc37cae15cb98a02c2884c928dd65ac03820e1ef53ea031128a831a44
 DIST burp-1.3.8.tar.bz2 796082 SHA256 ed1546d97e902d0b3974a32ef3f543b5d9ec0a5448f3caca2373383192169656 SHA512 49f4fa43bcbd2aa54b8cee840dfb2f1b7e396048c609d7303fdef08d13dbaf7b0c7016da39620fc5a15cd9dfb8577f82e8446512887aff1ce1b6ce31e7a60e57 WHIRLPOOL 957cdf4b75ec5a79b7c259786b099cf5c001ebc1684df0a1028dda7ec90a2710c1cfcd4f2a8a2fb349466bc5405672350f01f989a4f6a5302eae4fa466af3056
 DIST burp-1.4.34.tar.bz2 712409 SHA256 547d84a03d84a5ece0562b75f785180846c8f0525c212f66316650187c9cbad2 SHA512 c65d7fab80d24fbf73c5bed1381709ad00c43372e26cebffb2847be57f3c32ec5e6ab060707766a06689a9ab7b490ce10acc93b4c229b336d1791b9dd82e025d WHIRLPOOL fa15dbdae7efd7c9736f40f06555b83b4a4b6cb932ce205eccf3e0606276aa0723c083ef0cf6e006d1cbca814265e6280572a17483d5631ac3928e6967cbcc8a
+DIST burp-1.4.40.tar.bz2 712937 SHA256 4108eb45e14740de990d918a2adbb661d88f90de48d6e2e3a6b54fd12b16fa5e SHA512 b44ba3a63d3b75f6fee55bbfef70ac07fa87e78ddb22a398e31a86670dfa3f2db1c9dbc58de3d0038cdc409bd5ae52c8e901cb26975fd7dbe0f773c4841af10c WHIRLPOOL 636120b3fa2d4a3217567177f3c8abbdeb562d298043fd6bd685842287964d835f2a369e36db0bc32ce908ce8f96e4e2677569e6ca4bac80f8d9958a2364a62d
diff --git a/app-backup/burp/burp-1.4.40.ebuild b/app-backup/burp/burp-1.4.40.ebuild
new file mode 100644 (file)
index 0000000..9c1ed76
--- /dev/null
@@ -0,0 +1,95 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils user
+
+DESCRIPTION="Network backup and restore client and server for Unix and Windows"
+HOMEPAGE="http://burp.grke.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="acl afs ipv6 nls ssl tcpd xattr"
+
+DEPEND="
+       dev-libs/openssl:0
+       dev-libs/uthash
+       sys-libs/libcap
+       net-libs/librsync
+       sys-libs/ncurses
+       sys-libs/zlib
+       acl? ( sys-apps/acl )
+       afs? ( net-fs/openafs )
+       nls? ( sys-devel/gettext )
+       tcpd? ( sys-apps/tcp-wrappers )
+       xattr? ( sys-apps/attr )
+       "
+RDEPEND="${DEPEND}
+       virtual/logger
+       "
+
+DOCS=( CONTRIBUTORS DONATIONS UPGRADING )
+PATCHES=(
+       "${FILESDIR}/${PV}-bedup-conf-path.patch"
+       "${FILESDIR}/${PV}-tinfo.patch"
+       )
+
+pkg_setup() {
+       enewgroup "${PN}"
+       enewuser "${PN}" -1 "" "" "${PN}"
+}
+
+src_prepare() {
+       epatch "${PATCHES[@]}"
+       eautoreconf
+}
+
+src_configure() {
+       local myeconfargs=(
+               --sbindir=/usr/sbin
+               --sysconfdir=/etc/burp
+               --enable-largefile
+               $(use_with ssl openssl)
+               $(use_enable acl)
+               $(use_enable afs)
+               $(use_enable ipv6)
+               $(use_enable nls)
+               $(use_enable xattr)
+               $(use_with tcpd tcp-wrappers)
+       )
+       econf "${myeconfargs[@]}"
+}
+
+src_install() {
+       default
+
+       fowners root:burp /etc/burp /var/spool/burp
+       fperms 0775 /etc/burp /var/spool/burp
+       fowners root:burp /etc/burp/clientconfdir
+       fperms 0750 /etc/burp/clientconfdir
+       fowners root:burp /etc/burp/burp-server.conf
+       fperms 0640 /etc/burp/burp-server.conf
+
+       newinitd "${FILESDIR}"/${PN}.initd ${PN}
+       dodoc docs/*
+
+       sed -e 's|^# user=graham|user = burp|' \
+               -e 's|^# group=nogroup|group = burp|' \
+               -e 's|^pidfile = .*|lockfile = /run/lock/burp/server.lock|' \
+               -i "${D}"/etc/burp/burp-server.conf || die
+}
+
+pkg_postinst() {
+       if use ssl && [ ! -e /etc/burp/CA/index.txt ]; then
+               elog "At first run burp server will generate DH parameters and SSL"
+               elog "certificates.  You should adjust configuration before."
+               elog "Server configuration is located at"
+               elog ""
+               elog "  /etc/burp/burp-server.conf"
+               elog ""
+       fi
+}
diff --git a/app-backup/burp/files/1.4.40-bedup-conf-path.patch b/app-backup/burp/files/1.4.40-bedup-conf-path.patch
new file mode 100644 (file)
index 0000000..30346d4
--- /dev/null
@@ -0,0 +1,33 @@
+diff -Naur burp/manpages/bedup.8 burp.new/manpages/bedup.8
+--- burp/manpages/bedup.8      2014-10-28 12:45:26.000000000 +0100
++++ burp.new/manpages/bedup.8  2014-11-21 09:49:57.705796144 +0100
+@@ -16,7 +16,7 @@
+ .SH OPTIONS
+ .TP
+ \fB\-c\fR \fBpath\fR
+-Path to config file (default: /etc/burp/burp.conf).
++Path to config file (default: /etc/burp/burp-server.conf).
+ .TP
+ \fB\-g\fR \fB<list of group names>\fR
+ Only run on the directories of clients that are in one of the groups specified. The list is comma-separated. To put a client in a group, use the 'dedup_group' option in the client configuration file on the server.
+@@ -42,7 +42,7 @@
+ \fB\-V\fR \fB\fR
+ Print version and exit.\fR
+ .TP
+-By default, bedup will read /etc/burp/burp.conf and deduplicate client storage directories using special knowledge of the structure.\fR
++By default, bedup will read /etc/burp/burp-server.conf and deduplicate client storage directories using special knowledge of the structure.\fR
+ .TP
+ With '\-n', this knowledge is turned off and you have to specify the directories to deduplicate on the command line. Running with '\-n' is therefore dangerous if you are deduplicating burp storage directories.
+diff -Naur burp/src/bedup.c burp.new/src/bedup.c
+--- burp/src/bedup.c   2014-10-28 12:45:56.000000000 +0100
++++ burp.new/src/bedup.c       2014-11-20 21:39:28.728206536 +0100
+@@ -740,7 +740,7 @@
+ static char *get_config_path(void)
+ {
+         static char path[256]="";
+-        snprintf(path, sizeof(path), "%s", SYSCONFDIR "/burp.conf");
++        snprintf(path, sizeof(path), "%s", SYSCONFDIR "/burp-server.conf");
+         return path;
+ }
diff --git a/app-backup/burp/files/1.4.40-tinfo.patch b/app-backup/burp/files/1.4.40-tinfo.patch
new file mode 100644 (file)
index 0000000..0814922
--- /dev/null
@@ -0,0 +1,22 @@
+diff -Naur burp/configure.ac burp-new/configure.ac
+--- burp/configure.ac  2014-10-28 12:45:56.000000000 +0100
++++ burp-new/configure.ac      2014-11-10 17:40:50.996955441 +0100
+@@ -1203,13 +1203,12 @@
+ fi
+ AC_CHECK_HEADERS(ncurses.h)
+-AC_CHECK_LIB(ncurses, curs_set, [NCURSES_LIBS="-lncurses"])
+ have_ncurses=no
+-if test x$NCURSES_LIBS = x-lncurses; then
+-   AC_DEFINE(HAVE_NCURSES, 1, [Defined to 1 if libncurses was found])
+-   have_ncurses=yes
+-fi
+-AC_SUBST(NCURSES_LIBS)
++AC_CHECK_LIB(ncurses, endwin,
++      [NCURSES_LIBS="-lncurses"; have_ncurses=yes]
++      AC_SEARCH_LIBS(curs_set, tinfo, [NCURSES_LIBS="$NCURSES_LIBS $ac_res"]),
++      AC_DEFINE(HAVE_NCURSES, 1, [Defined to 1 if libncurses was found])
++      AC_SUBST(NCURSES_LIBS))
+ dnl
+ dnl Check if we have AFS on this system