sys-devel/clang-runtime: Remove USE=crt from 9+
authorMichał Górny <mgorny@gentoo.org>
Fri, 11 Oct 2019 13:46:39 +0000 (15:46 +0200)
committerMichał Górny <mgorny@gentoo.org>
Fri, 11 Oct 2019 14:13:35 +0000 (16:13 +0200)
Since LLVM 9.0.0, compiler-rt provides crt* objects.  The separate 'crt'
flag was provided only to let people choose whether they want to install
netbsd-csu on Linux.  Remove it and use USE=compiler-rt for both main
libs and crt.

Closes: https://bugs.gentoo.org/697468
Signed-off-by: Michał Górny <mgorny@gentoo.org>
sys-devel/clang-runtime/clang-runtime-10.0.0.9999.ebuild
sys-devel/clang-runtime/clang-runtime-9.0.0.9999.ebuild
sys-devel/clang-runtime/clang-runtime-9.0.0.ebuild

index 34bd6e203736a87bb6594daef9a064d334023ff7..806c398483be17a0e70555afe3d3f9dde83a9d9e 100644 (file)
@@ -12,7 +12,7 @@ SRC_URI=""
 LICENSE="metapackage"
 SLOT="$(ver_cut 1-3)"
 KEYWORDS=""
-IUSE="+compiler-rt crt libcxx openmp +sanitize"
+IUSE="+compiler-rt libcxx openmp +sanitize"
 REQUIRED_USE="sanitize? ( compiler-rt )"
 PROPERTIES="live"
 
@@ -21,11 +21,5 @@ RDEPEND="
                ~sys-libs/compiler-rt-${PV}:${SLOT}
                sanitize? ( ~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT} )
        )
-       crt? (
-               || (
-                       sys-libs/netbsd-csu[${MULTILIB_USEDEP}]
-                       sys-freebsd/freebsd-lib[${MULTILIB_USEDEP}]
-               )
-       )
        libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
        openmp? ( >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )"
index 34bd6e203736a87bb6594daef9a064d334023ff7..806c398483be17a0e70555afe3d3f9dde83a9d9e 100644 (file)
@@ -12,7 +12,7 @@ SRC_URI=""
 LICENSE="metapackage"
 SLOT="$(ver_cut 1-3)"
 KEYWORDS=""
-IUSE="+compiler-rt crt libcxx openmp +sanitize"
+IUSE="+compiler-rt libcxx openmp +sanitize"
 REQUIRED_USE="sanitize? ( compiler-rt )"
 PROPERTIES="live"
 
@@ -21,11 +21,5 @@ RDEPEND="
                ~sys-libs/compiler-rt-${PV}:${SLOT}
                sanitize? ( ~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT} )
        )
-       crt? (
-               || (
-                       sys-libs/netbsd-csu[${MULTILIB_USEDEP}]
-                       sys-freebsd/freebsd-lib[${MULTILIB_USEDEP}]
-               )
-       )
        libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
        openmp? ( >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )"
index 53fffbc04674a09a9c615d1e3da7d78d100736b8..ebd4556635e65a007b7fd6e0b05f1f7b774a89a9 100644 (file)
@@ -12,7 +12,7 @@ SRC_URI=""
 LICENSE="metapackage"
 SLOT="$(ver_cut 1-3)"
 KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-fbsd ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="+compiler-rt crt libcxx openmp +sanitize"
+IUSE="+compiler-rt libcxx openmp +sanitize"
 REQUIRED_USE="sanitize? ( compiler-rt )"
 
 RDEPEND="
@@ -20,11 +20,5 @@ RDEPEND="
                ~sys-libs/compiler-rt-${PV}:${SLOT}
                sanitize? ( ~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT} )
        )
-       crt? (
-               || (
-                       sys-libs/netbsd-csu[${MULTILIB_USEDEP}]
-                       sys-freebsd/freebsd-lib[${MULTILIB_USEDEP}]
-               )
-       )
        libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
        openmp? ( >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )"