dev-python/tld: 0.9.2 bump
authorBernard Cafarelli <voyageur@gentoo.org>
Mon, 14 Jan 2019 17:32:47 +0000 (18:32 +0100)
committerBernard Cafarelli <voyageur@gentoo.org>
Mon, 14 Jan 2019 17:32:47 +0000 (18:32 +0100)
Bugfixes and Python 3.7 support

Package-Manager: Portage-2.3.55, Repoman-2.3.12
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
dev-python/tld/Manifest
dev-python/tld/tld-0.9.2.ebuild [new file with mode: 0644]

index 5aacf2191a915963196ca831849c506ba379bb16..048f46354b9e767ff69e061e3c426e82d60300f1 100644 (file)
@@ -1,2 +1,3 @@
 DIST tld-0.7.10.tar.gz 242027 BLAKE2B b72d673ecf4753f95d0bf8403abb296eef67b7aeea7233e1b8e3ae262667a252d7cd5125c8cd3a11b5422eded604ccc3c86fd7d5ae1a500f926b9fd6464b9acf SHA512 e144f2eb037da482965636cb14c1d0bd91f66d9836f1ea0662b1a34d6760fba7784f26a398d0a1fe0ae4f15bc79372dfd92d94eb624b04955320813b08ab4968
 DIST tld-0.9.1.tar.gz 479262 BLAKE2B 908be345720b2e8131c89fac9fbbee7137674aa036b99076e60352b5ff37f682c3f5dcd8bf4bade58fffeeebeb6cbd2924042db9da383373ba4542639189e1d1 SHA512 167629fc1f837c12d8baeb83b032fe10291ba5444373b225eb73bab515e46efe5f29f83acd1eea07caa54d6b69fad8238d531867f1956c13243bc1908961a4cf
+DIST tld-0.9.2.tar.gz 562143 BLAKE2B 6b7f3c15127d2a97240054b3ee53c628ebf3f381399f7b4460879cd0034dae4f944e33950cafeaf36ab222b9578146564369c0401dc8066d8092bc00ebeb40c4 SHA512 72e829efa48fccb7f8f771f7b84e98d7f38de8f214c26d25741448981de432bbe09f3dac646779135a74c8f3fd0669e3c371d2136e5edc3c2e3750fd5d5631dd
diff --git a/dev-python/tld/tld-0.9.2.ebuild b/dev-python/tld/tld-0.9.2.ebuild
new file mode 100644 (file)
index 0000000..13ac655
--- /dev/null
@@ -0,0 +1,20 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Extract the top level domain (TLD) from the URL given"
+HOMEPAGE="https://github.com/barseghyanartur/tld"
+SRC_URI="https://github.com/barseghyanartur/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""