dev-python/dogpile-cache: 0.7.1 bump
authorMatthew Thode <prometheanfire@gentoo.org>
Tue, 9 Apr 2019 03:30:59 +0000 (22:30 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Tue, 9 Apr 2019 07:04:37 +0000 (02:04 -0500)
Package-Manager: Portage-2.3.62, Repoman-2.3.12
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
dev-python/dogpile-cache/Manifest
dev-python/dogpile-cache/dogpile-cache-0.7.1.ebuild [new file with mode: 0644]

index a90153d71d3a2c84362785348d90e081651ff9fd..8bdcb0bc1a61a0204cdb99ef2aeca2626cb04658 100644 (file)
@@ -1 +1,2 @@
 DIST dogpile.cache-0.6.4.tar.gz 315533 BLAKE2B 92848b82d923c6d19bc3aa7f0f1c399f8d7131bc308a79686269e904520e6b690c8d78a3c715e3e9153f81f1478bbb6e82ed6caad60a791e2488b023f1fe3d8c SHA512 0e86ed6aacbfbbbefdc3622ac956679c4986c77989daa3c3e845d4b8dbbf7945b4d0764789f03540b2ff59712e2ee86c8283cc3ee8d9e950f9ef1772db7ea137
+DIST dogpile.cache-0.7.1.tar.gz 326127 BLAKE2B 358391033d1d22b2711052f1aa3003c0c5f2da42b33b3f4fbb2d582418b0b42695db5df638dabcb9ba81ba414d142ac7f52a6c80ea645f5fcba12ca21122a495 SHA512 39c0a1d3d5027bc61cc69eda46c846c72d09892b2de0ea2e9545b1f710911dce8726b4ee4a0daef0d3c409a16733920d437f6e833a5b3f55ccc80267bb0da39c
diff --git a/dev-python/dogpile-cache/dogpile-cache-0.7.1.ebuild b/dev-python/dogpile-cache/dogpile-cache-0.7.1.ebuild
new file mode 100644 (file)
index 0000000..27d7bd1
--- /dev/null
@@ -0,0 +1,30 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A locking API for expiring values while a single thread generates a new value."
+HOMEPAGE="https://bitbucket.org/zzzeek/dogpile.cache"
+SRC_URI="mirror://pypi/${PN:0:1}/dogpile.cache/dogpile.cache-${PV}.tar.gz"
+S="${WORKDIR}/dogpile.cache-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+               test? ( dev-python/pytest[${PYTHON_USEDEP}]
+                               dev-python/pytest-cov[${PYTHON_USEDEP}]
+                               dev-python/mock[${PYTHON_USEDEP}]
+                               dev-python/mako[${PYTHON_USEDEP}] )"
+
+# This time half the doc files are missing; Do you want them? toss a coin
+
+python_test() {
+       "${EPYTHON}" ./setup.py test || die "test failed under ${EPYTHON}"
+}