dev-python/prometheus_client-0.6.0-r1: revbump add py38 (0.6.0 series)
authorPatrick McLean <patrick.mclean@sony.com>
Thu, 13 Feb 2020 23:29:49 +0000 (15:29 -0800)
committerPatrick McLean <chutzpah@gentoo.org>
Thu, 13 Feb 2020 23:29:49 +0000 (15:29 -0800)
Copyright: Sony Interactive Entertainment Inc.
Package-Manager: Portage-2.3.88, Repoman-2.3.20
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
dev-python/prometheus_client/prometheus_client-0.6.0-r1.ebuild [new file with mode: 0644]

diff --git a/dev-python/prometheus_client/prometheus_client-0.6.0-r1.ebuild b/dev-python/prometheus_client/prometheus_client-0.6.0-r1.ebuild
new file mode 100644 (file)
index 0000000..55559cf
--- /dev/null
@@ -0,0 +1,21 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_6,3_7,3_8} )
+inherit distutils-r1
+
+DESCRIPTION="Python client for the Prometheus monitoring system"
+HOMEPAGE="https://pypi.org/project/prometheus_client/
+       https://github.com/prometheus/client_python"
+SRC_URI="https://github.com/prometheus/client_python/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/client_python-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-python/twisted[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest