sci-libs/pyshp: Version bump, add py3.7 and 3.8
authorThomas Beierlein <tomjbe@gentoo.org>
Wed, 22 Apr 2020 16:22:43 +0000 (18:22 +0200)
committerThomas Beierlein <tomjbe@gentoo.org>
Wed, 22 Apr 2020 20:41:31 +0000 (22:41 +0200)
Take maintainership of the package.

Closes: https://bugs.gentoo.org/718500
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Thomas Beierlein <tomjbe@gentoo.org>
sci-libs/pyshp/Manifest
sci-libs/pyshp/metadata.xml
sci-libs/pyshp/pyshp-2.1.0.ebuild [new file with mode: 0644]

index 6ae88c063bd63636c296e66f3731cbf9ff5092d2..4c844169a6806a27b3402e4dfc5c52d5a1b5610f 100644 (file)
@@ -1 +1,2 @@
 DIST pyshp-1.2.0.tar.gz 58993 BLAKE2B f7cb69976b6dd089be45d7984765f803ce94300dc19df1b99a11ba876365f49659fb37a5ebfa36ebe3ce6de4df9f0b80f628160ace9b11a66a247f9a57ac0a80 SHA512 c77e19f258ba9d2e2c480b82c342d2bbeae4b5855627aa98777fbf590e904d50045edecaa0e5ec2e03ddaaf49bf7261944fb77bcd26bf6d21e50c90c30cd0b43
+DIST pyshp-2.1.0.tar.gz 215360 BLAKE2B 2b32a3db242b90f801abdbc31f3c930bc40c3ad0606433d90f62c6b9af3c0459e8c8467d60aec1075368779e5a4fffa9e3985e1875d82edf732faf982359c605 SHA512 ab0c7832f7e480ec3cdbf94ec29f84b590486625bde3d5cf465e5dc6ddca02998b99510b6c14d5ba005816c5b091044badc1e68988fd971f9e18266096ad86cb
index 512ca5c34a9e70d1b2430cc91201072043f0f414..3da8982993cc6d91037258e1f53b228bbf221594 100644 (file)
@@ -1,7 +1,10 @@
 <?xml version="1.0" encoding="UTF-8"?>
 <!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
 <pkgmetadata>
-  <!-- maintainer-needed -->
+  <maintainer type="person">
+    <email>tomjbe@gentoo.org</email>
+    <name>Thomas Beierlein</name>
+  </maintainer>
   <upstream>
     <remote-id type="pypi">pyshp</remote-id>
   </upstream>
diff --git a/sci-libs/pyshp/pyshp-2.1.0.ebuild b/sci-libs/pyshp/pyshp-2.1.0.ebuild
new file mode 100644 (file)
index 0000000..5499cd1
--- /dev/null
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit distutils-r1
+
+DESCRIPTION="Pure Python read/write support for ESRI Shapefile format"
+HOMEPAGE="https://pypi.org/project/pyshp/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+       dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+       "${EPYTHON}" shapefile.py || die
+}