dev-perl/Pod-Tests: Add build fix for Perl 5.26, bug 623076
authorAndreas K. Hüttel <dilfridge@gentoo.org>
Sun, 2 Jul 2017 15:25:25 +0000 (17:25 +0200)
committerAndreas K. Hüttel <dilfridge@gentoo.org>
Sun, 2 Jul 2017 15:25:25 +0000 (17:25 +0200)
Package-Manager: Portage-2.3.6, Repoman-2.3.2

dev-perl/Pod-Tests/Pod-Tests-1.190.0-r1.ebuild

index 8b3d49e6f884e237e3abc80561fb199171593bfb..ca9f05940b4c0be3311d5401f16781973541ff50 100644 (file)
@@ -1,10 +1,10 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=5
+EAPI=6
 
-MODULE_AUTHOR=ADAMK
-MODULE_VERSION=1.19
+DIST_AUTHOR=ADAMK
+DIST_VERSION=1.19
 inherit perl-module
 
 DESCRIPTION="Extracts embedded tests and code examples from POD"
@@ -16,4 +16,8 @@ IUSE=""
 RDEPEND="virtual/perl-File-Spec"
 DEPEND="${RDEPEND}"
 
-SRC_TEST="do"
+src_prepare() {
+       sed -i -e 's/use inc::Module::Install/use lib q[.]; use inc::Module::Install/' Makefile.PL ||
+               die "Can't patch Makefile.PL for 5.26 dot-in-inc"
+       perl-module_src_prepare
+}