app-admin/filebeat: bump to 7.4.1
authorTomas Mozes <hydrapolic@gmail.com>
Fri, 25 Oct 2019 16:41:18 +0000 (16:41 +0000)
committerJoonas Niilola <juippis@gentoo.org>
Tue, 29 Oct 2019 06:53:27 +0000 (08:53 +0200)
Closes: https://bugs.gentoo.org/695328
Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com>
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
app-admin/filebeat/Manifest
app-admin/filebeat/filebeat-6.8.4.ebuild
app-admin/filebeat/filebeat-7.4.1.ebuild [new file with mode: 0644]

index a2881a00b2976561a9ce3081dcfab29246609d76..bb36b2b166131d55fc6dfc7df09147bf3720227e 100644 (file)
@@ -8,3 +8,4 @@ DIST filebeat-6.8.3.tar.gz 35551301 BLAKE2B ec33f0a5812e355bf2a9212daff999dfed86
 DIST filebeat-6.8.4.tar.gz 35552503 BLAKE2B 165edceffa71318d77363e4e8e737663eb45e5c3d20148dffd8111187eb3d07eb7998c068b3a3da315ff582f7687d75183ae9828f8b9c87d0c025d450936e00d SHA512 4739481a2ec0307804b797369050b81668f531793bdd1c72304b963e8ab4662b40820dfab211c7fdeeef5deb431f5a0e6ef2680841b4748d352ee8724b2bac42
 DIST filebeat-7.2.0.tar.gz 46415588 BLAKE2B a8940e9a4a85e6eac79dca3418d3dcd14c5a1062741dd895c561d1498c287bb974a5ac89d5b353dbb75e78e6c67cba97a08d41528042db4e4d76bb46016fac60 SHA512 67d251cabca10a1f6d392be8e6203e66d4cf5d63ceb2af88185ea4824259995dafd3aa8dd2da326d079cfcfedce5996f173cd6c50972db67cbe25f660683e5d1
 DIST filebeat-7.3.2.tar.gz 49977990 BLAKE2B 6219a382b415572fdea2ff4b0aa3f02b3c1e500d77ed5200b6d5b4334a08b8e91d389ea41b3afe98355f8b20e7f8ecaccf5996f0bb7aad5f10e0f0d69400a0d6 SHA512 75943b251343d28f478f2f19665e4ba31f5bc6e4b26f6e6da8aa062322da4ab8e134c87a9557a97677ba3b22484c44ebaeaeeb87866e0f12e67f1647fe34131a
+DIST filebeat-7.4.1.tar.gz 59665819 BLAKE2B 5af538d317713d42d79d43b58344149980d4bf07b99ea6e6b29562cbce8e221f067881b85a78e4b6dee4973f42aaca1108e4941b1c3041df6162885a7c49d57f SHA512 917942f2434ed09ccc998e75d4272ff03ed1536bfa8c7f09d48f11bccdbe0315d298bc3aeab3c66be3ac3d9fabac506c8b797aa4560dceb7f1978ac420d35696
index 0c71f0e08435c2ac176d14290db7be02c66abe56..916728450cc4bc51b32ea710326ea3faa289b6d2 100644 (file)
@@ -7,7 +7,7 @@ DESCRIPTION="Lightweight log shipper for Logstash and Elasticsearch"
 HOMEPAGE="https://www.elastic.co/products/beats"
 SRC_URI="https://github.com/elastic/beats/archive/v${PV}.tar.gz -> ${P}.tar.gz"
 
-LICENSE="Apache-2.0"
+LICENSE="Apache-2.0 BSD-2 MIT"
 SLOT="0"
 KEYWORDS="~amd64 ~x86"
 RESTRICT="test"
diff --git a/app-admin/filebeat/filebeat-7.4.1.ebuild b/app-admin/filebeat/filebeat-7.4.1.ebuild
new file mode 100644 (file)
index 0000000..9167284
--- /dev/null
@@ -0,0 +1,67 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Lightweight log shipper for Logstash and Elasticsearch"
+HOMEPAGE="https://www.elastic.co/products/beats"
+SRC_URI="https://github.com/elastic/beats/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD-2 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test"
+
+DEPEND=">=dev-lang/go-1.12.9"
+RDEPEND="!app-admin/filebeat-bin"
+
+# Do not complain about CFLAGS etc since go projects do not use them.
+QA_FLAGS_IGNORED='.*'
+
+S="${WORKDIR}/src/github.com/elastic/beats"
+
+src_unpack() {
+       mkdir -p "${S%/*}" || die
+       default
+       mv beats-${PV} "${S}" || die
+}
+
+src_prepare() {
+       default
+
+       # avoid Elastic license
+       rm -r x-pack || die
+
+       # use ${PV} instead of git commit id
+       sed -i "s/\(COMMIT_ID=\).*/\1${PV}/g" "${S}/libbeat/scripts/Makefile" || die
+}
+
+src_compile() {
+       GOPATH="${WORKDIR}" emake -C "${S}/filebeat"
+}
+
+src_install() {
+       keepdir /etc/${PN}
+       keepdir /var/{lib,log}/${PN}
+
+       fperms 0750 /var/{lib,log}/${PN}
+
+       newconfd "${FILESDIR}/${PN}.confd" ${PN}
+       newinitd "${FILESDIR}/${PN}.initd.1" ${PN}
+
+       docinto examples
+       dodoc ${PN}/{filebeat.yml,filebeat.reference.yml}
+
+       dobin filebeat/filebeat
+}
+
+pkg_postinst() {
+       if [[ -n "${REPLACING_VERSIONS}" ]]; then
+               elog "Please read the migration guide at:"
+               elog "https://www.elastic.co/guide/en/beats/libbeat/$(ver_cut 1-2)/upgrading.html"
+               elog ""
+       fi
+
+       elog "Example configurations:"
+       elog "${EROOT}/usr/share/doc/${PF}/examples"
+}