net-misc/openconnect: Make CONFIG_TUN check non-fatal
authorMike Gilbert <floppym@gentoo.org>
Wed, 2 Sep 2015 14:40:50 +0000 (10:40 -0400)
committerMike Gilbert <floppym@gentoo.org>
Wed, 2 Sep 2015 14:42:56 +0000 (10:42 -0400)
Also move the check to pkg_pretend, and remove the custom error messaging.

Package-Manager: portage-2.2.20

net-misc/openconnect/metadata.xml
net-misc/openconnect/openconnect-7.06-r1.ebuild

index 4b425f03961bf440601a7bc4f75f82d9471cb94f..7030dec29348518cc205faabdfa42ad1a38d4073 100644 (file)
@@ -8,7 +8,7 @@
        <maintainer>
                <email>mattsch@gmail.com</email>
                <name>Matthew Schultz</name>
-               <description>Proxied maintainer. Assign bugs to him.</description>
+               <description>Proxied maintainer. Copy on bugs.</description>
        </maintainer>
        <use>
                <flag name='gssapi'>Build GSSAPI support.</flag>
index ab33ab3a05cb3e7c3c80e3b1338785fbc5171c0f..76711e28543a28892b81f0b3deeca76810e2d14c 100644 (file)
@@ -45,19 +45,10 @@ DEPEND="${DEPEND}
        java? ( >=virtual/jdk-1.6 )
        nls? ( sys-devel/gettext )"
 
-tun_tap_check() {
-       ebegin "Checking for TUN/TAP support"
-       if { ! linux_chkconfig_present TUN; }; then
-               eerror "Please enable TUN/TAP support in your kernel config, found at:"
-               eerror
-               eerror "  Device Drivers  --->"
-               eerror "    [*] Network device support  --->"
-               eerror "      <*>   Universal TUN/TAP device driver support"
-               eerror
-               eerror "and recompile your kernel ..."
-               die "no CONFIG_TUN support detected!"
-       fi
-       eend $?
+CONFIG_CHECK="~TUN"
+
+pkg_pretend() {
+       check_extra_config
 }
 
 pkg_setup() {
@@ -66,19 +57,6 @@ pkg_setup() {
        if use doc; then
                python-any-r1_pkg_setup
        fi
-
-       if use kernel_linux; then
-               get_version
-               if linux_config_exists; then
-                       tun_tap_check
-               else
-                       ewarn "Was unable to determine your kernel .config"
-                       ewarn "Please note that OpenConnect requires CONFIG_TUN to be set in your"
-                       ewarn "kernel .config, Without it, it will not work correctly."
-                       # We don't die here, so it's possible to compile this package without
-                       # kernel sources available. Required for cross-compilation.
-               fi
-       fi
 }
 
 src_configure() {