dev-php/pecl-redis: Version bump for 4.0.2
authorBrian Evans <grknight@gentoo.org>
Wed, 9 May 2018 13:50:42 +0000 (09:50 -0400)
committerBrian Evans <grknight@gentoo.org>
Wed, 9 May 2018 13:51:56 +0000 (09:51 -0400)
Package-Manager: Portage-2.3.36, Repoman-2.3.9

dev-php/pecl-redis/Manifest
dev-php/pecl-redis/pecl-redis-4.0.2.ebuild [new file with mode: 0644]

index f3b0fdf84cade4b0b9aeb02c5e860bc166b898f7..c0b5bad4943cc2f1ffbdb4c169dccb67e119821c 100644 (file)
@@ -1,2 +1,3 @@
 DIST redis-3.1.6.tgz 199920 BLAKE2B 00aa81cdbedc03b4a672a58be98d8f01d2076038622b9d1e9673c0628c096152f12f9f5ff540af639da73b4458fcb1fce9c1c8b49a95db48970bab07806ac8d0 SHA512 4263d150c93f11dd06587925ad9a3cd8fbba2e4a18b2f23e6adfaeb25d566a1c2d256551a50ae1b9c770fd0f9bc4c92f483c46d60be9d4f5b5ba056231b7d527
 DIST redis-4.0.0.tgz 212340 BLAKE2B 996138b3dd92e839fbebaf5d562cfbe90e66384233c83612c8726fa41f10c106d0195c87449fc7886b3e832fd551b962ef50c161372c04c899c9fe7fd1140101 SHA512 e4bf2294f696e468174c0fff9ed33831cf81c3548ce30ede01bc3c45a15cb87b9b9ea02899c451f63211be8cb37e953be138e93c16d9e0f12772b7b6d03e8dcd
+DIST redis-4.0.2.tgz 212617 BLAKE2B 5778cf08e93fe8343e8fa07f1314c39b2d6d9a150d70c5b2084274afb163f1132a4be81385563f74d3b1d8f2dc32bf6578e98a123b43a941635fd85ebb229771 SHA512 3b296926ddd6a69a4d633da8bf6257c9b2962dffb4dd38c20eaf821a8c64262b476a7fb10ab4412ceb2d1307aef26c3d1d4b72141d29dab262d521a08df13a6a
diff --git a/dev-php/pecl-redis/pecl-redis-4.0.2.ebuild b/dev-php/pecl-redis/pecl-redis-4.0.2.ebuild
new file mode 100644 (file)
index 0000000..7c75c71
--- /dev/null
@@ -0,0 +1,58 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PHP_EXT_NAME="redis"
+USE_PHP="php5-6 php7-0 php7-1 php7-2"
+DOCS=( arrays.markdown cluster.markdown README.markdown CREDITS )
+MY_P="${PN/pecl-/}-${PV/_rc/RC}"
+PHP_EXT_PECL_FILENAME="${MY_P}.tgz"
+PHP_EXT_S="${WORKDIR}/${MY_P}"
+
+inherit php-ext-pecl-r3
+
+DESCRIPTION="PHP extension for interfacing with Redis"
+LICENSE="PHP-3.01"
+SLOT="0"
+KEYWORDS="~amd64 ~arm"
+IUSE="igbinary +session"
+
+DEPEND="
+       php_targets_php5-6? ( dev-lang/php:5.6[session?] igbinary? ( dev-php/igbinary[php_targets_php5-6] ) )
+       php_targets_php7-0? ( dev-lang/php:7.0[session?] igbinary? ( dev-php/igbinary[php_targets_php7-0] ) )
+       php_targets_php7-1? ( dev-lang/php:7.1[session?] igbinary? ( dev-php/igbinary[php_targets_php7-1] ) )
+       php_targets_php7-2? ( dev-lang/php:7.2[session?] igbinary? ( dev-php/igbinary[php_targets_php7-2] ) )
+"
+RDEPEND="${DEPEND} !dev-php/pecl-redis:7"
+
+# The test suite requires network access.
+RESTRICT=test
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+       local PHP_EXT_ECONF_ARGS=(
+               --enable-redis
+               $(use_enable igbinary redis-igbinary)
+               $(use_enable session redis-session)
+       )
+       php-ext-source-r3_src_configure
+}
+
+src_test(){
+       local slot
+       for slot in $(php_get_slots); do
+               php_init_slot_env "${slot}"
+               # Run tests for Redis class
+               ${PHPCLI} -d extension=modules/redis.so \
+                                 tests/TestRedis.php \
+                                 --class Redis \
+                                 --host ${PECL_REDIS_HOST} || die 'test suite failed'
+       done
+}
+
+pkg_postinst() {
+       elog "The 4.0 release comes with breaking API changes."
+       elog "Be sure to verify any applications upon upgrading."
+}