app-editors/kakoune-9999: add GCC version check
authorMykyta Holubakha <hilobakho@gmail.com>
Sat, 27 Aug 2016 20:40:08 +0000 (23:40 +0300)
committerGöktürk Yüksek <gokturk@gentoo.org>
Thu, 1 Sep 2016 03:20:23 +0000 (23:20 -0400)
correct usage of pkg-config

app-editors/kakoune/kakoune-9999.ebuild

index aec9313a2beee95417c4defa98f07b167960722e..cee92150dfc9a8a54869effb5a429e8eb15c85f9 100644 (file)
@@ -4,7 +4,7 @@
 
 EAPI=6
 
-inherit flag-o-matic toolchain-funcs git-r3
+inherit flag-o-matic toolchain-funcs git-r3 versionator
 
 DESCRIPTION="Selection-oriented code editor inspired by vim"
 HOMEPAGE="https://github.com/mawww/kakoune"
@@ -17,7 +17,7 @@ IUSE="debug"
 
 RDEPEND="
        sys-libs/ncurses:=[unicode]
-       dev-libs/boost
+       dev-libs/boost:=
 "
 DEPEND="
        app-text/asciidoc
@@ -27,9 +27,17 @@ DEPEND="
 
 PATCHES=( "${FILESDIR}/${PN}-makefile.patch" )
 
+pkg_pretend() {
+       if [[ ${MERGE_TYPE} != binary ]]; then
+               if tc-is-gcc && ! version_is_at_least 5.0 $(gcc-version); then
+                       die "Clang or GCC >=5.0 is required to build this version"
+               fi
+       fi
+}
+
 src_configure() {
-       append-cppflags $(pkg-config --cflags ncursesw)
-       append-libs $(pkg-config --libs ncursesw)
+       append-cppflags $($(tc-getPKG_CONFIG) --cflags ncursesw)
+       append-libs $($(tc-getPKG_CONFIG) --libs ncursesw)
        export CXX=$(tc-getCXX)
        export debug=$(usex debug)
        S="${WORKDIR}/${P}/src"