Pass --disable-lookup option to configure, to prevent ike-scan from phoning home...
authorMarcelo Góes <vanquirius@gentoo.org>
Sat, 9 Dec 2006 04:59:46 +0000 (04:59 +0000)
committerMarcelo Góes <vanquirius@gentoo.org>
Sat, 9 Dec 2006 04:59:46 +0000 (04:59 +0000)
Package-Manager: portage-2.1.1-r2

net-analyzer/ike-scan/ChangeLog
net-analyzer/ike-scan/files/digest-ike-scan-1.8-r1 [new file with mode: 0644]
net-analyzer/ike-scan/ike-scan-1.8-r1.ebuild [new file with mode: 0644]

index 8b024e7e4827f87386a326f0393b96fe5e6d6c06..feaab90309ac8aa4ed6c3e922fc98210e618f5b7 100644 (file)
@@ -1,6 +1,14 @@
 # ChangeLog for net-analyzer/ike-scan
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ike-scan/ChangeLog,v 1.4 2006/03/05 20:44:18 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ike-scan/ChangeLog,v 1.5 2006/12/09 04:59:46 vanquirius Exp $
+
+*ike-scan-1.8-r1 (09 Dec 2006)
+
+  09 Dec 2006; Marcelo Goes <vanquirius@gentoo.org> -ike-scan-1.7.ebuild,
+  -ike-scan-1.8.ebuild, +ike-scan-1.8-r1.ebuild:
+  Pass --disable-lookup option to configure, to prevent ike-scan from phoning
+  home. Fixes bug 157507, reported by Richard van den Berg <richard at vdberg
+  dot org>.
 
   05 Mar 2006; Markus Ullmann <jokey@gentoo.org> ike-scan-1.7.ebuild:
   INSTALL cleanup
diff --git a/net-analyzer/ike-scan/files/digest-ike-scan-1.8-r1 b/net-analyzer/ike-scan/files/digest-ike-scan-1.8-r1
new file mode 100644 (file)
index 0000000..b1a7a0e
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 961310e6f3c07d26c90447e392dfb97e ike-scan-1.8.tar.gz 1376995
+RMD160 25a55ef2679c5d42ab979d7b22e6ed0af33834b6 ike-scan-1.8.tar.gz 1376995
+SHA256 fc7b4aea32e4cf577411237410323c8bc327f65e54b88184b1a85118d79c918c ike-scan-1.8.tar.gz 1376995
diff --git a/net-analyzer/ike-scan/ike-scan-1.8-r1.ebuild b/net-analyzer/ike-scan/ike-scan-1.8-r1.ebuild
new file mode 100644 (file)
index 0000000..84c2c9a
--- /dev/null
@@ -0,0 +1,28 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ike-scan/ike-scan-1.8-r1.ebuild,v 1.1 2006/12/09 04:59:46 vanquirius Exp $
+
+DESCRIPTION="A utility for finding, fingerprinting and testing IKE VPN servers"
+HOMEPAGE="http://www.nta-monitor.com/ike-scan/"
+SRC_URI="http://www.nta-monitor.com/ike-scan/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE="ssl"
+
+DEPEND="virtual/libc
+       ssl? ( dev-libs/openssl )"
+
+src_compile() {
+       # --disable-lookup prevents ike-scan from phoning home
+       # for more information, please see bug 157507
+       econf $(use_with ssl openssl) --disable-lookup || die
+       emake || die
+}
+
+src_install() {
+       emake DESTDIR="${D}" install || die
+       dodoc ChangeLog NEWS README TODO
+       dodoc udp-backoff-fingerprinting-paper.txt
+}