x11-drivers/xf86-video-ati: Add patch for GCC-10
authorMatt Turner <mattst88@gentoo.org>
Fri, 1 May 2020 18:48:58 +0000 (11:48 -0700)
committerMatt Turner <mattst88@gentoo.org>
Fri, 1 May 2020 18:54:34 +0000 (11:54 -0700)
Closes: https://bugs.gentoo.org/720266
Signed-off-by: Matt Turner <mattst88@gentoo.org>
x11-drivers/xf86-video-ati/files/xf86-video-ati-19.1.0-Fix-link-failure-with-gcc-10.patch [new file with mode: 0644]
x11-drivers/xf86-video-ati/xf86-video-ati-19.1.0.ebuild

diff --git a/x11-drivers/xf86-video-ati/files/xf86-video-ati-19.1.0-Fix-link-failure-with-gcc-10.patch b/x11-drivers/xf86-video-ati/files/xf86-video-ati-19.1.0-Fix-link-failure-with-gcc-10.patch
new file mode 100644 (file)
index 0000000..e0375b0
--- /dev/null
@@ -0,0 +1,33 @@
+From f223035f4ffcff2a9296d1e907a5193f8e8845a3 Mon Sep 17 00:00:00 2001
+From: Adam Jackson <ajax@redhat.com>
+Date: Tue, 4 Feb 2020 16:38:06 -0500
+Subject: [PATCH] Fix link failure with gcc 10
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Without the 'extern' this looks like a definition not just a
+declaration, in every file that includes the header. gcc 10 is stricter
+about this kind of multiple definition.
+
+Reviewed-by: Michel Dänzer <mdaenzer@redhat.com>
+---
+ src/drmmode_display.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/drmmode_display.h b/src/drmmode_display.h
+index 96eaef0a..8cd8a0a6 100644
+--- a/src/drmmode_display.h
++++ b/src/drmmode_display.h
+@@ -262,7 +262,7 @@ Bool drmmode_wait_vblank(xf86CrtcPtr crtc, drmVBlankSeqType type,
+                        uint64_t *ust, uint32_t *result_seq);
+-miPointerSpriteFuncRec drmmode_sprite_funcs;
++extern miPointerSpriteFuncRec drmmode_sprite_funcs;
+ #endif
+-- 
+2.26.2
+
index f0b151ac4acab4daa8763291fde85b3b00f3cd48..5350c72cb7410411d8ddd5e245e332ab9edc5b94 100644 (file)
@@ -24,6 +24,10 @@ RDEPEND=">=x11-libs/libdrm-2.4.89[video_cards_radeon]
 DEPEND="${RDEPEND}
        x11-base/xorg-proto"
 
+PATCHES=(
+       "${FILESDIR}"/${P}-Fix-link-failure-with-gcc-10.patch
+)
+
 pkg_pretend() {
        if use kernel_linux ; then
                if kernel_is -ge 3 9; then