net-misc/ntpsec: version bump to 1.1.8, bug #703618
authorAnthony G. Basile <blueness@gentoo.org>
Mon, 23 Dec 2019 20:51:48 +0000 (15:51 -0500)
committerAnthony G. Basile <blueness@gentoo.org>
Mon, 23 Dec 2019 20:51:48 +0000 (15:51 -0500)
Package-Manager: Portage-2.3.79, Repoman-2.3.16
Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
net-misc/ntpsec/Manifest
net-misc/ntpsec/ntpsec-1.1.8.ebuild [new file with mode: 0644]

index 31d78e746ff8038b0eb82dda0f80e355328af44f..3989a106bbaac25687f059261e13b2b25def9c3f 100644 (file)
@@ -1,3 +1,4 @@
 DIST ntpsec-1.1.4.tar.gz 2536268 BLAKE2B 320e7afee1b776e0327f8bf34bc0b8cd3a2c67fd9fd16564323ce825cb9e36d7d5fb48a38b734600286cbd039f41f296d9e488e25d2680f08412aa983101987b SHA512 1b74e7cb87e189137e1b66b52ce89498e0061a10abf017c36bfdecb4aefe9c3fb6e8fd7819a9f822fb946dca6ae20ee724b2aed35e03d73f8e3015d8818d02db
 DIST ntpsec-1.1.6.tar.gz 2600632 BLAKE2B 1ee3e266f9a0ff45fc8f001a2b5a1722c6acf75a2151ee3724812acef3409eccbb865b321a3a346c7ced1770aa24190281a94593b881b4bbb0a2b2e6df5629cc SHA512 f57fde6f329a858313968798d64df5e93d7eba43edf4752cd0eb45ff1a2237ce2731b4603ec997c493dea85edb42976f96eb1508beae087a8c2ae8a76c0a6941
 DIST ntpsec-1.1.7.tar.gz 2534524 BLAKE2B 5777ecca4ceb988632fadc0e7124530993a7758cdf335e8cd90f0ec1a8b643be89b67c0e2bf49d6d7193bf92ded138af0df4b5856c0d113f552ef22dd8a6cadf SHA512 734b12820539e655e504dd5071a58b9d1f80c0b0c3c7458c797ba7ada23d8e446751fbcbddd9832d9151a3ba9464749878db9e77e23cdd5f6215ab9e1d908ae9
+DIST ntpsec-1.1.8.tar.gz 2589363 BLAKE2B e7e11a7d980599ac598f084608160d3f6f6cf8e2aab5fb45cc15cabca30462bd03db7b9ecc140826c5d7b5e26f49b48f7f2b6043bdc2ffa1d73167347fb8123f SHA512 0920f25adf68f1b8ccd1734c5d61ba1c858cd86b342db7b5155dd9b58e538aa96aad3fd4058597f079ec3df63cb51d2900ac8e6d9c84d6f2bd4a3a22cc0c967c
diff --git a/net-misc/ntpsec/ntpsec-1.1.8.ebuild b/net-misc/ntpsec/ntpsec-1.1.8.ebuild
new file mode 100644 (file)
index 0000000..0d9f22d
--- /dev/null
@@ -0,0 +1,159 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{5,6} )
+PYTHON_REQ_USE='threads(+)'
+
+inherit flag-o-matic python-r1 waf-utils systemd
+
+if [[ ${PV} == *9999* ]]; then
+       inherit git-r3
+       EGIT_REPO_URI="https://gitlab.com/NTPsec/ntpsec.git"
+       BDEPEND=""
+       KEYWORDS=""
+else
+       SRC_URI="ftp://ftp.ntpsec.org/pub/releases/${PN}-${PV}.tar.gz"
+       RESTRICT="mirror"
+       BDEPEND=""
+       KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+DESCRIPTION="The NTP reference implementation, refactored"
+HOMEPAGE="https://www.ntpsec.org/"
+
+NTPSEC_REFCLOCK=(
+       oncore trimble truetime gpsd jjy generic spectracom
+       shm pps hpgps zyfer arbiter nmea neoclock modem
+       local)
+
+IUSE_NTPSEC_REFCLOCK=${NTPSEC_REFCLOCK[@]/#/rclock_}
+
+LICENSE="HPND MIT BSD-2 BSD CC-BY-SA-4.0"
+SLOT="0"
+IUSE="${IUSE_NTPSEC_REFCLOCK} debug doc early gdb heat libbsd nist ntpviz samba seccomp smear tests" #ionice
+REQUIRED_USE="${PYTHON_REQUIRED_USE} nist? ( rclock_local )"
+
+# net-misc/pps-tools oncore,pps
+CDEPEND="${PYTHON_DEPS}
+       ${BDEPEND}
+       sys-libs/libcap
+       dev-python/psutil[${PYTHON_USEDEP}]
+       libbsd? ( dev-libs/libbsd:0= )
+       dev-libs/openssl:0=
+       seccomp? ( sys-libs/libseccomp )
+"
+RDEPEND="${CDEPEND}
+       ntpviz? ( sci-visualization/gnuplot media-fonts/liberation-fonts )
+       !net-misc/ntp
+       !net-misc/openntpd
+       acct-group/ntp
+       acct-user/ntp
+"
+DEPEND="${CDEPEND}
+       app-text/asciidoc
+       dev-libs/libxslt
+       app-text/docbook-xsl-stylesheets
+       sys-devel/bison
+       rclock_oncore? ( net-misc/pps-tools )
+       rclock_pps? ( net-misc/pps-tools )
+"
+
+WAF_BINARY="${S}/waf"
+
+src_prepare() {
+       default
+       # Remove autostripping of binaries
+       sed -i -e '/Strip binaries/d' wscript
+       if ! use libbsd ; then
+               epatch "${FILESDIR}/${PN}-no-bsd.patch"
+       fi
+       python_copy_sources
+}
+
+src_configure() {
+       is-flagq -flto* && filter-flags -flto* -fuse-linker-plugin
+
+       local string_127=""
+       local rclocks="";
+       local CLOCKSTRING=""
+
+       for refclock in ${NTPSEC_REFCLOCK[@]} ; do
+               if use rclock_${refclock} ; then
+                       string_127+="$refclock,"
+               fi
+       done
+       CLOCKSTRING="`echo ${string_127}|sed 's|,$||'`"
+
+       local myconf=(
+               --nopyc
+               --nopyo
+               --refclock="${CLOCKSTRING}"
+               --build-epoch="$(date +%s)"
+               $(use doc       && echo "--enable-doc")
+               $(use early     && echo "--enable-early-droproot")
+               $(use gdb       && echo "--enable-debug-gdb")
+               $(use samba     && echo "--enable-mssntp")
+               $(use seccomp   && echo "--enable-seccomp")
+               $(use smear     && echo "--enable-leap-smear")
+               $(use tests     && echo "--alltests")
+               $(use debug     && echo "--enable-debug")
+       )
+
+       python_configure() {
+               waf-utils_src_configure "${myconf[@]}"
+       }
+       python_foreach_impl run_in_build_dir python_configure
+}
+
+src_compile() {
+       unset MAKEOPTS
+       python_compile() {
+               waf-utils_src_compile
+       }
+       python_foreach_impl run_in_build_dir python_compile
+}
+
+src_install() {
+       python_install() {
+               waf-utils_src_install
+       }
+       python_foreach_impl run_in_build_dir python_install
+       python_foreach_impl python_optimize
+
+       # Install heat generating scripts
+       use heat && dosbin "${S}"/contrib/ntpheat{,usb}
+
+       # Install the openrc files
+       newinitd "${FILESDIR}"/ntpd.rc-r2 ntp
+       newconfd "${FILESDIR}"/ntpd.confd ntp
+
+       # Install the systemd unit file
+       systemd_newunit "${FILESDIR}"/ntpd-r1.service ntpd.service
+
+       # Prepare a directory for the ntp.drift file
+       mkdir -pv "${ED}"/var/lib/ntp
+       chown ntp:ntp "${ED}"/var/lib/ntp
+       chmod 770 "${ED}"/var/lib/ntp
+       keepdir /var/lib/ntp
+
+       # Install a log rotate script
+       mkdir -pv "${ED}"/etc/logrotate.d
+       cp -v "${S}"/etc/logrotate-config.ntpd "${ED}"/etc/logrotate.d/ntpd
+
+       # Install the configuration file and sample configuration
+       cp -v "${FILESDIR}"/ntp.conf "${ED}"/etc/ntp.conf
+       cp -Rv "${S}"/etc/ntp.d/ "${ED}"/etc/
+
+       # move doc files to /usr/share/doc/"${P}"
+       use doc && mv -v "${ED}"/usr/share/doc/"${PN}" "${ED}"/usr/share/doc/"${P}"/html
+}
+
+pkg_postinst() {
+       einfo "If you want to serve time on your local network, then"
+       einfo "you should disable all the ref_clocks unless you have"
+       einfo "one and can get stable time from it.  Feel free to try"
+       einfo "it but PPS probably won't work unless you have a UART"
+       einfo "GPS that actually provides PPS messages."
+}