kde-plasma/kwallet-pam: Improve pkg_postinst
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>
Tue, 12 Apr 2016 16:14:21 +0000 (18:14 +0200)
committerMichael Palimaka <kensington@gentoo.org>
Thu, 14 Apr 2016 19:35:27 +0000 (05:35 +1000)
Gentoo-bug: 579594

Package-Manager: portage-2.2.27

kde-apps/kwalletd-pam/kwalletd-pam-5.5.5.ebuild
kde-plasma/kwallet-pam/kwallet-pam-5.5.5.ebuild
kde-plasma/kwallet-pam/kwallet-pam-5.6.2-r1.ebuild

index a4e3d0b09e6e59db5c6e42414825706e7be3d1af..23141ef2e9ab9c1894899602be21bf022d68038e 100644 (file)
@@ -40,8 +40,8 @@ src_configure() {
 pkg_postinst() {
        check_dm() {
                if [[ -e "${ROOT}${2}" ]] && \
-                       [[ -n $(egrep "auth\s+optional\s+pam_kwallet.so" "${ROOT}${2}") ]] && \
-                       [[ -n $(egrep "session\s+optional\s+pam_kwallet.so" "${ROOT}${2}") ]]; then
+                       grep -Eq "auth\s+optional\s+pam_kwallet.so" "${ROOT}${2}" && \
+                       grep -Eq "session\s+optional\s+pam_kwallet.so" "${ROOT}${2}" ; then
                        elog "    ${1} - ${2} ...GOOD"
                else
                        ewarn "    ${1} - ${2} ...BAD"
@@ -50,12 +50,13 @@ pkg_postinst() {
        elog
        elog "This package enables auto-unlocking of kde-apps/kwalletd:4."
        elog "List of things to make it work:"
-       elog "1.  Use same password for login and kwallet"
-       elog "2.  A display manager with support for PAM"
-       elog "3.a Have the following lines in the display manager's pam.d file:"
+       elog "1.  Use standard blowfish encryption instead of GPG"
+       elog "2.  Use same password for login and kwallet"
+       elog "3.  A display manager with support for PAM"
+       elog "4.a Have the following lines in the display manager's pam.d file:"
        elog "    -auth        optional        pam_kwallet.so kdehome=.kde4"
        elog "    -session     optional        pam_kwallet.so"
-       elog "3.b Checking installed DMs..."
+       elog "4.b Checking installed DMs..."
        has_version "x11-misc/sddm" && check_dm "SDDM" "/etc/pam.d/sddm"
        has_version "x11-misc/lightdm" && check_dm "LightDM" "/etc/pam.d/lightdm"
        has_version "kde-base/kdm" && check_dm "KDM" "/etc/pam.d/kde"
index 155acc7b668d155500ec41d438c8f4d7dbee53e3..19156bee619a631d8a7275217683dcc30e64b9e6 100644 (file)
@@ -31,8 +31,8 @@ src_configure() {
 pkg_postinst() {
        check_dm() {
                if [[ -e "${ROOT}${2}" ]] && \
-                       [[ -n $(egrep "auth\s+optional\s+pam_kwallet5.so" "${ROOT}${2}") ]] && \
-                       [[ -n $(egrep "session\s+optional\s+pam_kwallet5.so" "${ROOT}${2}") ]]; then
+                       grep -Eq "auth\s+optional\s+pam_kwallet5.so" "${ROOT}${2}" && \
+                       grep -Eq "session\s+optional\s+pam_kwallet5.so" "${ROOT}${2}" ; then
                        elog "    ${1} - ${2} ...GOOD"
                else
                        ewarn "    ${1} - ${2} ...BAD"
@@ -41,12 +41,13 @@ pkg_postinst() {
        elog
        elog "This package enables auto-unlocking of kde-frameworks/kwallet:5."
        elog "List of things to make it work:"
-       elog "1.  Use same password for login and kwallet"
-       elog "2.  A display manager with support for PAM"
-       elog "3.a Have the following lines in the display manager's pam.d file:"
+       elog "1.  Use standard blowfish encryption instead of GPG"
+       elog "2.  Use same password for login and kwallet"
+       elog "3.  A display manager with support for PAM"
+       elog "4.a Have the following lines in the display manager's pam.d file:"
        elog "    -auth        optional        pam_kwallet5.so"
        elog "    -session     optional        pam_kwallet5.so auto_start"
-       elog "3.b Checking installed DMs..."
+       elog "4.b Checking installed DMs..."
        has_version "x11-misc/sddm" && check_dm "SDDM" "/etc/pam.d/sddm"
        has_version "x11-misc/lightdm" && check_dm "LightDM" "/etc/pam.d/lightdm"
        has_version "kde-base/kdm" && check_dm "KDM" "/etc/pam.d/kde"
index 9c5669e841664e5c87fbdea2c8223c49ff1ace14..0713014356070d99d2abf55f1d88bbd53519db61 100644 (file)
@@ -73,16 +73,17 @@ pkg_postinst() {
        elog "This package enables auto-unlocking of kde-frameworks/kwallet:5."
        use oldwallet && elog "You have also selected support for legacy kde-apps/kwalletd:4."
        elog "List of things to make it work:"
-       elog "1.  Use same password for login and kwallet"
-       elog "2.  A display manager with support for PAM"
-       elog "3.a Have the following lines in the display manager's pam.d file:"
+       elog "1.  Use standard blowfish encryption instead of GPG"
+       elog "2.  Use same password for login and kwallet"
+       elog "3.  A display manager with support for PAM"
+       elog "4.a Have the following lines in the display manager's pam.d file:"
        elog "    -auth        optional        pam_kwallet5.so"
        elog "    -session     optional        pam_kwallet5.so auto_start"
        if use oldwallet ; then
                elog "    -auth        optional        pam_kwallet.so kdehome=.kde4"
                elog "    -session     optional        pam_kwallet.so"
        fi
-       elog "3.b Checking installed DMs..."
+       elog "4.b Checking installed DMs..."
        has_version "x11-misc/sddm" && check_dm "SDDM" "/etc/pam.d/sddm"
        has_version "x11-misc/lightdm" && check_dm "LightDM" "/etc/pam.d/lightdm"
        has_version "kde-base/kdm" && check_dm "KDM" "/etc/pam.d/kde"