dev-python/flask-security: Remove old
authorDavid Seifert <soap@gentoo.org>
Sun, 29 Dec 2019 08:51:39 +0000 (09:51 +0100)
committerDavid Seifert <soap@gentoo.org>
Sun, 29 Dec 2019 08:51:39 +0000 (09:51 +0100)
Package-Manager: Portage-2.3.83, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
dev-python/flask-security/Manifest
dev-python/flask-security/flask-security-1.7.5-r1.ebuild [deleted file]

index 84141986bf0fc1f5b74df3dee42c36c76cf46625..a8eeac2761e7c00438955d0a77183bdc5a83e1b3 100644 (file)
@@ -1,2 +1 @@
-DIST Flask-Security-1.7.5.tar.gz 42261 BLAKE2B b71170e83acadf036f8b7d2ab6d2cf6521ee06109bb1cb45801a10fa20c050ae5f933df4414ce57d1c9dabed60b068eeab3e0a0f6d318f092680ac7f5e775cfb SHA512 41fd806d35746bdc212aa4ab01af678d39765a6d4df42cd19c87b8a2060374112d3e8a5f2fc243e88906505d6a942b9a824cf19a29b2c0eebacde9299534ffc9
 DIST Flask-Security-3.0.0.tar.gz 160367 BLAKE2B c2e1449dc2807c2c40519fa3afb894157e17ecc9ff3f6dcf5ef0d02839a5988f827afd26c1d31af86d5e240e0ea8bfb8ed86354bb6a83535436b08721cac8f26 SHA512 09b94f0850372513add5c054c07aa465ecb95e8d1c414647e3ebee571ec08c94a29f0c138d092c02a55e242c422bc53f929ca066d671c082dcb29834ac753984
diff --git a/dev-python/flask-security/flask-security-1.7.5-r1.ebuild b/dev-python/flask-security/flask-security-1.7.5-r1.ebuild
deleted file mode 100644 (file)
index b0e48bc..0000000
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 python3_5 )
-
-inherit distutils-r1
-
-MY_PN="Flask-Security"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Simple security for Flask apps"
-HOMEPAGE="https://pythonhosted.org/Flask-Security/ https://pypi.org/project/Flask-Security/"
-SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="test"
-# tests are foobar
-RESTRICT="test"
-
-RDEPEND=">=dev-python/flask-0.9[${PYTHON_USEDEP}]
-       >=dev-python/itsdangerous-0.17[${PYTHON_USEDEP}]
-       >=dev-python/passlib-1.6.1[${PYTHON_USEDEP}]
-       >=dev-python/flask-login-0.1.3[${PYTHON_USEDEP}]
-       >=dev-python/flask-mail-0.7.3[${PYTHON_USEDEP}]
-       >=dev-python/flask-wtf-0.8[${PYTHON_USEDEP}]
-       >=dev-python/flask-principal-0.3.3[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? (
-               dev-python/nose[${PYTHON_USEDEP}]
-               dev-python/flask-sqlalchemy[${PYTHON_USEDEP}]
-               dev-python/flask-mongoengine[${PYTHON_USEDEP}]
-               dev-python/bcrypt[${PYTHON_USEDEP}]
-               dev-python/simplejson[${PYTHON_USEDEP}]
-               $(python_gen_cond_dep 'dev-python/flask-peewee[${PYTHON_USEDEP}]' 'python2*')
-       )"
-
-S="${WORKDIR}/${MY_P}"
-
-python_test() {
-       nosetests -v || die "Testing failed with ${EPYTHON}"
-}