app-emacs/windows: Add version 2.49
authorVictor Gaydov <victor@enise.org>
Sun, 24 Apr 2016 20:41:30 +0000 (23:41 +0300)
committerUlrich Müller <ulm@gentoo.org>
Sun, 1 May 2016 17:29:02 +0000 (19:29 +0200)
Package-Manager: portage-2.2.26

app-emacs/windows/Manifest [new file with mode: 0644]
app-emacs/windows/files/50windows-gentoo.el [new file with mode: 0644]
app-emacs/windows/metadata.xml [new file with mode: 0644]
app-emacs/windows/windows-2.49.ebuild [new file with mode: 0644]

diff --git a/app-emacs/windows/Manifest b/app-emacs/windows/Manifest
new file mode 100644 (file)
index 0000000..0fcd237
--- /dev/null
@@ -0,0 +1 @@
+DIST windows-2.49.el.xz 26240 SHA256 14c32604b604f6ce7cb7622d5813870165cf97d65c4ed128cae3c3174afd957d SHA512 de75f2c07cd544de7e7c616b5b928c0dd538b341396819a49525304ed3d9c01c4814e0f8a8da97bdf1a449844605127da690db3ccd95980240156d3c3600b704 WHIRLPOOL 5e325a3756b1fe60cc7fca0d772f5f2bd4f7a8de3052b908590a3795fcc8e78670dd4d024421e829803401b2cdbf63ba74f774ed9d6f80e52d27ddd5fe1dc8d5
diff --git a/app-emacs/windows/files/50windows-gentoo.el b/app-emacs/windows/files/50windows-gentoo.el
new file mode 100644 (file)
index 0000000..892a420
--- /dev/null
@@ -0,0 +1,2 @@
+(add-to-list 'load-path "@SITELISP@")
+(load "windows-autoloads" nil t)
diff --git a/app-emacs/windows/metadata.xml b/app-emacs/windows/metadata.xml
new file mode 100644 (file)
index 0000000..c2b1693
--- /dev/null
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+  <maintainer type="person">
+    <email>victor@enise.org</email>
+       <name>Victor Gaydov</name>
+       <description>Proxy maintainer.</description>
+  </maintainer>
+  <maintainer type="project">
+    <email>gnu-emacs@gentoo.org</email>
+    <name>Gentoo GNU Emacs project</name>
+  </maintainer>
+  <maintainer type="project">
+    <email>proxy-maint@gentoo.org</email>
+    <name>Proxy Maintainers</name>
+  </maintainer>
+</pkgmetadata>
diff --git a/app-emacs/windows/windows-2.49.ebuild b/app-emacs/windows/windows-2.49.ebuild
new file mode 100644 (file)
index 0000000..12b33fe
--- /dev/null
@@ -0,0 +1,26 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit elisp
+
+DESCRIPTION="Window manager for GNU Emacs"
+HOMEPAGE="http://www.gentei.org/~yuuji/software/"
+# taken from http://www.gentei.org/~yuuji/software/euc/windows.el
+SRC_URI="https://enise.org/users/victor/share/distfiles/${P}.el.xz"
+
+LICENSE="yuuji"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="app-emacs/revive"
+DEPEND="${RDEPEND}"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+       elisp-compile *.el || die
+       elisp-make-autoload-file || die
+}