sys-apps/portage: Replace python_gen_usedep
authorMichał Górny <mgorny@gentoo.org>
Sat, 21 Dec 2019 08:31:44 +0000 (09:31 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sat, 21 Dec 2019 08:31:44 +0000 (09:31 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
sys-apps/portage/portage-2.3.82.ebuild
sys-apps/portage/portage-9999.ebuild

index a7197349654da4b42317c0c86329ae8c3f1c791c..bd5bc590071e4c0a2d4478bd45af9a3f65355133 100644 (file)
@@ -26,7 +26,11 @@ DEPEND="!build? ( $(python_gen_impl_dep 'ssl(+)') )
        dev-lang/python-exec:2
        >=sys-apps/sed-4.0.5 sys-devel/patch
        doc? ( app-text/xmlto ~app-text/docbook-xml-dtd-4.4 )
-       epydoc? ( >=dev-python/epydoc-2.0[$(python_gen_usedep 'python2*')] )"
+       epydoc? (
+               $(python_gen_cond_dep '
+                       >=dev-python/epydoc-2.0[${PYTHON_USEDEP}]
+               ' 'python2*')
+       )"
 # Require sandbox-2.2 for bug #288863.
 # For xattr, we can spawn getfattr and setfattr from sys-apps/attr, but that's
 # quite slow, so it's not considered in the dependencies as an alternative to
index 04544afb66d4ca8a8aa02595e9bc066c8a635f9d..edfa4bf26344e677f15a38f7a67846b5f777a196 100644 (file)
@@ -26,7 +26,11 @@ DEPEND="!build? ( $(python_gen_impl_dep 'ssl(+)') )
        dev-lang/python-exec:2
        >=sys-apps/sed-4.0.5 sys-devel/patch
        doc? ( app-text/xmlto ~app-text/docbook-xml-dtd-4.4 )
-       epydoc? ( >=dev-python/epydoc-2.0[$(python_gen_usedep 'python2*')] )"
+       epydoc? (
+               $(python_gen_cond_dep '
+                       >=dev-python/epydoc-2.0[${PYTHON_USEDEP}]
+               ' 'python2*')
+       )"
 # Require sandbox-2.2 for bug #288863.
 # For xattr, we can spawn getfattr and setfattr from sys-apps/attr, but that's
 # quite slow, so it's not considered in the dependencies as an alternative to