dev-python/flake8: Replace virts with cond deps
authorMichał Górny <mgorny@gentoo.org>
Mon, 16 Mar 2020 20:53:24 +0000 (21:53 +0100)
committerMichał Górny <mgorny@gentoo.org>
Mon, 16 Mar 2020 20:56:41 +0000 (21:56 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/flake8/flake8-3.5.0.ebuild
dev-python/flake8/flake8-3.7.9.ebuild

index 13da912b4ca67adb80412cc14243b63b906c0b1d..e90b92fd28c0b551969431510803b34a532f6841 100644 (file)
@@ -23,8 +23,10 @@ RDEPEND="
        <dev-python/pyflakes-1.7.0[${PYTHON_USEDEP}]
        >=dev-python/pycodestyle-2.0.0[${PYTHON_USEDEP}]
        <dev-python/pycodestyle-2.4.0[${PYTHON_USEDEP}]
-       virtual/python-enum34[${PYTHON_USEDEP}]
-       $(python_gen_cond_dep 'dev-python/configparser[${PYTHON_USEDEP}]' 'python2*' pypy )
+       $(python_gen_cond_dep '
+               dev-python/configparser[${PYTHON_USEDEP}]
+               dev-python/enum34[${PYTHON_USEDEP}]
+       ' -2)
 "
 PDEPEND="
        >=dev-python/mccabe-0.6.0[${PYTHON_USEDEP}]
index 81df18dff71b0a326723d615c242b5887b226fe0..0cc36ad2720e69075d753b49800447536dd6b457 100644 (file)
@@ -24,11 +24,12 @@ RDEPEND="
        <dev-python/pyflakes-2.2.0[${PYTHON_USEDEP}]
        >=dev-python/pycodestyle-2.5.0[${PYTHON_USEDEP}]
        <dev-python/pycodestyle-2.6.0[${PYTHON_USEDEP}]
-       virtual/python-enum34[${PYTHON_USEDEP}]
-       virtual/python-typing[${PYTHON_USEDEP}]
-       $(python_gen_cond_dep 'dev-python/configparser[${PYTHON_USEDEP}]' -2)
-       $(python_gen_cond_dep 'dev-python/functools32[${PYTHON_USEDEP}]' -2)
-       $(python_gen_cond_dep 'dev-python/functools32[${PYTHON_USEDEP}]' -2)
+       $(python_gen_cond_dep '
+               dev-python/configparser[${PYTHON_USEDEP}]
+               dev-python/enum34[${PYTHON_USEDEP}]
+               dev-python/functools32[${PYTHON_USEDEP}]
+               dev-python/typing[${PYTHON_USEDEP}]
+       ' -2)
        !dev-python/pep8[${PYTHON_USEDEP}]
 "
 PDEPEND="