sys-libs/timezone-data: version bump to 2015g
authorMike Frysinger <vapier@gentoo.org>
Sat, 3 Oct 2015 02:20:41 +0000 (22:20 -0400)
committerMike Frysinger <vapier@gentoo.org>
Sat, 3 Oct 2015 02:20:41 +0000 (22:20 -0400)
sys-libs/timezone-data/Manifest
sys-libs/timezone-data/timezone-data-2015g.ebuild [new file with mode: 0644]

index 8b2191274f65fdc0792a949d645641e239cbd57f..0221b9cdda409c34c8951bcba761560dfd00a345 100644 (file)
@@ -1,4 +1,6 @@
 DIST tzcode2015e.tar.gz 185129 SHA256 b5a217b55847fb56f470a7738939c36f3a520d6cc12342d965cfcf848e59ada0 SHA512 fdc568a68f4876b967b39e21fa53f063dc5756e886e2a273cc046d5a014eb517e9c91eb6e03d18c94a89ce48578868aed710790415c500188fce4e4add0ce7ca WHIRLPOOL d3fde26e0b0ebe98d7de0c2a666a79dd6020e471b647de2b61a89dc1eeba61e8928c7dcb2e1b15d867e8e81b5e33321a288a2b94e713deaf5579e00b6082e7b8
 DIST tzcode2015f.tar.gz 180742 SHA256 0c95e0a42bb61141f790f4f5f204b954d7654c894aa54a594a215d6f38de84ae SHA512 5cfbebde8a0be57e8388a7b6d35aeba99130a72c1a41f9bbd5d5864511a473aa5e9320ab21055b4383e64b3b9d7682c0d30377ce8407619987be672436014710 WHIRLPOOL c657f8d6a77cd96f6fed296bc905fd5690abe47f7cf25d99ea6802d61cee619c75e70ea006a77a0680d4c46ea43f8fb509bbb32b7ecc0323996e44b462e17845
+DIST tzcode2015g.tar.gz 181695 SHA256 18e402ef24bfad2ded38643c9a7a9a580f940a729cb47d983052fc28ff0c7ec4 SHA512 44da833da3afdb82636a953785372bb4c765e61e40d700da40b46ab70007ebdbde4d480e10b87cbb36c45eaaffcaa6b9894375e2f553b7d16655dc167cd4a11f WHIRLPOOL 7c71471ba122865710ec6c71e443dab7db8fd6f43cf4348dd02438129d9c80dcfb3d6da3cdb3b04efeabcc5debba35a78d0b946b6b9e98caa5d7ddefbbe600e4
 DIST tzdata2015e.tar.gz 296773 SHA256 ffc9b5d38abda8277aa479e3f75aa7668819d0977cd1a0c8ef3b09128334ba6f SHA512 86498190a20c5c67827aa75f7e9c6aa6c19d58a88a70425ce70d5ae7cea42dc7386eb2867fa455fcfcdedc6a105ad70fbbdc7c27c7a58a51bd21d76a135983ce WHIRLPOOL aaf2f2009f451beaf178d1ee622ebacdd04f1795e07a606b61620cac8faf74a63e1ea3f75ef58b846a6093922cba9df764ed1929e70d1f0be5181fdc25901282
 DIST tzdata2015f.tar.gz 298815 SHA256 959f81b541e042ecb13c50097d264ae92ff03a57979c478dbcf24d5da242531d SHA512 d86e6c9e4c6d9cd5de30762723d7a90ac697feeb6dd1f04649f6a35e4e1dc638261c32066db4aeafa767ac339ccd100c38dde044ceadd61e95cb3d39c27f977e WHIRLPOOL 0b56e3ae620bed60d37abb195e8c4add8f5a00114422e91f2e533fce8c0091bdd681ff5c682e929e5af45202afde838fcc1ae14b7865f6f83a126c647e56d6a4
+DIST tzdata2015g.tar.gz 300363 SHA256 b923cdbf078491696b17bc8d069c74bce73fabc5774629da2f410c9b31576161 SHA512 ad7de0e3e8753861d260f0fcbcbca327516a4dc826f7659370a7fb979e6154f1a26b23d2609acf6e1790c8c59da0b76c42f4a94bf361409c1460f6a8ffa6f879 WHIRLPOOL 3af55fc43133ef3c03b734d8db35feda760feb5ad3adf0e763337fcf4ad7057231f5a24ddf68fdac9ae4014d31675d6a51c29f14b987118daad7f691f7e3fe98
diff --git a/sys-libs/timezone-data/timezone-data-2015g.ebuild b/sys-libs/timezone-data/timezone-data-2015g.ebuild
new file mode 100644 (file)
index 0000000..fdeb523
--- /dev/null
@@ -0,0 +1,140 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils toolchain-funcs flag-o-matic
+
+code_ver=${PV}
+data_ver=${PV}
+DESCRIPTION="Timezone data (/usr/share/zoneinfo) and utilities (tzselect/zic/zdump)"
+HOMEPAGE="http://www.iana.org/time-zones http://www.twinsun.com/tz/tz-link.htm"
+SRC_URI="http://www.iana.org/time-zones/repository/releases/tzdata${data_ver}.tar.gz
+       http://www.iana.org/time-zones/repository/releases/tzcode${code_ver}.tar.gz"
+
+LICENSE="BSD public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="nls leaps_timezone elibc_FreeBSD elibc_glibc"
+
+RDEPEND="!sys-libs/glibc[vanilla(+)]"
+
+S=${WORKDIR}
+
+src_prepare() {
+       epatch "${FILESDIR}"/${PN}-2015c-makefile.patch
+       tc-is-cross-compiler && cp -pR "${S}" "${S}"-native
+}
+
+_emake() {
+       emake \
+               TOPDIR="${EPREFIX}/usr" \
+               REDO=$(usex leaps_timezone posix_right posix_only) \
+               "$@"
+}
+
+src_compile() {
+       local LDLIBS
+       tc-export CC
+       if use elibc_FreeBSD || use elibc_Darwin ; then
+               append-cppflags -DSTD_INSPIRED #138251
+       fi
+       export NLS=$(usex nls 1 0)
+       if use nls && ! use elibc_glibc ; then
+               LDLIBS+=" -lintl" #154181
+       fi
+       # TOPDIR is used in some utils when compiling.
+       _emake \
+               AR="$(tc-getAR)" \
+               CC="$(tc-getCC)" \
+               RANLIB="$(tc-getRANLIB)" \
+               CFLAGS="${CFLAGS} -std=gnu99" \
+               LDFLAGS="${LDFLAGS}" \
+               LDLIBS="${LDLIBS}"
+       if tc-is-cross-compiler ; then
+               _emake -C "${S}"-native \
+                       CC="$(tc-getBUILD_CC)" \
+                       CFLAGS="${BUILD_CFLAGS}" \
+                       CPPFLAGS="${BUILD_CPPFLAGS}" \
+                       LDFLAGS="${BUILD_LDFLAGS}" \
+                       LDLIBS="${LDLIBS}" \
+                       zic
+       fi
+}
+
+src_install() {
+       local zic=""
+       tc-is-cross-compiler && zic="zic=${S}-native/zic"
+       _emake install ${zic} DESTDIR="${D}"
+       dodoc CONTRIBUTING README NEWS Theory
+       dohtml *.htm
+}
+
+get_TIMEZONE() {
+       local tz src="${EROOT}etc/timezone"
+       if [[ -e ${src} ]] ; then
+               tz=$(sed -e 's:#.*::' -e 's:[[:space:]]*::g' -e '/^$/d' "${src}")
+       else
+               tz="FOOKABLOIE"
+       fi
+       [[ -z ${tz} ]] && return 1 || echo "${tz}"
+}
+
+pkg_preinst() {
+       local tz=$(get_TIMEZONE)
+       if [[ ${tz} == right/* || ${tz} == posix/* ]] ; then
+               eerror "The right & posix subdirs are no longer installed as subdirs -- they have been"
+               eerror "relocated to match upstream paths as sibling paths.  Further, posix/xxx is the"
+               eerror "same as xxx, so you should simply drop the posix/ prefix.  You also should not"
+               eerror "be using right/xxx for the system timezone as it breaks programs."
+               die "Please fix your timezone setting"
+       fi
+
+       # Trim the symlink by hand to avoid portage's automatic protection checks.
+       rm -f "${EROOT}"/usr/share/zoneinfo/posix
+
+       if has_version "<=${CATEGORY}/${PN}-2015c" ; then
+               elog "Support for accessing posix/ and right/ directly has been dropped to match"
+               elog "upstream.  There is no need to set TZ=posix/xxx as it is the same as TZ=xxx."
+               elog "For TZ=right/, you can use TZ=../zoneinfo-leaps/xxx instead.  See this post"
+               elog "for details: https://mm.icann.org/pipermail/tz/2015-February/022024.html"
+       fi
+}
+
+pkg_config() {
+       # make sure the /etc/localtime file does not get stale #127899
+       local tz src="${EROOT}etc/timezone" etc_lt="${EROOT}etc/localtime"
+
+       # If it's a symlink, assume the user knows what they're doing and
+       # they're managing it themselves. #511474
+       if [[ -L ${etc_lt} ]] ; then
+               einfo "Assuming your ${etc_lt} symlink is what you want; skipping update."
+               return 0
+       fi
+
+       tz=$(get_TIMEZONE) || return 0
+       if [[ ${tz} == "FOOKABLOIE" ]] ; then
+               elog "You do not have TIMEZONE set in ${src}."
+
+               if [[ ! -e ${etc_lt} ]] ; then
+                       cp -f "${EROOT}"/usr/share/zoneinfo/Factory "${etc_lt}"
+                       elog "Setting ${etc_lt} to Factory."
+               else
+                       elog "Skipping auto-update of ${etc_lt}."
+               fi
+               return 0
+       fi
+
+       if [[ ! -e ${EROOT}/usr/share/zoneinfo/${tz} ]] ; then
+               elog "You have an invalid TIMEZONE setting in ${src}"
+               elog "Your ${etc_lt} has been reset to Factory; enjoy!"
+               tz="Factory"
+       fi
+       einfo "Updating ${etc_lt} with ${EROOT}usr/share/zoneinfo/${tz}"
+       cp -f "${EROOT}"/usr/share/zoneinfo/"${tz}" "${etc_lt}"
+}
+
+pkg_postinst() {
+       pkg_config
+}