dev-python/rospkg: Bump to 1.1.0 and use the github snapshot only
authorAlexis Ballier <aballier@gentoo.org>
Sat, 25 Feb 2017 08:56:02 +0000 (09:56 +0100)
committerAlexis Ballier <aballier@gentoo.org>
Sat, 25 Feb 2017 09:54:48 +0000 (10:54 +0100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

dev-python/rospkg/Manifest
dev-python/rospkg/rospkg-1.1.0.ebuild [new file with mode: 0644]
dev-python/rospkg/rospkg-9999.ebuild

index 4e3b9ed1cda59d574b42e25345e7a41129c1ce0b..80ad25c2fe7d1be33184d0b445db030dfe57ae34 100644 (file)
@@ -1 +1,2 @@
 DIST rospkg-1.0.41.tar.gz 89625 SHA256 19e0ebf751a716e312ad848ab2b545f6634d87573109b6164438db210f1f1c12 SHA512 d831ed5da8c5cf8d01cafcb83c879ef17647bdd8ec40f58e27766c5843bba118553daa932e18d9448120ce0be3e89f20a0ddd728c38ce47b2b3a41fb537123b5 WHIRLPOOL cb1e3a5dec83f0b1612df8dbbf46c845f970916259084fd9c2b8b80d0bb8ea0bc59bf064685461ec64637259c36cedb45f4f431656627beedfddf0c915ad4762
+DIST rospkg-1.1.0.tar.gz 89282 SHA256 e1a7c0025c565a969a32d75407f4fc9ae51c0676a40aa0d86c65cac7779fc760 SHA512 0b38eb9fec701ff27842870c4d089f2deede1558f41a02004a8f2eb3fb639dac9c744086794f756b94dc108483ca433ffe4bff33be3031f496e90059f3f5c65b WHIRLPOOL 5c89ef46a0e5372725617f17ef3cf5daa474ed6de1c57884e6b1e49069f93d2aebfe6a176ecb0ae5c8d69def5091432b99b481d81b0d69893fb53c3dce9360f6
diff --git a/dev-python/rospkg/rospkg-1.1.0.ebuild b/dev-python/rospkg/rospkg-1.1.0.ebuild
new file mode 100644 (file)
index 0000000..cd2e7b3
--- /dev/null
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy{,3} )
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+       SCM="git-r3"
+       EGIT_REPO_URI="https://github.com/ros-infrastructure/rospkg"
+fi
+
+inherit ${SCM} distutils-r1
+
+DESCRIPTION="Standalone Python library for the ROS package system"
+HOMEPAGE="http://wiki.ros.org/rospkg"
+if [ "${PV#9999}" != "${PV}" ] ; then
+       SRC_URI=""
+       KEYWORDS=""
+       # Needed for tests
+       S="${WORKDIR}/${PN}"
+       EGIT_CHECKOUT_DIR="${S}"
+else
+       SRC_URI="https://github.com/ros-infrastructure/rospkg/archive/${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64 ~arm"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+       test? (
+               dev-python/nose[${PYTHON_USEDEP}]
+               dev-python/coverage[${PYTHON_USEDEP}]
+       )
+"
+
+python_test() {
+       nosetests --with-coverage --cover-package=rospkg --with-xunit test || die
+}
index b1e0b7c7034e04a313987313d3fbf9f35fe3ddc7..cd2e7b33c72044e2022d1f9c7404ecb265a41eb1 100644 (file)
@@ -22,9 +22,7 @@ if [ "${PV#9999}" != "${PV}" ] ; then
        S="${WORKDIR}/${PN}"
        EGIT_CHECKOUT_DIR="${S}"
 else
-       SRC_URI="http://download.ros.org/downloads/${PN}/${P}.tar.gz
-               https://github.com/ros-infrastructure/rospkg/archive/${PV}.tar.gz -> ${P}.tar.gz
-       "
+       SRC_URI="https://github.com/ros-infrastructure/rospkg/archive/${PV}.tar.gz -> ${P}.tar.gz"
        KEYWORDS="~amd64 ~arm"
 fi