dev-haskell/cryptohash-sha256: new package, a depend of dev-haskell/cabal-install...
authorSergei Trofimovich <slyfox@gentoo.org>
Wed, 15 Feb 2017 08:32:48 +0000 (08:32 +0000)
committerSergei Trofimovich <slyfox@gentoo.org>
Wed, 15 Feb 2017 08:32:48 +0000 (08:32 +0000)
Fast, pure and practical SHA-256 implementation

Package-Manager: Portage-2.3.3, Repoman-2.3.1

dev-haskell/cryptohash-sha256/Manifest [new file with mode: 0644]
dev-haskell/cryptohash-sha256/cryptohash-sha256-0.11.100.1.ebuild [new file with mode: 0644]
dev-haskell/cryptohash-sha256/metadata.xml [new file with mode: 0644]

diff --git a/dev-haskell/cryptohash-sha256/Manifest b/dev-haskell/cryptohash-sha256/Manifest
new file mode 100644 (file)
index 0000000..9ba15d0
--- /dev/null
@@ -0,0 +1 @@
+DIST cryptohash-sha256-0.11.100.1.tar.gz 10885 SHA256 57b02338e9648639335788b422dd4c744543cb0991347472e2e3628a33c2f5d6 SHA512 df6a8c7a4796f3b94faf0c1073b552eccf7dfbe6ab1489fef391e6342f34b3cb29991d1313aa5da11a90cb37bcd43c23eea12073ad4c7190926005de952c39e2 WHIRLPOOL 40b6b78e3631085765cea2d5868de95939d52e41b1de36b9ccb862b0b4cdfe8b144516ef551ab0c659b6652849d53e66ec6984f3bcdebae59bf3354c24f42060
diff --git a/dev-haskell/cryptohash-sha256/cryptohash-sha256-0.11.100.1.ebuild b/dev-haskell/cryptohash-sha256/cryptohash-sha256-0.11.100.1.ebuild
new file mode 100644 (file)
index 0000000..4677949
--- /dev/null
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Fast, pure and practical SHA-256 implementation"
+HOMEPAGE="https://github.com/hvr/cryptohash-sha256"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+       >=dev-haskell/cabal-1.10
+       test? ( >=dev-haskell/base16-bytestring-0.1.1 <dev-haskell/base16-bytestring-0.2
+               >=dev-haskell/sha-1.6.4 <dev-haskell/sha-1.7
+               >=dev-haskell/tasty-0.11 <dev-haskell/tasty-0.12
+               >=dev-haskell/tasty-hunit-0.9 <dev-haskell/tasty-hunit-0.10
+               >=dev-haskell/tasty-quickcheck-0.8 <dev-haskell/tasty-quickcheck-0.9 )
+"
diff --git a/dev-haskell/cryptohash-sha256/metadata.xml b/dev-haskell/cryptohash-sha256/metadata.xml
new file mode 100644 (file)
index 0000000..b1c194f
--- /dev/null
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="project">
+               <email>haskell@gentoo.org</email>
+               <name>Gentoo Haskell</name>
+       </maintainer>
+       <longdescription>
+               A practical incremental and one-pass, pure API to the
+               &lt;https://en.wikipedia.org/wiki/SHA-2 SHA-256 hash algorithm&gt;
+               with performance close to the fastest implementations available in other languages.
+               
+               The implementation is made in C with a haskell FFI wrapper that hides the C implementation.
+               
+               NOTE: This package has been forked off @cryptohash-0.11.7@ because the @cryptohash@ has been
+               deprecated and so this package continues to satisfy the need for a lightweight package
+               providing the SHA256 hash algorithm without any dependencies on packages other than
+               @base@ and @bytestring@.
+               
+               Consequently, this package can be used as a drop-in replacement for @cryptohash@&#39;s
+               &quot;Crypto.Hash.SHA256&quot; module, though with a clearly smaller footprint.
+       </longdescription>
+</pkgmetadata>