dev-ruby/curb: cleanup
authorHans de Graaff <graaff@gentoo.org>
Sun, 13 Jan 2019 07:54:38 +0000 (08:54 +0100)
committerHans de Graaff <graaff@gentoo.org>
Sun, 13 Jan 2019 07:54:38 +0000 (08:54 +0100)
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Package-Manager: Portage-2.3.51, Repoman-2.3.11

dev-ruby/curb/Manifest
dev-ruby/curb/curb-0.9.4.ebuild [deleted file]
dev-ruby/curb/curb-0.9.6.ebuild [deleted file]

index d20c6d099d94508e2f1f504e0646a162ebd5525d..4d0f2dd30783455d1c9a586310029289af847c0a 100644 (file)
@@ -1,3 +1 @@
-DIST curb-0.9.4.gem 82432 BLAKE2B 2bf2bf0d887369c484d246771afc9cb34c6eb72a3809f13c9047f82030d79b1be47141db03659c1e4f42792c94094e40f05d4b1b0d984aed73a47c24ef96379a SHA512 7b81ba587ac9beb203e040234d9f5032d87352a3e045d3705f474d2eaf1f620245240a59894c7147f54d55f0293f60488e8f883367f96945d49ffcdcef42bfc1
-DIST curb-0.9.6.gem 83456 BLAKE2B 79ef506ef3c570cae2527b3547d3b315ec3b1ba8cb8295f5c886d653ca5f3b8454a3326b9d704ce20aea6e2ff0652bb682e9931f9ba0573f449322e087ea53fe SHA512 b592e04f963a32a81dec0b67348921da7b9a84d6943398984126eae1dc22653efbb049ad04201a7f22cbf19a03d6c587a525491d25585d3f12e29d4a5cf469a8
 DIST curb-0.9.7.gem 83968 BLAKE2B 591c4fde6fe809c813bb7586875e954dcc3b6190eb6955b5769a2dd1538d156074d0e025af6b1d42cbd820fb012b46eec4e9ca96fe61acc3697cf1f6c5018b43 SHA512 6068eaaad6b1dc2dbbf7d0588235ce2a681d786bf8ed6d072e501b7cbff600d8fbc9d675fac3949a565c8451641982cbd9ab29a50cf3707e8c4cdc35b539f42b
diff --git a/dev-ruby/curb/curb-0.9.4.ebuild b/dev-ruby/curb/curb-0.9.4.ebuild
deleted file mode 100644 (file)
index db40877..0000000
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-USE_RUBY="ruby22 ruby23 ruby24 ruby25"
-
-RUBY_FAKEGEM_RECIPE_TEST="rake"
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Ruby-language bindings for libcurl"
-HOMEPAGE="https://github.com/taf2/curb"
-
-LICENSE="Ruby"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-DEPEND+=" net-misc/curl[ssl]"
-RDEPEND+=" net-misc/curl[ssl]"
-
-all_ruby_prepare() {
-       # fix tests when localhost is also ::1
-       sed -i -e 's|localhost:|127.0.0.1:|g' tests/*.rb || die
-
-       # avoid tests making outside network connections
-       rm tests/bug_postfields_crash.rb || die
-       sed -e '/test_easy_http_verbs_must_respond_to_str/,/^  end/ s:^:#:' \
-               -i tests/tc_curl_easy.rb || die
-
-       # avoid failing tests where failure condition seems weird, no
-       # upstream travis so not clear if the test is indeed broken.
-       sed -i -e '/test_multi_easy_http/,/^  end/ s:^:#:' tests/tc_curl_multi.rb || die
-}
-
-each_ruby_configure() {
-       ${RUBY} -Cext extconf.rb || die "extconf.rb failed"
-}
-
-each_ruby_compile() {
-       emake -Cext CFLAGS="${CFLAGS} -fPIC" archflags="${LDFLAGS}" V=1
-       cp -l ext/curb_core$(get_modname) lib || die
-}
diff --git a/dev-ruby/curb/curb-0.9.6.ebuild b/dev-ruby/curb/curb-0.9.6.ebuild
deleted file mode 100644 (file)
index 303e1f6..0000000
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-USE_RUBY="ruby23 ruby24 ruby25"
-
-RUBY_FAKEGEM_RECIPE_TEST="rake"
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Ruby-language bindings for libcurl"
-HOMEPAGE="https://github.com/taf2/curb"
-
-LICENSE="Ruby"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-DEPEND+=" net-misc/curl[ssl]"
-RDEPEND+=" net-misc/curl[ssl]"
-
-all_ruby_prepare() {
-       # fix tests when localhost is also ::1
-       sed -i -e 's|localhost:|127.0.0.1:|g' tests/*.rb || die
-
-       # avoid tests making outside network connections
-       rm tests/bug_postfields_crash.rb || die
-       sed -e '/test_easy_http_verbs_must_respond_to_str/,/^  end/ s:^:#:' \
-               -i tests/tc_curl_easy.rb || die
-
-       # avoid failing tests where failure condition seems weird, no
-       # upstream travis so not clear if the test is indeed broken.
-       sed -i -e '/test_multi_easy_http/,/^  end/ s:^:#:' tests/tc_curl_multi.rb || die
-}
-
-each_ruby_configure() {
-       ${RUBY} -Cext extconf.rb || die "extconf.rb failed"
-}
-
-each_ruby_compile() {
-       emake -Cext CFLAGS="${CFLAGS} -fPIC" archflags="${LDFLAGS}" V=1
-       cp -l ext/curb_core$(get_modname) lib || die
-}