net-misc/networkmanager-strongswan: bump to EAPI=7
authorConrad Kostecki <conrad@kostecki.com>
Sun, 28 Oct 2018 13:10:50 +0000 (14:10 +0100)
committerThomas Deutschmann <whissi@gentoo.org>
Sat, 19 Jan 2019 05:49:22 +0000 (06:49 +0100)
Signed-off-by: Conrad Kostecki <conrad@kostecki.com>
Package-Manager: Portage-2.3.51, Repoman-2.3.11
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
net-misc/networkmanager-strongswan/networkmanager-strongswan-1.4.4-r1.ebuild [new file with mode: 0644]

diff --git a/net-misc/networkmanager-strongswan/networkmanager-strongswan-1.4.4-r1.ebuild b/net-misc/networkmanager-strongswan/networkmanager-strongswan-1.4.4-r1.ebuild
new file mode 100644 (file)
index 0000000..de93d1d
--- /dev/null
@@ -0,0 +1,50 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="NetworkManager"
+MY_P="${P/networkmanager/${MY_PN}}"
+
+DESCRIPTION="NetworkManager StrongSwan plugin"
+HOMEPAGE="https://www.strongswan.org/"
+SRC_URI="https://download.strongswan.org/${MY_PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+glib"
+
+RDEPEND="
+       app-crypt/libsecret
+       gnome-extra/nm-applet
+       net-misc/networkmanager
+       net-vpn/strongswan[networkmanager]
+       x11-libs/gtk+:3
+"
+
+DEPEND="
+       ${RDEPEND}
+       dev-util/intltool
+"
+
+BDEPEND="virtual/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+       local myeconfargs=(
+               # Don't enable all warnings, as some are treated as errors and the compilation will fail
+               --disable-more-warnings
+               --disable-static
+               $(usex glib '' --without-libnm-glib)
+       )
+
+       econf "${myeconfargs[@]}"
+}
+
+src_install() {
+       default
+
+       find "${D}" -name '*.la' -delete || die
+}