xfce-base/exo: Bump to 0.12.11
authorMichał Górny <mgorny@gentoo.org>
Thu, 19 Dec 2019 19:24:03 +0000 (20:24 +0100)
committerMichał Górny <mgorny@gentoo.org>
Thu, 19 Dec 2019 19:27:38 +0000 (20:27 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
xfce-base/exo/Manifest
xfce-base/exo/exo-0.12.11.ebuild [new file with mode: 0644]

index 378b90f49cd955c3f1ce4cabca0ad9a73a2ba327..7429df407c5694485270268ac0f45db6c0079b2c 100644 (file)
@@ -1,2 +1,3 @@
 DIST exo-0.12.10.tar.bz2 1333794 BLAKE2B 6dd32fcb797f704713a01a01960cb047809e2d3fad3962fbc5a16a510f78ba359978664c4ca7b20e066fdac77a41568ed15af84b6f45048b6bd78a7fadcbeed1 SHA512 b532a33eededc0d81e37c49975281e64d27bacebe878b784669d18112bc70dc39a4e82f781ad602263b10e0167e6391511a8be51f37e82f7be3b14cb6990a49e
+DIST exo-0.12.11.tar.bz2 1333227 BLAKE2B 4e95809c58b6db26ecdf524663c06df9cd70007726091e381a1f0dd58be52efee85ad9721c421c0df6438073bb9de97d56cd039f520e2f7c0f5722a1839ba167 SHA512 ecbf20feddf86178d34a5c70212f0c2310ab1d6ce25291846d6d1d3045270ae3e68102065d7b3d8840137406f826f9bc37fed92a16c1268c3d14f2833a97d533
 DIST exo-0.12.8.tar.bz2 1342201 BLAKE2B 6f52072f169a48ace6490d4c272e7e1208ca66efc388c8706b183d8ebe908d2fc305ae0239647e96e860eaacb1fbc440fc8dd559757f29088548c95702b1401e SHA512 5b96f1e3ba7112d349ee7d986288996c52210304d0aa54594fdc8c85ec0b12e13791f320f28e91bd25afda5f1046f402ba4fcf2eca5df5d8fc0c3515cd6b98a3
diff --git a/xfce-base/exo/exo-0.12.11.ebuild b/xfce-base/exo/exo-0.12.11.ebuild
new file mode 100644 (file)
index 0000000..77319c3
--- /dev/null
@@ -0,0 +1,48 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils
+
+DESCRIPTION="Extensions, widgets and framework library with session support for Xfce"
+HOMEPAGE="https://www.xfce.org/projects/"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
+IUSE="gtk2"
+
+RDEPEND=">=dev-lang/perl-5.6
+       >=dev-libs/glib-2.42
+       dev-perl/URI
+       >=x11-libs/gtk+-3.22:3
+       >=xfce-base/libxfce4ui-4.12:=[gtk3(+)]
+       >=xfce-base/libxfce4util-4.12:=
+       gtk2? ( >=x11-libs/gtk+-2.24:2 )"
+DEPEND="${RDEPEND}
+       dev-util/gtk-doc-am
+       dev-util/intltool
+       sys-devel/gettext
+       virtual/pkgconfig"
+
+src_configure() {
+       local myconf=(
+               $(use_enable gtk2)
+       )
+       econf "${myconf[@]}"
+}
+
+src_install() {
+       default
+       find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+       xdg_icon_cache_update
+}
+
+pkg_postrm() {
+       xdg_icon_cache_update
+}