dev-lang/yasm: use python-single-r1
authorMike Gilbert <floppym@gentoo.org>
Fri, 24 Apr 2020 16:49:32 +0000 (12:49 -0400)
committerMike Gilbert <floppym@gentoo.org>
Fri, 24 Apr 2020 16:52:57 +0000 (12:52 -0400)
Closes: https://bugs.gentoo.org/710216
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
dev-lang/yasm/yasm-1.3.0.ebuild
dev-lang/yasm/yasm-9999.ebuild

index e1ef59791ee033412d57c303a8bee4a1f98f0da8..53906bb765c5cb49d33c5b3aac64ef2d238d61db 100644 (file)
@@ -1,11 +1,11 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
 
 PYTHON_COMPAT=( python2_7 )
 
-inherit python-r1
+inherit python-single-r1
 
 DESCRIPTION="An assembler for x86 and x86_64 instruction sets"
 HOMEPAGE="http://yasm.tortall.net/"
@@ -23,7 +23,11 @@ RDEPEND="
 DEPEND="
        ${RDEPEND}
        nls? ( sys-devel/gettext )
-       python? ( >=dev-python/cython-0.14[${PYTHON_USEDEP}] )"
+       python? ( $(python_gen_cond_dep '>=dev-python/cython-0.14[${PYTHON_USEDEP}]') )"
+
+pkg_setup() {
+       : # Avoid python-single-r1_pkg_setup
+}
 
 src_configure() {
        use python && python_setup
index 1dc81bc993d4d093904fcd7262bfe65e5e4a9515..bb7aeeb4452584e64960466fe3c312e9d3b860a4 100644 (file)
@@ -1,11 +1,11 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
 
 PYTHON_COMPAT=( python2_7 )
 
-inherit autotools eutils python-r1
+inherit autotools eutils python-single-r1
 
 if [[ ${PV} == 9999* ]] ; then
        EGIT_REPO_URI="https://github.com/yasm/yasm.git"
@@ -29,12 +29,16 @@ RDEPEND="
 DEPEND="
        ${RDEPEND}
        nls? ( sys-devel/gettext )
-       python? ( >=dev-python/cython-0.14[${PYTHON_USEDEP}] )"
+       python? ( $(python_gen_cond_dep '>=dev-python/cython-0.14[${PYTHON_USEDEP}]') )"
 
 if [[ ${PV} == 9999* ]]; then
        DEPEND="${DEPEND} ${PYTHON_DEPS} app-text/xmlto app-text/docbook-xml-dtd:4.1.2"
 fi
 
+pkg_setup() {
+       : # Avoid python-single-r1_pkg_setup
+}
+
 src_prepare() {
        if ! [[ ${PV} == 9999* ]]; then
                sed -i -e 's:xmlto:&dIsAbLe:' configure.ac || die #459940