remove old versions, use gnome2_src_unpack to fix #154631 , cleanup ebuilds
authorJohn N. Laliberte <allanonjl@gentoo.org>
Fri, 10 Nov 2006 12:43:53 +0000 (12:43 +0000)
committerJohn N. Laliberte <allanonjl@gentoo.org>
Fri, 10 Nov 2006 12:43:53 +0000 (12:43 +0000)
Package-Manager: portage-2.1.2_rc1-r1

media-gfx/gtkam/ChangeLog
media-gfx/gtkam/gtkam-0.1.12-r1.ebuild
media-gfx/gtkam/gtkam-0.1.12-r2.ebuild

index 4c766712ab4e58b6342a50b22c52d725955d382a..01da49df36d9b8eaed47359a65186d7ee4400a02 100644 (file)
@@ -1,6 +1,11 @@
 # ChangeLog for media-gfx/gtkam
 # Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/gtkam/ChangeLog,v 1.38 2006/04/27 22:56:52 marienz Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gtkam/ChangeLog,v 1.39 2006/11/10 12:43:53 allanonjl Exp $
+
+  10 Nov 2006; John N. Laliberte <allanonjl@gentoo.org>
+  -gtkam-0.1.10-r1.ebuild, -gtkam-0.1.11.ebuild, -gtkam-0.1.12.ebuild,
+  gtkam-0.1.12-r1.ebuild, gtkam-0.1.12-r2.ebuild:
+  remove old versions, use gnome2_src_unpack to fix #154631 , cleanup ebuilds
 
   27 Apr 2006; Marien Zwart <marienz@gentoo.org>
   files/digest-gtkam-0.1.10-r1, files/digest-gtkam-0.1.11,
index f391fa8ec89b431617be83a2305a6e657ed38296..b45b057c91650db7cbb331d75373e8f0d525659e 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/gtkam/gtkam-0.1.12-r1.ebuild,v 1.4 2006/01/05 14:31:11 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gtkam/gtkam-0.1.12-r1.ebuild,v 1.5 2006/11/10 12:43:53 allanonjl Exp $
 
 inherit eutils gnome2
 
@@ -24,10 +24,10 @@ DEPEND="${RDEPEND}
        nls? ( sys-devel/gettext )"
 
 src_unpack() {
-       unpack ${A}
-       cd ${S}
-       epatch ${FILESDIR}/${PN}-0.1.10-norpm.patch
-       epatch ${FILESDIR}/${PN}-0.1.12-helpdoc.patch
+       gnome2_src_unpack
+
+       epatch "${FILESDIR}/${PN}-0.1.10-norpm.patch"
+       epatch "${FILESDIR}/${PN}-0.1.12-helpdoc.patch"
 }
 
 src_compile() {
@@ -37,6 +37,7 @@ src_compile() {
                $(use_with gnome gnome) \
                $(use_with gnome bonobo) \
                --with-rpmbuild=/bin/false --without-gimp
+
        emake || die
 }
 
index 51962c1f1d8ab3518b95711652336cb7b1f787e0..fa0507589bc0cc9a9f70ce320d23ba8858f56838 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/gtkam/gtkam-0.1.12-r2.ebuild,v 1.5 2006/03/09 23:53:48 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gtkam/gtkam-0.1.12-r2.ebuild,v 1.6 2006/11/10 12:43:53 allanonjl Exp $
 
 inherit eutils gnome2
 
@@ -17,6 +17,7 @@ RDEPEND=">=x11-libs/gtk+-2
        >=media-libs/libgphoto2-2.1.6
        exif? ( media-libs/libexif-gtk media-libs/libexif )
        gnome? ( >=gnome-base/libbonobo-2 >=gnome-base/libgnomeui-2 )"
+
 DEPEND="${RDEPEND}
        dev-util/pkgconfig
        nls? ( sys-devel/gettext )"
@@ -24,20 +25,24 @@ DEPEND="${RDEPEND}
 DOCS="ABOUT-NLS AUTHORS MANUAL NEWS README"
 
 pkg_setup() {
-       G2CONF="${G2CONF} $(use_enable nls) $(use_enable exif) $(use_with gnome) \
-                       $(use_with gnome bonobo) --with-rpmbuild=/bin/false --without-gimp"
+       G2CONF="${G2CONF} \
+                       $(use_enable nls) \
+                       $(use_enable exif) \
+                       $(use_with gnome) \
+                       $(use_with gnome bonobo) \
+                       --with-rpmbuild=/bin/false --without-gimp"
 }
 
 src_unpack() {
-       unpack ${A}
-       cd ${S}
+       gnome2_src_unpack
 
-       epatch ${FILESDIR}/${PN}-0.1.10-norpm.patch
-       epatch ${FILESDIR}/${PN}-0.1.12-helpdoc.patch
-       epatch ${FILESDIR}/${PN}-0.1.12-desktop-image.patch
+       epatch "${FILESDIR}/${PN}-0.1.10-norpm.patch"
+       epatch "${FILESDIR}/${PN}-0.1.12-helpdoc.patch"
+       epatch "${FILESDIR}/${PN}-0.1.12-desktop-image.patch"
 }
 
 src_install() {
        gnome2_src_install
+
        rm -rf ${D}/usr/share/doc/gtkam
 }