dev-java/openjdk: remove postinst warnings from :8
authorGeorgy Yakovlev <gyakovlev@gentoo.org>
Sun, 29 Dec 2019 08:35:21 +0000 (00:35 -0800)
committerGeorgy Yakovlev <gyakovlev@gentoo.org>
Sun, 29 Dec 2019 08:36:12 +0000 (00:36 -0800)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
dev-java/openjdk/openjdk-8.222_p10.ebuild
dev-java/openjdk/openjdk-8.232_p09.ebuild

index 047e06407e8d38e2996075acf8cf6f3bb6ea8149..9a7f4a3fb7891f4d2a40b642295845123fc0e7c6 100644 (file)
@@ -241,15 +241,4 @@ src_install() {
 
 pkg_postinst() {
        java-vm-2_pkg_postinst
-
-       if use gentoo-vm ; then
-               ewarn "WARNING! You have enabled the gentoo-vm USE flag, making this JDK"
-               ewarn "recognised by the system. This will almost certainly break things."
-       else
-               ewarn "The experimental gentoo-vm USE flag has not been enabled so this JDK"
-               ewarn "will not be recognised by the system. For example, simply calling"
-               ewarn "\"java\" will launch a different JVM. This is necessary until Gentoo"
-               ewarn "fully supports Java ${SLOT}. This JDK must therefore be invoked using its"
-               ewarn "absolute location under ${EPREFIX}/usr/$(get_libdir)/${PN}-${SLOT}."
-       fi
 }
index 2bb661e689e795212a046a2701890a79e2d7d810..003e868749f91123b36b56c17fa95374ed203e28 100644 (file)
@@ -241,15 +241,4 @@ src_install() {
 
 pkg_postinst() {
        java-vm-2_pkg_postinst
-
-       if use gentoo-vm ; then
-               ewarn "WARNING! You have enabled the gentoo-vm USE flag, making this JDK"
-               ewarn "recognised by the system. This will almost certainly break things."
-       else
-               ewarn "The experimental gentoo-vm USE flag has not been enabled so this JDK"
-               ewarn "will not be recognised by the system. For example, simply calling"
-               ewarn "\"java\" will launch a different JVM. This is necessary until Gentoo"
-               ewarn "fully supports Java ${SLOT}. This JDK must therefore be invoked using its"
-               ewarn "absolute location under ${EPREFIX}/usr/$(get_libdir)/${PN}-${SLOT}."
-       fi
 }