Fix broken autotools handling.
authorDiego Elio Pettenò <flameeyes@gentoo.org>
Thu, 4 Jan 2007 16:53:45 +0000 (16:53 +0000)
committerDiego Elio Pettenò <flameeyes@gentoo.org>
Thu, 4 Jan 2007 16:53:45 +0000 (16:53 +0000)
Package-Manager: portage-2.1.2_rc4-r5

net-p2p/gnunet/ChangeLog
net-p2p/gnunet/gnunet-0.7.0d-r1.ebuild
net-p2p/hx/ChangeLog
net-p2p/hx/hx-0.4.11.ebuild

index b5fb82b53aa71a55b0c027118712344b96fc1db3..4932c4b9a45938be9330f40c98bdbbc3094c7dcd 100644 (file)
@@ -1,6 +1,10 @@
 # ChangeLog for net-p2p/gnunet
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/gnunet/ChangeLog,v 1.48 2006/11/23 17:30:57 vivo Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/gnunet/ChangeLog,v 1.49 2007/01/04 16:48:57 flameeyes Exp $
+
+  04 Jan 2007; Diego Pettenò <flameeyes@gentoo.org>
+  gnunet-0.7.0d-r1.ebuild:
+  Fix broken autotools handling.
 
   23 Nov 2006; Francesco Riosa <vivo@gentoo.org> gnunet-0.6.2b.ebuild,
   gnunet-0.7.0d-r1.ebuild:
index 821fa6a72befce8e138356971cbe0d8fe74db7b1..9616d555429cc36e9c6c364939f61557ba117b9f 100644 (file)
@@ -1,8 +1,11 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/gnunet/gnunet-0.7.0d-r1.ebuild,v 1.4 2006/11/23 17:30:57 vivo Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/gnunet/gnunet-0.7.0d-r1.ebuild,v 1.5 2007/01/04 16:48:57 flameeyes Exp $
 
-inherit eutils libtool
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="latest"
+
+inherit eutils autotools
 
 S="${WORKDIR}/GNUnet-${PV}"
 DESCRIPTION="GNUnet is an anonymous, distributed, reputation based network."
@@ -49,18 +52,18 @@ src_unpack() {
        cd ${S}
        epatch ${FILESDIR}/${P}-nulludp.patch
 
-       # make mysql default sqstore if we do not compile sql support 
+       # make mysql default sqstore if we do not compile sql support
        # (bug #107330)
        ! use sqlite && \
                sed -i 's:default "sqstore_sqlite":default "sqstore_mysql":' \
                contrib/config-daemon.in
 
-       # we do not want to built gtk support with USE=-gtk     
+       # we do not want to built gtk support with USE=-gtk
        if ! use gtk ; then
                sed -i "s:AC_DEFINE_UNQUOTED..HAVE_GTK.*:true:" configure.ac
-               autoconf || die "autoconf failed"
-               libtoolize --copy --force
        fi
+
+       AT_M4DIR="${S}/m4" eautoreconf
 }
 
 src_compile() {
@@ -107,10 +110,10 @@ pkg_postinst() {
        use ipv6 && ewarn "ipv6 support is -very- experimental and prone to bugs"
        einfo
        einfo "To configure"
-       einfo "  1) Add user(s) to the gnunet group"
-       einfo "  2) Run 'gnunet-setup' to generate your client config file"
-       einfo "  3) Run gnunet-setup -d to generate a server config file"
-       einfo "  4) Optionally copy the .gnunet/gnunetd.conf into /etc and"
+       einfo "  1) Add user(s) to the gnunet group"
+       einfo "  2) Run 'gnunet-setup' to generate your client config file"
+       einfo "  3) Run gnunet-setup -d to generate a server config file"
+       einfo "  4) Optionally copy the .gnunet/gnunetd.conf into /etc and"
        einfo "\tuse as a global server config file:"
        einfo "$ gnunet-setup -d"
        einfo "# cp ~/.gnunet/gnunetd.conf /etc/"
index f620101192ca30c61cbca44ea514efe99979b6f7..146ae0c094723ae28bbe85e65d95705d7fc686cf 100644 (file)
@@ -1,6 +1,9 @@
 # ChangeLog for net-p2p/hx
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/hx/ChangeLog,v 1.5 2006/10/29 13:04:40 kang Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/hx/ChangeLog,v 1.6 2007/01/04 16:53:45 flameeyes Exp $
+
+  04 Jan 2007; Diego Pettenò <flameeyes@gentoo.org> hx-0.4.11.ebuild:
+  Fix broken autotools handling.
 
   29 Oct 2006; Guillaume Destuynder <kang@gentoo.org> hx-0.4.11.ebuild:
   Marked stable for x86
index 2ba411c129398f42f500c2093884f9bffab331d7..a8b1c4f1391d67d21caf4f0df2924378a8b95f3d 100644 (file)
@@ -1,6 +1,11 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/hx/hx-0.4.11.ebuild,v 1.2 2006/10/29 13:04:40 kang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/hx/hx-0.4.11.ebuild,v 1.3 2007/01/04 16:53:45 flameeyes Exp $
+
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="latest"
+
+inherit autotools
 
 LICENSE="GPL-2"
 KEYWORDS="x86 ~ppc ~sparc"
@@ -18,9 +23,16 @@ DEPEND="virtual/libc
 
 SLOT="0"
 
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+       unpack ${A}
+
+       cd "${S}"
+       eautoreconf
+}
+
 src_compile() {
-       cd work/${MY_P}
-       libtoolize --copy --force
        econf \
        `use_enable ssl idea` \
        `use_enable ssl cipher` \
@@ -32,7 +44,6 @@ src_compile() {
 }
 
 src_install() {
-       cd ${PF}/work/${MY_P}
        dodoc AUTHORS INSTALL PROBLEMS README* ChangeLog TODO NEWS run/hx/ghxvars run/hx/ghxvars.jp \
        run/hx/hxrc run/hx/hxvars