net-dns/unbound: bump version
authorMarc Schiffbauer <mschiff@gentoo.org>
Mon, 4 Jun 2018 08:17:52 +0000 (10:17 +0200)
committerMarc Schiffbauer <mschiff@gentoo.org>
Mon, 4 Jun 2018 08:18:08 +0000 (10:18 +0200)
Thanks to nemunaire on github ;)

Package-Manager: Portage-2.3.40, Repoman-2.3.9

net-dns/unbound/Manifest
net-dns/unbound/unbound-1.7.1.ebuild [new file with mode: 0644]

index 72f2ebf241ed53ad7e1a5a9bbd5e4bf0ad0fb59c..a047a933fb3ebaf14787321adcd0e90317c7782c 100644 (file)
@@ -6,3 +6,4 @@ DIST unbound-1.6.6.tar.gz 5460482 BLAKE2B af0d9ca0e5eeaebc3a2023dc7179a3bc80952d
 DIST unbound-1.6.7.tar.gz 5466931 BLAKE2B 57a051d5ac6d7fbc3d51613305651987670d0f50fbebf661505b42b6c8980543b34b52a4f9ca9e6ee4dbad59d9acf547b78cf35a691d0c00884da979ae22d8c4 SHA512 6e3d1a057081252183343d0d1b8ace742ab15e8f5244e61287340f49289d7449bed93fbfdaa3194c0e99ca23948f4b33038f75af5c5b26c938004d06fc3031e0
 DIST unbound-1.6.8.tar.gz 5467536 BLAKE2B 06caffbd905c339b3d0667382114bb3e5d5da90988402c8f488f789f9bf6ab87377e6a26aa083a7e9ba3d023f37d3eeba1e069adf8a8a266b23fb8361aeb6e26 SHA512 653d88d5dbc8cf25f7261e4a9869b6591843c7ff27b5d63f979a94505daafbbb61e05d46bedd2d01230355d5f08dd9fe14ed04c5c7340f3f27581b61ad6edfa3
 DIST unbound-1.7.0.tar.gz 5538228 BLAKE2B a825e2cbef74b3a78f9802056d6f0992f77e0d40d4d28889c98b9ffa224ec3281b6873eab59134dcca8dc56bdd17202b3817dd28ab30d0a0bb72d749426b7675 SHA512 49b07643da2a89d8ceedce1295f550f74a76f4f11c2df54df55e9c42f03bad1b133789c7b36fb3c4f37d6b331ac302ecfd1249e8ebaaa4333beda8fa250b61d9
+DIST unbound-1.7.1.tar.gz 5565938 BLAKE2B 423dde8a13ea3539d86eade96507e6cdb4ac816393e99f58b4e0dc74a79c31bae57c87924ef737a567cc338d02d672f6c059c86d2f28a634f06e5f9a339f4260 SHA512 99a68abf1f60f6ea80cf2973906df44da9c577d8cac969824af1ce9ca385a2e84dd684937480da87cb73c7dc41ad5c00b0013ec74103eadb8fd7dc6f98a89255
diff --git a/net-dns/unbound/unbound-1.7.1.ebuild b/net-dns/unbound/unbound-1.7.1.ebuild
new file mode 100644 (file)
index 0000000..9edf230
--- /dev/null
@@ -0,0 +1,156 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils flag-o-matic multilib-minimal python-single-r1 systemd user
+
+MY_P=${PN}-${PV/_/}
+DESCRIPTION="A validating, recursive and caching DNS resolver"
+HOMEPAGE="http://unbound.net/"
+SRC_URI="http://unbound.net/downloads/${MY_P}.tar.gz"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~x86"
+IUSE="debug dnscrypt dnstap +ecdsa gost libressl python selinux static-libs systemd test threads"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+# Note: expat is needed by executable only but the Makefile is custom
+# and doesn't make it possible to easily install the library without
+# the executables. MULTILIB_USEDEP may be dropped once build system
+# is fixed.
+
+CDEPEND=">=dev-libs/expat-2.1.0-r3[${MULTILIB_USEDEP}]
+       >=dev-libs/libevent-2.0.21:0=[${MULTILIB_USEDEP}]
+       libressl? ( >=dev-libs/libressl-2.2.4:0[${MULTILIB_USEDEP}] )
+       !libressl? ( >=dev-libs/openssl-1.0.1h-r2:0[${MULTILIB_USEDEP}] )
+       dnscrypt? ( dev-libs/libsodium[${MULTILIB_USEDEP}] )
+       dnstap? (
+               dev-libs/fstrm[${MULTILIB_USEDEP}]
+               >=dev-libs/protobuf-c-1.0.2-r1[${MULTILIB_USEDEP}]
+       )
+       ecdsa? (
+               !libressl? ( dev-libs/openssl:0[-bindist] )
+       )
+       python? ( ${PYTHON_DEPS} )"
+
+DEPEND="${CDEPEND}
+       python? ( dev-lang/swig )
+       test? (
+               net-dns/ldns-utils[examples]
+               dev-util/splint
+               app-text/wdiff
+       )
+       systemd? ( sys-apps/systemd )
+       virtual/pkgconfig"
+
+RDEPEND="${CDEPEND}
+       selinux? ( sec-policy/selinux-bind )"
+
+# bug #347415
+RDEPEND="${RDEPEND}
+       net-dns/dnssec-root"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+       enewgroup unbound
+       enewuser unbound -1 -1 /etc/unbound unbound
+       # improve security on existing installs (bug #641042)
+       # as well as new installs where unbound homedir has just been created
+       if [[ -d "${ROOT}/etc/unbound" ]]; then
+               chown --no-dereference --from=unbound root "${ROOT}/etc/unbound"
+       fi
+
+       use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+       # To avoid below error messages, set 'trust-anchor-file' to same value in
+       # 'auto-trust-anchor-file'.
+       # [23109:0] error: Could not open autotrust file for writing,
+       # /etc/dnssec/root-anchors.txt: Permission denied
+       epatch "${FILESDIR}"/${PN}-1.5.7-trust-anchor-file.patch
+
+       # required for the python part
+       multilib_copy_sources
+}
+
+src_configure() {
+       [[ ${CHOST} == *-darwin* ]] || append-ldflags -Wl,-z,noexecstack
+       multilib-minimal_src_configure
+}
+
+multilib_src_configure() {
+       econf \
+               $(use_enable debug) \
+               $(use_enable gost) \
+               $(use_enable dnscrypt) \
+               $(use_enable dnstap) \
+               $(use_enable ecdsa) \
+               $(use_enable static-libs static) \
+               $(use_enable systemd) \
+               $(multilib_native_use_with python pythonmodule) \
+               $(multilib_native_use_with python pyunbound) \
+               $(use_with threads pthreads) \
+               --disable-flto \
+               --disable-rpath \
+               --with-libevent="${EPREFIX}"/usr \
+               --with-pidfile="${EPREFIX}"/var/run/unbound.pid \
+               --with-rootkey-file="${EPREFIX}"/etc/dnssec/root-anchors.txt \
+               --with-ssl="${EPREFIX}"/usr \
+               --with-libexpat="${EPREFIX}"/usr
+
+               # http://unbound.nlnetlabs.nl/pipermail/unbound-users/2011-April/001801.html
+               # $(use_enable debug lock-checks) \
+               # $(use_enable debug alloc-checks) \
+               # $(use_enable debug alloc-lite) \
+               # $(use_enable debug alloc-nonregional) \
+}
+
+multilib_src_install_all() {
+       prune_libtool_files --modules
+       use python && python_optimize
+
+       newinitd "${FILESDIR}"/unbound.initd unbound
+       newconfd "${FILESDIR}"/unbound.confd unbound
+
+       systemd_dounit "${FILESDIR}"/unbound.service
+       systemd_dounit "${FILESDIR}"/unbound.socket
+       systemd_newunit "${FILESDIR}"/unbound_at.service "unbound@.service"
+       systemd_dounit "${FILESDIR}"/unbound-anchor.service
+
+       dodoc doc/{README,CREDITS,TODO,Changelog,FEATURES}
+
+       # bug #315519
+       dodoc contrib/unbound_munin_
+
+       docinto selinux
+       dodoc contrib/selinux/*
+
+       exeinto /usr/share/${PN}
+       doexe contrib/update-anchor.sh
+
+       # create space for auto-trust-anchor-file...
+       keepdir /etc/unbound/var
+       # ... and point example config to it
+       sed -i '/# auto-trust-anchor-file:/s,/etc/dnssec/root-anchors.txt,/etc/unbound/var/root-anchors.txt,' "${ED}/etc/unbound/unbound.conf"
+}
+
+pkg_postinst() {
+       # make var/ writable by unbound
+       if [[ -d "${ROOT}/etc/unbound/var" ]]; then
+               chown --no-dereference --from=root unbound: "${ROOT}/etc/unbound/var"
+       fi
+       einfo ""
+       einfo "If you want unbound to automatically update the root-anchor file for DNSSEC validation"
+       einfo "set 'auto-trust-anchor-file: /etc/unbound/var/root-anchors.txt' in /etc/unbound/unbound.conf"
+       einfo "and run"
+       einfo ""
+       einfo "  su -s /bin/sh -c '/usr/sbin/unbound-anchor -a /etc/unbound/var/root-anchors.txt' unbound"
+       einfo ""
+       einfo "as root to create it initially before starting unbound for the first time after enabling this."
+       einfo ""
+}