Use make_desktop_entry rather than a provided desktop file, use the right icon locati...
authorAlexis Ballier <aballier@gentoo.org>
Sun, 7 Jan 2007 14:28:39 +0000 (14:28 +0000)
committerAlexis Ballier <aballier@gentoo.org>
Sun, 7 Jan 2007 14:28:39 +0000 (14:28 +0000)
Package-Manager: portage-2.1.2_rc4-r6

media-sound/gnome-alsamixer/ChangeLog
media-sound/gnome-alsamixer/files/digest-gnome-alsamixer-0.9.6
media-sound/gnome-alsamixer/gnome-alsamixer-0.9.6.ebuild

index 686581c5bd6d094821e8f9b3981c4be0759613b5..8dd87bd684efbd3bfcbf978295574ffc59dd8361 100644 (file)
@@ -1,6 +1,11 @@
 # ChangeLog for media-sound/gnome-alsamixer
-# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/gnome-alsamixer/ChangeLog,v 1.15 2006/05/08 04:20:49 tcort Exp $
+# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/gnome-alsamixer/ChangeLog,v 1.16 2007/01/07 14:28:39 aballier Exp $
+
+  07 Jan 2007; Alexis Ballier <aballier@gentoo.org>
+  -files/gnome-alsamixer.desktop, gnome-alsamixer-0.9.6.ebuild:
+  Use make_desktop_entry rather than a provided desktop file, use the right
+  icon location, bug #159755
 
   08 May 2006; <tcort@gentoo.org> gnome-alsamixer-0.9.6.ebuild:
   Removed COPYING and INSTALL from dodoc.
index ed95d98c4809eb367d8097f2ac01cb8bc3515bd3..738258aec80d69fae10eca918e3e24b4dfd5a1d6 100644 (file)
@@ -1 +1,3 @@
 MD5 387623cfeb079d78325eed2d6bc94251 gnome-alsamixer-0.9.6.tar.gz 93557
+RMD160 3653444fc6b65f8fc10e06499c2bdd735ee71943 gnome-alsamixer-0.9.6.tar.gz 93557
+SHA256 50ca29e7dc92673700bd302dacfe66a14d0b2c2fb1c8e1521c6306bb8d7c818d gnome-alsamixer-0.9.6.tar.gz 93557
index 27af2c25119915d93e493a9f29108f4d54b9de56..7127901efdc7990c73e8fb0bcfcee1fcab6db438 100644 (file)
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/gnome-alsamixer/gnome-alsamixer-0.9.6.ebuild,v 1.12 2006/05/08 04:20:49 tcort Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/gnome-alsamixer/gnome-alsamixer-0.9.6.ebuild,v 1.13 2007/01/07 14:28:39 aballier Exp $
 
 inherit eutils fdo-mime
 
@@ -28,9 +28,8 @@ src_unpack() {
 src_install() {
        make DESTDIR=${D} install || die
 
-       # manuall install menu entry
-       insinto /usr/share/applications
-       doins ${FILESDIR}/${PN}.desktop
+       make_desktop_entry gnome-alsamixer "Gnome Alsa Mixer"\
+               /usr/share/pixmaps/${PN}/${PN}-icon.png
 
        dodoc AUTHORS ChangeLog
 }