sys-libs/libseccomp: bump to 2.4.1
authorMike Gilbert <floppym@gentoo.org>
Thu, 18 Apr 2019 15:40:04 +0000 (11:40 -0400)
committerMike Gilbert <floppym@gentoo.org>
Thu, 18 Apr 2019 15:40:31 +0000 (11:40 -0400)
Package-Manager: Portage-2.3.62_p4, Repoman-2.3.12_p87
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
sys-libs/libseccomp/Manifest
sys-libs/libseccomp/libseccomp-2.4.1.ebuild [new file with mode: 0644]

index 7d314750f31aa21204ccad94f3cc5c87e0d2c75e..00c6fcfc168298cb2d15e556f3e284997c4d023f 100644 (file)
@@ -1 +1,2 @@
 DIST libseccomp-2.4.0.tar.gz 604987 BLAKE2B 2dd84f2c08d40a61dfe4fdc47a9dcdad2701e2918cdcdeae2d15a66eb114221866121bab11a8292f3bd31493b6cd7b370d0728976cb1bbfd0dbb9e32127b9045 SHA512 daa4a32c6c2b2f39aa9db1a4606619f9faeffcd2fca00c25ac5cf95d0405639ec21203293be7c8341317a05b18fd9f603a201544457cac91bf034a0bbd4dfc88
+DIST libseccomp-2.4.1.tar.gz 606860 BLAKE2B f80f11ef4e03fc9f59fdd38466e32b081e9858473266942b22a1bd1afbd480d21e9c72f9c33e197349fcd2658361f84ee1ee371f73aa5dfe19561472fec8c1ed SHA512 1fe47ebb032635ba1b1cbefb505a0c103bae659844d1bf106d03e7f28b3c470726f7b0dbbe76d10ab89501630dc4f20b162c2eeefa22394eb632f803ae62ccc5
diff --git a/sys-libs/libseccomp/libseccomp-2.4.1.ebuild b/sys-libs/libseccomp/libseccomp-2.4.1.ebuild
new file mode 100644 (file)
index 0000000..96b995d
--- /dev/null
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# TODO: Add python support.
+
+EAPI=6
+
+inherit multilib-minimal
+
+DESCRIPTION="high level interface to Linux seccomp filter"
+HOMEPAGE="https://github.com/seccomp/libseccomp"
+SRC_URI="https://github.com/seccomp/libseccomp/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~s390 ~x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+
+# We need newer kernel headers; we don't keep strict control of the exact
+# version here, just be safe and pull in the latest stable ones. #551248
+DEPEND=">=sys-kernel/linux-headers-4.3"
+
+src_prepare() {
+       default
+       sed -i \
+               -e '/_LDFLAGS/s:-static::' \
+               tools/Makefile.in || die
+}
+
+multilib_src_configure() {
+       local myeconfargs=(
+               $(use_enable static-libs static)
+               --disable-python
+       )
+       ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_install_all() {
+       find "${ED}" -name libseccomp.la -delete
+       einstalldocs
+}