net-irc/ngircd: bump to version 24
authorMoritz Kick <gentoo@blackphoenix.de>
Fri, 27 Jan 2017 21:44:03 +0000 (22:44 +0100)
committerMichael Palimaka <kensington@gentoo.org>
Thu, 23 Feb 2017 08:39:20 +0000 (19:39 +1100)
- Updated copyright years
- Updated ebuild to EAPI6
- Cleaned up USE=ssl
- Added USE=test and dependencies to prepare for unrestricting
  FEATURES=test (one testcase is currently failing)

Signed-off-by: Moritz Kick <gentoo@blackphoenix.de>
net-irc/ngircd/Manifest
net-irc/ngircd/ngircd-24.ebuild [new file with mode: 0644]

index 098b7eb75b20004fc2b72cafe7ec930d8e40bdc1..8509224be6eb2c6f07d31912b624f3d47cfcb9e1 100644 (file)
@@ -1 +1,2 @@
 DIST ngircd-23.tar.gz 517686 SHA256 99b8b67a975a9ae9b81c96bdee02133a10f515c718825d34cedcb64f1fc95e73 SHA512 714fbb4af12335e62c615fa1e8de9c7366c4c6da6af9b334019ba900dce072067f7b08199de8c96aad5dd4b9b786b57d536ba9dc92c62b37d2ae11960dbd01b1 WHIRLPOOL 06e1b3a9675277c980898118e71e9a6c08de998c93919f431ecd7505f64dc57617beef885aae5e5c72b27cd1df3c89204dbc2101c1f4a30970fceb78a7825441
+DIST ngircd-24.tar.gz 524968 SHA256 3e00a7da52c81fc1e02bb996a27bf43da905ba7037bf8c6bb3bd13321e0c85ab SHA512 66d1b9576c03d0a70be17a235f2da50ee661646cd428d18a6c61975407671dd4a3a545069258536773b27d4fb63523527366bbbf4f35cb08111dc60842924395 WHIRLPOOL 5c163820638cad6e2dcad3118b4e35113696aa16501f81c177ed68e28cdebfaf37bd65fcd12c3d750a8f3c01fb5af40068ac812d76bb578074bdbe7dbe08f763
diff --git a/net-irc/ngircd/ngircd-24.ebuild b/net-irc/ngircd/ngircd-24.ebuild
new file mode 100644 (file)
index 0000000..43f1106
--- /dev/null
@@ -0,0 +1,93 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+inherit user
+
+DESCRIPTION="An IRC server written from scratch"
+HOMEPAGE="https://ngircd.barton.de/"
+SRC_URI="https://arthur.barton.de/pub/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x64-macos"
+IUSE="debug gnutls iconv ident ipv6 libressl pam ssl tcpd test zlib"
+
+RDEPEND="
+       iconv? ( virtual/libiconv )
+       ident? ( net-libs/libident )
+       pam? ( virtual/pam )
+       ssl? (
+               gnutls? ( net-libs/gnutls:= )
+               !gnutls? (
+                       !libressl? ( dev-libs/openssl:0= )
+                       libressl? ( dev-libs/libressl:0= )
+               )
+       )
+       tcpd? ( sys-apps/tcp-wrappers )
+       zlib? ( sys-libs/zlib )
+"
+
+DEPEND="${RDEPEND}
+       >=sys-apps/sed-4
+       test? (
+               dev-tcltk/expect
+               net-misc/netkit-telnetd
+       )
+"
+
+# Testsuite fails server-login-test
+RESTRICT="test"
+
+src_prepare() {
+       default
+
+       if ! use prefix; then
+               sed -i \
+                       -e "s:;ServerUID = 65534:ServerUID = ngircd:" \
+                       -e "s:;ServerGID = 65534:ServerGID = nogroup:" \
+                       doc/sample-ngircd.conf.tmpl || die
+       fi
+}
+
+src_configure() {
+       local myconf=(
+               --sysconfdir="${EPREFIX}"/etc/"${PN}"
+               $(use_enable debug sniffer)
+               $(use_enable debug)
+               $(use_enable ipv6)
+               $(use_with iconv)
+               $(use_with ident)
+               $(use_with pam)
+               $(use_with tcpd tcp-wrappers)
+               $(use_with zlib)
+       )
+
+       if use ssl; then
+               myconf+=(
+                       $(use_with !gnutls openssl)
+                       $(use_with gnutls)
+               )
+       else
+               myconf+=(
+                       --without-gnutls
+                       --without-openssl
+               )
+       fi
+
+       econf "${myconf[@]}"
+}
+
+src_install() {
+       default
+       newinitd "${FILESDIR}"/ngircd.init-r1.d ngircd
+}
+
+pkg_postinst() {
+       if ! use prefix; then
+               enewuser ngircd
+               chown ngircd "${EROOT%/}"/etc/ngircd/ngircd.conf || die
+       fi
+}