dev-vcs/subversion: Rename USE=kde -> kwallet
authorAndreas Sturmlechner <asturm@gentoo.org>
Sat, 25 Feb 2017 12:08:49 +0000 (13:08 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sat, 25 Feb 2017 19:42:25 +0000 (20:42 +0100)
Gentoo-bug: 609336

Package-Manager: Portage-2.3.3, Repoman-2.3.1

dev-vcs/subversion/metadata.xml
dev-vcs/subversion/subversion-1.8.17.ebuild
dev-vcs/subversion/subversion-1.9.5.ebuild
profiles/arch/arm/package.use.mask
profiles/arch/powerpc/package.use.mask
profiles/arch/powerpc/package.use.stable.mask
profiles/arch/powerpc/ppc64/package.use.mask

index 9e61a1496e6f0edc1e1fefdb2c6b5c48bc520792..112e883a106d38862cd7d6069dae20ab8157007d 100644 (file)
@@ -10,5 +10,6 @@
                <flag name="dso">Enable runtime module search</flag>
                <flag name="extras">Install extra scripts (examples, tools, hooks)</flag>
                <flag name="http">Enable http support using <pkg>net-libs/serf</pkg></flag>
+               <flag name="kwallet">Enable encrypted storage of passwords with <pkg>kde-apps/kwalletd</pkg></flag>
        </use>
 </pkgmetadata>
index 7849a8fb67953ab7d082d8daa256c37fe70017c5..494a1b2f3ae1f4a703301b06f39fc8baa35b769e 100644 (file)
@@ -20,28 +20,29 @@ S="${WORKDIR}/${MY_P}"
 LICENSE="Subversion GPL-2"
 SLOT="0"
 KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="apache2 berkdb ctypes-python debug doc +dso extras gnome-keyring +http java kde nls perl python ruby sasl test vim-syntax"
+IUSE="apache2 berkdb ctypes-python debug doc +dso extras gnome-keyring +http java kwallet nls perl python ruby sasl test vim-syntax"
 
-COMMON_DEPEND=">=dev-db/sqlite-3.7.12
+COMMON_DEPEND="
+       app-arch/bzip2
+       >=dev-db/sqlite-3.7.12
        >=dev-libs/apr-1.3:1
        >=dev-libs/apr-util-1.3:1
        dev-libs/expat
        sys-apps/file
        sys-libs/zlib
-       app-arch/bzip2
        berkdb? ( >=sys-libs/db-4.0.14:= )
        ctypes-python? ( ${PYTHON_DEPS} )
        gnome-keyring? ( dev-libs/glib:2 sys-apps/dbus gnome-base/libgnome-keyring )
-       kde? ( sys-apps/dbus dev-qt/qtcore:4 dev-qt/qtdbus:4 dev-qt/qtgui:4 kde-frameworks/kdelibs:4 )
+       http? ( >=net-libs/serf-1.2.1 )
+       kwallet? ( sys-apps/dbus dev-qt/qtcore:4 dev-qt/qtdbus:4 dev-qt/qtgui:4 kde-frameworks/kdelibs:4 )
        perl? ( dev-lang/perl:= )
        python? ( ${PYTHON_DEPS} )
        ruby? ( ${RUBY_DEPS} )
-       sasl? ( dev-libs/cyrus-sasl )
-       http? ( >=net-libs/serf-1.2.1 )"
+       sasl? ( dev-libs/cyrus-sasl )"
 RDEPEND="${COMMON_DEPEND}
        apache2? ( www-servers/apache[apache2_modules_dav] )
        java? ( >=virtual/jre-1.5 )
-       kde? ( kde-apps/kwalletd:4 )
+       kwallet? ( kde-apps/kwalletd:4 )
        nls? ( virtual/libintl )
        perl? ( dev-perl/URI )"
 # Note: ctypesgen doesn't need PYTHON_USEDEP, it's used once
@@ -52,7 +53,7 @@ DEPEND="${COMMON_DEPEND}
        gnome-keyring? ( virtual/pkgconfig )
        http? ( virtual/pkgconfig )
        java? ( >=virtual/jdk-1.5 )
-       kde? ( virtual/pkgconfig )
+       kwallet? ( virtual/pkgconfig )
        nls? ( sys-devel/gettext )
        test? ( ${PYTHON_DEPS} )"
 
@@ -235,7 +236,7 @@ src_configure() {
                $(use_with gnome-keyring) \
                $(use_enable java javahl) \
                $(use_with java jdk "${JAVA_HOME}") \
-               $(use_with kde kwallet) \
+               $(use_with kwallet) \
                $(use_enable nls) \
                $(use_with sasl) \
                $(use_with http serf) \
index 61dbb6286f38137c4e64d952b2895bbb61806282..cdf47b60fcf2961088c2dd14a800d393acbc3493 100644 (file)
@@ -20,28 +20,29 @@ S="${WORKDIR}/${MY_P}"
 LICENSE="Subversion GPL-2"
 SLOT="0"
 KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="apache2 berkdb ctypes-python debug doc +dso extras gnome-keyring +http java kde nls perl python ruby sasl test vim-syntax"
+IUSE="apache2 berkdb ctypes-python debug doc +dso extras gnome-keyring +http java kwallet nls perl python ruby sasl test vim-syntax"
 
-COMMON_DEPEND=">=dev-db/sqlite-3.7.12
+COMMON_DEPEND="
+       app-arch/bzip2
+       >=dev-db/sqlite-3.7.12
        >=dev-libs/apr-1.3:1
        >=dev-libs/apr-util-1.3:1
        dev-libs/expat
        sys-apps/file
        sys-libs/zlib
-       app-arch/bzip2
        berkdb? ( >=sys-libs/db-4.0.14:= )
        ctypes-python? ( ${PYTHON_DEPS} )
        gnome-keyring? ( dev-libs/glib:2 sys-apps/dbus gnome-base/libgnome-keyring )
-       kde? ( sys-apps/dbus dev-qt/qtcore:4 dev-qt/qtdbus:4 dev-qt/qtgui:4 kde-frameworks/kdelibs:4 )
+       http? ( >=net-libs/serf-1.3.4 )
+       kwallet? ( sys-apps/dbus dev-qt/qtcore:4 dev-qt/qtdbus:4 dev-qt/qtgui:4 kde-frameworks/kdelibs:4 )
        perl? ( dev-lang/perl:= )
        python? ( ${PYTHON_DEPS} )
        ruby? ( ${RUBY_DEPS} )
-       sasl? ( dev-libs/cyrus-sasl )
-       http? ( >=net-libs/serf-1.3.4 )"
+       sasl? ( dev-libs/cyrus-sasl )"
 RDEPEND="${COMMON_DEPEND}
        apache2? ( www-servers/apache[apache2_modules_dav] )
        java? ( >=virtual/jre-1.5 )
-       kde? ( kde-apps/kwalletd:4 )
+       kwallet? ( kde-apps/kwalletd:4 )
        nls? ( virtual/libintl )
        perl? ( dev-perl/URI )"
 # Note: ctypesgen doesn't need PYTHON_USEDEP, it's used once
@@ -52,7 +53,7 @@ DEPEND="${COMMON_DEPEND}
        gnome-keyring? ( virtual/pkgconfig )
        http? ( virtual/pkgconfig )
        java? ( >=virtual/jdk-1.5 )
-       kde? ( virtual/pkgconfig )
+       kwallet? ( virtual/pkgconfig )
        nls? ( sys-devel/gettext )
        test? ( ${PYTHON_DEPS} )"
 
@@ -228,7 +229,7 @@ src_configure() {
                $(use_with gnome-keyring) \
                $(use_enable java javahl) \
                $(use_with java jdk "${JAVA_HOME}") \
-               $(use_with kde kwallet) \
+               $(use_with kwallet) \
                $(use_enable nls) \
                $(use_with sasl) \
                $(use_with http serf) \
index 66529088d5b47a10caee7033125f2fbb4b88d5c5..294a11f76c359f485e801e6bfe8d09bc44f9afbd 100644 (file)
@@ -470,7 +470,7 @@ net-misc/mediatomb lastfm
 
 # Raúl Porcel <armin76@gentoo.org> (28 Mar 2010)
 # Needs kde-4 stable
-dev-vcs/subversion kde
+dev-vcs/subversion kwallet
 
 # Markus Meier <maekke@gentoo.org> (27 Sep 2009)
 # mask media-gfx/imagemagick[autotrace] as autotrace is not keyworded
index ffe7835502012d3920d94f7db1d876b8b417df8f..97cfe5fdcbd0b408d6b8298b2adcd7fb601291bc 100644 (file)
@@ -22,7 +22,7 @@ dev-python/PyQt5 bluetooth location webengine
 # Michael Palimaka <kensington@gentoo.org> (07 Jul 2016)
 # Requires unkeyworded dependencies
 app-misc/hachoir-metadata kde
-dev-vcs/subversion kde
+dev-vcs/subversion kwallet
 games-arcade/jumpnbump kde
 kde-apps/katepart handbook
 kde-frameworks/kdelibs handbook policykit
index 9593a9643a13ed1b1f334e84766189b8c849f0dc..02effc4eca3c4e17e4d47947f92e9445ba207ff2 100644 (file)
@@ -35,7 +35,7 @@ media-video/vlc opencv
 # Dependencies not stable
 app-arch/p7zip kde
 app-i18n/uim kde
-dev-vcs/subversion kde
+dev-vcs/subversion kwallet
 games-arcade/jumpnbump kde
 media-video/vlc kde
 net-irc/quassel kde
index c28e5fa8dc96bbe76467e2ec696eb10adda72455..a33a9f78f5a7249e8404e7fc665100a1fb3f9ef7 100644 (file)
@@ -101,7 +101,7 @@ kde-apps/marble     gps
 # These need stable kdelibs-4.
 app-i18n/uim kde
 app-arch/p7zip kde
-dev-vcs/subversion kde
+dev-vcs/subversion kwallet
 media-video/vlc kde
 net-libs/libproxy kde