dev-libs/aws-sdk-cpp: Version bump to 1.7.178
authorSven Eden <yamakuzure@gmx.net>
Thu, 15 Aug 2019 16:25:29 +0000 (18:25 +0200)
committerJoonas Niilola <juippis@gentoo.org>
Fri, 20 Sep 2019 15:23:33 +0000 (18:23 +0300)
Closes: https://bugs.gentoo.org/666494
Closes: https://bugs.gentoo.org/665540
Signed-off-by: Sven Eden <yamakuzure@gmx.net>
Bug: https://bugs.gentoo.org/666494
Package-Manager: Portage-2.3.71, Repoman-2.3.17
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
dev-libs/aws-sdk-cpp/Manifest
dev-libs/aws-sdk-cpp/aws-sdk-cpp-1.7.178.ebuild [new file with mode: 0644]
dev-libs/aws-sdk-cpp/metadata.xml

index 3e0506583819b823972bf728695756628aaa915d..94388e17a89710c592f437d4478c48a89920e190 100644 (file)
@@ -1 +1,2 @@
 DIST aws-sdk-cpp-1.5.17.tar.gz 16424254 BLAKE2B 3beeda2085a487b007c088b149a84b7c561ebc75a3a431d2c0139d1f2c6b3c1182e5e00df349436cd5d1f25fbbf60a963db69b562503903cd4a5ccf4db01aac0 SHA512 1a69098c0ddaba46e0d336875029dbdea0d92a3165ee7eed77d1425ea375b401138235f4fa71604fd3df89db633664cd9c36c1fad7989d974f28f7e1785b95c0
+DIST aws-sdk-cpp-1.7.178.tar.gz 22589166 BLAKE2B 40364307fb676a89cf2b363d02dfa95e03c6e0b02e34c3d5376820dd7721f13108bf1f1713ff5f39dfc7d98f5cd368718601a397f55c4e26a37cd62d346cbf70 SHA512 b5c969d8b0b9ca5aa7b6af762bf79647ee407cae2686b90c4acefb6a113cf4e7a582e4e5aebd2e6289685e6ac373f9f994e57cd34bd12543b2b36142e00df478
diff --git a/dev-libs/aws-sdk-cpp/aws-sdk-cpp-1.7.178.ebuild b/dev-libs/aws-sdk-cpp/aws-sdk-cpp-1.7.178.ebuild
new file mode 100644 (file)
index 0000000..1c20c4f
--- /dev/null
@@ -0,0 +1,150 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit cmake-utils python-single-r1
+
+DESCRIPTION="AWS SDK for C++"
+HOMEPAGE="https://aws.amazon.com/sdk-for-cpp/"
+SRC_URI="https://github.com/aws/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+MODULES=(
+       access-management apigateway backup batch budgets chime cloud-desktop cloud-dev cloud-media cloud-mobile
+       cloudformation cloudfront cloudhsm cloudsearch cloudwatch cognito config dlm ec2 ecr ecs eks elasticache
+       elasticbeanstalk elasticloadbalancing elasticmapreduce email es events fsx globalaccelerator iot kinesis kms
+       lambda lex license-manager lightsail machinelearning macie managedblockchain marketplace opsworks organizations
+       other personalize polly queues rds rekognition resource-groups route53 s3 sagemaker secretsmanager securityhub
+       serverlessrepo shield sns sqs textract transcribe translate waf
+)
+
+IUSE="+http libressl +rtti +ssl static-libs test unity-build ${MODULES[*]}"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="
+       http? ( net-misc/curl:= )
+       polly? ( media-sound/pulseaudio )
+       ssl? (
+               !libressl? ( dev-libs/openssl:0= )
+               libressl? ( dev-libs/libressl:0= )
+       )
+       dev-libs/aws-c-common
+       dev-libs/aws-checksums
+       dev-libs/aws-c-event-stream
+       sys-libs/zlib
+"
+RDEPEND="
+       ${DEPEND}
+       ${PYTHON_DEPS}
+"
+
+src_configure() {
+       local mybuildtargets="core"
+
+       for module in ${MODULES[@]}; do
+               if use ${module}; then
+                       if [ "${module}" = "access-management" ] ; then
+                               mybuildtargets+=";${module};acm;acm-pca;iam;identity-management;ram;sts"
+                       elif [ "${module}" = "apigateway" ] ; then
+                               mybuildtargets+=";${module};apigatewaymanagementapi;apigatewayv2"
+                       elif [ "${module}" = "budgets" ] ; then
+                               mybuildtargets+=";${module};ce;cur"
+                       elif [ "${module}" = "cloud-desktop" ] ; then
+                               mybuildtargets+=";appstream;workdocs;worklink;workmail;workspaces"
+                       elif [ "${module}" = "cloud-dev" ] ; then
+                               mybuildtargets+=";cloud9;codebuild;codecommit;codedeploy;codepipeline;codestar;xray"
+                               if ! use "queues"; then
+                                       mybuildtargets+=";queues"
+                               fi
+                       elif [ "${module}" = "cloud-media" ] ; then
+                               mybuildtargets+=";elastictranscoder;mediaconnect;mediaconvert;medialive;mediapackage"
+                               mybuildtargets+=";mediapackage-vod;mediastore;mediastore-data;mediatailor"
+                       elif [ "${module}" = "cloud-mobile" ] ; then
+                               mybuildtargets+=";amplify;appsync;devicefarm;mobile;mobileanalytics;pinpoint"
+                               mybuildtargets+=";pinpoint-email;sms-voice"
+                               if ! use "sns"; then
+                                       mybuildtargets+=";sns"
+                               fi
+                       elif [ "${module}" = "cloudhsm" ] ; then
+                               mybuildtargets+=";${module};cloudhsmv2"
+                       elif [ "${module}" = "cloudsearch" ] ; then
+                               mybuildtargets+=";${module};cloudsearchdomain"
+                       elif [ "${module}" = "cloudwatch" ] ; then
+                               mybuildtargets+=";application-insights;appmesh;cloudtrail;guardduty;health;inspector"
+                               mybuildtargets+=";logs;monitoring"
+                       elif [ "${module}" = "cognito" ] ; then
+                               mybuildtargets+=";cognito-identity;cognito-idp;cognito-sync"
+                       elif [ "${module}" = "dynamodb" ] ; then
+                               mybuildtargets+=";${module};dax;dynamodbstreams"
+                       elif [ "${module}" = "ec2" ] ; then
+                               mybuildtargets+=";${module};autoscaling;autoscaling-plans;application-autoscaling"
+                               mybuildtargets+=";ec2-instance-connect;elasticfilesystem"
+                       elif [ "${module}" = "elasticloadbalancing" ] ; then
+                               mybuildtargets+=";${module};elasticloadbalancingv2"
+                       elif [ "${module}" = "events" ] ; then
+                               mybuildtargets+=";${module};eventbridge"
+                       elif [ "${module}" = "iot" ] ; then
+                               mybuildtargets+=";${module};greengrass;iot1click-devices;iot1click-projects"
+                               mybuildtargets+=";iotanalytics;iot-data;iotevents;iotevents-data;iot-jobs-data"
+                               mybuildtargets+=";iotthingsgraph"
+                       elif [ "${module}" = "kinesis" ] ; then
+                               mybuildtargets+=";${module};firehose;kinesisanalytics;kinesisanalyticsv2;kinesisvideo"
+                               mybuildtargets+=";kinesis-video-archived-media;kinesis-video-media"
+                       elif [ "${module}" = "lex" ] ; then
+                               mybuildtargets+=";${module};lex-models"
+                       elif [ "${module}" = "marketplace" ] ; then
+                               mybuildtargets+=";marketplacecommerceanalytics;marketplace-entitlement"
+                               mybuildtargets+=";meteringmarketplace;pricing"
+                       elif [ "${module}" = "opsworks" ] ; then
+                               mybuildtargets+=";${module};opsworkscm"
+                       elif [ "${module}" = "other" ] ; then
+                               mybuildtargets+=";AWSMigrationHub;alexaforbusiness;clouddirectory;comprehend"
+                               mybuildtargets+=";comprehendmedical;connect;datapipeline;datasync;directconnect"
+                               mybuildtargets+=";discovery;dms;docdb;ds;dynamodb;gamelift;glue;groundstation"
+                               mybuildtargets+=";importexport;kafka;lakeformation;mq;mturk-requester;neptune"
+                               mybuildtargets+=";quicksight;redshift;robomaker;sdb;service-quotas;servicecatalog"
+                               mybuildtargets+=";servicediscovery;signer;sms;snowball;ssm;states;storagegateway"
+                               mybuildtargets+=";support;swf"
+                       elif [ "${module}" = "personalize" ] ; then
+                               mybuildtargets+=";${module};personalize-events;personalize-runtime"
+                       elif [ "${module}" = "polly" ] ; then
+                               mybuildtargets+=";${module};text-to-speech"
+                       elif [ "${module}" = "rds" ] ; then
+                               mybuildtargets+=";${module};pi;rds-data"
+                       elif [ "${module}" = "resource-groups" ] ; then
+                               mybuildtargets+=";${module};resourcegroupstaggingapi"
+                       elif [ "${module}" = "route53" ] ; then
+                               mybuildtargets+=";${module};route53domains;route53resolver"
+                       elif [ "${module}" = "s3" ] ; then
+                               mybuildtargets+=";${module};athena;awstransfer;glacier;s3-encryption;s3control;transfer"
+                       elif [ "${module}" = "sagemaker" ] ; then
+                               mybuildtargets+=";${module};sagemaker-runtime"
+                       elif [ "${module}" = "transcribe" ] ; then
+                               mybuildtargets+=";${module};transcribestreaming"
+                       elif [ "${module}" = "waf" ] ; then
+                               mybuildtargets+=";${module};fms;waf-regional"
+                       else
+                               mybuildtargets+=";${module}"
+                       fi
+               fi
+       done
+
+       local mycmakeargs=(
+               -DBUILD_DEPS=NO
+               -DBUILD_ONLY="${mybuildtargets}"
+               -DBUILD_SHARED_LIBS=$(usex !static-libs)
+               -DCPP_STANDARD=17
+               -DENABLE_RTTI=$(usex rtti)
+               -DENABLE_TESTING=$(usex test)
+               -DENABLE_UNITY_BUILD=$(usex unity-build)
+               -DNO_ENCRYPTION=$(usex !ssl)
+               -DNO_HTTP_CLIENT=$(usex !http)
+       )
+       cmake-utils_src_configure
+}
index 4520e67d29ef26fe207eda0e1bca7cb0c4f85fd2..15a0e912338c30b93797b9d8a77f87fd8e0db246 100644 (file)
@@ -8,6 +8,15 @@
                <email>proxy-maint@gentoo.org</email>
                <name>Proxy Maintainers</name>
        </maintainer>
+       <longdescription>
+               The AWS SDK for C++ provides a modern C++ version C++ 11 or later interface for Amazon Web Services AWS.
+               It is meant to be performant and fully functioning with low- and high-level SDKs, while minimizing
+               dependencies and providing platform portability Windows, OSX, Linux, and mobile.
+
+               AWS SDK for C++ is in now in General Availability and recommended for production use. We invite our
+               customers to join the development efforts by submitting pull requests and sending us feedback and ideas
+               via GitHub Issues.
+       </longdescription>
        <use>
                <flag name="aws_targets_access-management">SDK Support for AWS access-management</flag>
                <flag name="aws_targets_acm">SDK Support for AWS acm</flag>
                <flag name="aws_targets_workmail">SDK Support for AWS workmail</flag>
                <flag name="aws_targets_workspaces">SDK Support for AWS workspaces</flag>
                <flag name="aws_targets_xray">SDK Support for AWS xray</flag>
+               <flag name="http">Enable http support via curl</flag>
+               <flag name="rtti">Flag to enable/disable rtti within the library</flag>
+               <flag name="unity-build">
+                       Build using a single unified .cpp file for each service library.
+                       Reduces the size of static library binaries
+               </flag>
+
+               <flag name="access-management">
+                       AWS Access Management, a meta-flag that enables:
+                       AWS Certificate Manager (ACM): Provision, manage, and deploy SSL/TLS certificates on AWS managed
+                               resources.
+                       Identity and Access Management (IAM): A web service for securely controlling access to AWS
+                               services.
+                       Resource Access Manager (RAM): Customers who operate multiple accounts can create resources
+                               centrally and use AWS RAM to share them with all of their accounts to reduce operational
+                               overhead.
+                       Also enables acm-pca, identity-management and sts (Security Token Service).
+               </flag>
+               <flag name="apigateway">
+                       Create and deploy your own REST and WebSocket APIs at any scale.
+                       Also enables apigatewaymanagementapi and apigatewayv2.
+               </flag>
+               <flag name="backup">AWS Backup is a fully managed backup service</flag>
+               <flag name="batch">Run batch computing workloads on the AWS Cloud</flag>
+               <flag name="budgets">
+                       Use AWS Budgets to plan service usage, service costs, and instance reservations.
+                       Also enables the following related modules:
+                       AWS Cost Explorer (CE)     : Programmatically query cost and usage data.
+                       Cost and Usage Report (CUR): Programmatically create, query, and delete AWS Cost and Usage
+                               report definitions.
+               </flag>
+               <flag name="chime">Amazon Chime, a secure, real-time, unified communications service.</flag>
+               <flag name="cloud-desktop">
+                       AWS end user computing services.
+                       AppStream 2.0: Fully managed, secure application streaming service.
+                       WorkDocs     : Fully managed, secure enterprise storage and sharing service.
+                       WorkLink     : Fully managed, cloud-based service that enables secure, one-click access to
+                               internal websites and web apps from mobile devices.
+                       WorkMail     : Managed email and calendaring service.
+                       WorkSpaces   : Cloud-based desktop experience for end users.
+               </flag>
+               <flag name="cloud-dev">
+                       Enables in-cloud developer tools:
+                       Cloud9      : Cloud-based integrated development environment IDE to write, run, and debug code.
+                       CodeBuild   : Managed build service that compiles, runs unit tests and produces artifacts.
+                       CodeCommit  : Privately store and manage Git repositories in the AWS cloud.
+                       CodeDeploy  : Automate the deployment and updating of applications.
+                       CodePipeline: Continuous delivery service to model, visualize, and automate the steps required
+                               to release software.
+                       CodeStar    : Quickly develop, build, and deploy applications on AWS.
+                       Queues      : Simple queue class. Allows standard queue operations top, delete, and push. Also
+                               has higher level, asynchronous interface with callbacks.
+                       X-Ray       : Provides request tracing, exception collection, and profiling capabilities.
+               </flag>
+               <flag name="cloud-media">
+                       AWS Media modules for transforming, converting, delivering and streaming media.
+                       Elastic Transcoder     : Convert media files stored in Amazon S3 into media files in the formats
+                               required by consumer playback devices.
+                       Elemental Media Connect: Secure and flexible transport service for live video.
+                       Elemental Media Convert: Format and compress offline video content for delivery to televisions
+                               or connected devices.
+                       Elemental Media Live   : Video service that allows easy and reliable creation of live outputs
+                               for broadcast and streaming delivery.
+                       Elemental Media Package: Just-in-time video packaging and origination service. (Includes
+                               mediapackage-vod)
+                       Elemental Media Store  : Video origination and storage service.Manage video assets as objects in
+                               containers to build dependable, cloud-based media workflows. (Includes mediastore-data)
+                       Elemental Media Tailor : Personalization and monetization service that allows scalable server-
+                               side ad insertion.
+               </flag>
+               <flag name="cloud-mobile">
+                       AWS Mobile modules for handling mobile application management and delivery.
+                       Amplify    : Comprehensive set of SDKs, libraries, tools, and documentation for client app
+                               development.
+                       AppSync    : Enterprise level, fully managed GraphQL service with real-time data synchronization
+                               and offline programming features.
+                       Device Farm: Test iOS, Android and Fire OS apps on real, physical phones and tablets that are
+                               hosted by AWS.
+                       PinPoint   : Engage customers by sending them email, SMS and voice messages, and push
+                               notifications. (Includes pinpoint-email and sms-voice)
+                       SNS        : Amazon Simple Notification Service, see USE flag sns.
+                       Also enables mobile and mobileanalytics.
+               </flag>
+               <flag name="cloudformation">
+                       Create and provision AWS infrastructure deployments predictably and repeatedly. Use a template
+                       file to create and delete a collection of resources together as a single unit (a stack).
+               </flag>
+               <flag name="cloudfront">
+                       Delivers static and dynamic web content through a worldwide network of edge locations that
+                       provide low latency and high performance.
+               </flag>
+               <flag name="cloudhsm">
+                       Secure cryptographic key storage by providing managed hardware security modules in the AWS
+                       Cloud.
+                       Also enables cloudhsmv2.
+               </flag>
+               <flag name="cloudsearch">
+                       Fully managed service in the cloud to set up, manage, and scale a search solution for websites.
+                       Also enables cloudsearchdomain.
+               </flag>
+               <flag name="cloudwatch">
+                       Amazon CloudWatch monitors Amazon Web Services (AWS) resources and the applications run on AWS
+                       in real time.
+                       The following modules besides 'monitoring' are also enabled:
+                       Application Insights: Monitor .NET and SQL Server applications.
+                       App Mesh            : Monitor and control microservices running on AWS.
+                       CloudTrail          : Monitor AWS deployments in the cloud by getting a history of AWS API
+                               calls, including API calls made via the AWS Management Console, the AWS SDKs, the
+                               command line tools, and higher-level AWS services.
+                       GuardDuty           : Continuous security monitoring service.
+                       Health              : Provides personalized information about events that can affect the AWS
+                               infrastructure, guides through scheduled changes, and accelerates the troubleshooting of
+                               issues that affect AWS resources and accounts.
+                       Inspector           : A security vulnerability assessment service that helps improve the
+                               security and compliance of
+                       AWS resources.
+                       Logs                : Monitor, store, and access log files from Amazon EC2 instances, AWS
+                               CloudTrail, or other sources.
+               </flag>
+               <flag name="cognito">
+                       Create unique identities, authenticate these identities with identity providers and save mobile
+                       user data in the AWS Cloud.
+                       Enables cognito-identity, cognito-idp and cognito-sync
+               </flag>
+               <flag name="config">
+                       Provides a detailed view of the resources associated with your AWS account, including how they
+                       are configured, how they are related to one another, and how the configurations and their
+                       relationships have changed over time.
+               </flag>
+               <flag name="dlm">
+                       Amazon Data Lifecycle Manager (DLM):
+                       Manage the lifecycle of AWS resources. Create lifecycle policies to automate operations on
+                       specified resources.
+               </flag>
+               <flag name="ec2">
+                       Amazon Elastic Compute Cloud (EC2) is a web service that provides resizeable computing capacity.
+                       This flag also enables the following modules:
+                       Auto Scaling       : Set up dynamic and predictive scaling for scalable AWS resources. Also
+                               enables autoscaling-plans and application-autoscaling.
+                       Elastic File System: EFS provides file storage for Amazon EC2 instances.
+
+               </flag>
+               <flag name="ecr">
+                       Amazon Elastic Container Registry (ECR) is a fully managed Docker container registry.
+               </flag>
+               <flag name="ecs">
+                       Amazon Elastic Container Service (ECS) is a highly scalable, fast, container management service.
+               </flag>
+               <flag name="eks">
+                       Amazon Elastic Kubernetes Service (EKS) is a managed service to run Kubernetes on AWS without own Kubernetes clusters.
+               </flag>
+               <flag name="elasticache">
+                       Set up, manage, and scale distributed in-memory cache environments in the AWS Cloud
+               </flag>
+               <flag name="elasticbeanstalk">Quickly deploy and manage applications in the AWS Cloud.</flag>
+               <flag name="elasticloadbalancing">
+                       Automatically distribute incoming application traffic across multiple targets, such as EC2
+                       instances.
+                       Also enables elasticloadbalancingv2.
+               </flag>
+               <flag name="elasticmapreduce">
+                       Amazon Elastic MapReduce (EMR) processes large amounts of data efficiently using Hadoop
+                       processing combined with several AWS products.
+               </flag>
+               <flag name="email">
+                       Amazon Simple Email Service (Amazon SES):
+                       An email platform to send and receive email using ones own email addresses and domains.
+                       See: https://docs.aws.amazon.com/ses/latest/DeveloperGuide/Welcome.html
+               </flag>
+               <flag name="es">
+                       Amazon Elasticsearch Configuration Service (ES) is an API to create, configure, and manage
+                       Elasticsearch domains.
+               </flag>
+               <flag name="events">
+                       Serverless event bus service to connect applications with data from a variety of sources.
+                       Also enables eventbridge.
+               </flag>
+               <flag name="fsx">Amazon FSx is a fully managed service to launch and use shared file storage.</flag>
+               <flag name="globalaccelerator">
+                       AWS Global Accelerator is a network layer service for accelerators to improve availability and
+                       performance for internet applications used by a global audience.
+               </flag>
+               <flag name="iot">AWS IoT
+                       This is a meta-flag for all Internet of Things modules provided by the SDK:
+                       iot           : enables secure, bi-directional communication between Internet-connected things
+                               (such as sensors, actuators, embedded devices, or smart appliances) and the AWS Cloud
+                               over MQTT and HTTP.
+                       greengrass    : Extends AWS onto physical devices so they can act locally on the data they
+                               generate.
+                       iot1click     : A service for simple devices to trigger AWS Lambda functions that execute a
+                               specific action.
+                       iotanalytics  : Provides advanced data analysis for AWS IoT.
+                       iotevents     : Monitor equipment or device fleets for failures or changes in operation, and
+                               trigger actions when such events occur.
+                       iotthingsgraph: Integrated set of tools that enable developers to build IoT applications using
+                               devices and services that use different data representation standards and communication protocols.
+                       Also enables iot1click-devices, iot1click-projects, iot-data, iotevents-data and iot-jobs-data.
+               </flag>
+               <flag name="kinesis">
+                       Amazon Kinesis
+                       Collect, process, and analyze video and data streams in real time. The following modules besides
+                       'kinesis' are enabled:
+                       firehose                    : Load data streams into AWS data stores.
+                       kinesisanalytics            : Process and analyze streaming data using SQL or Java. (Also
+                               enables kinesisanalyticsv2)
+                       kinesisvideo                : Capture, process, and store video streams for analytics and
+                               machine learning.
+                       Additionally kinesis-video-archived-media and kinesis-video-media are enabled.
+               </flag>
+               <flag name="kms">
+                       AWS Key Management Service (KMS)
+                       An encryption and key management service scaled for the cloud.
+               </flag>
+               <flag name="lex">
+                       Amazon Lex is an AWS service for building conversational interfaces into applications using
+                       voice and text.
+                       Also enables lex-models.
+               </flag>
+               <flag name="lambda">AWS Lambda: Run code without provisioning or managing servers.</flag>
+               <flag name="license-manager">
+                       Streamlines the process of bringing software vendor licenses to the cloud.
+               </flag>
+               <flag name="lightsail">
+                       The easiest way to get started with AWS for developers who just need virtual private servers
+               </flag>
+               <flag name="machinelearning">
+                       The algorithms of Amazon Machine Learning create machine learning (ML) models by finding
+                       patterns in existing data. The service uses these models to process new data and generate
+                       predictions for application.
+               </flag>
+               <flag name="macie">
+                       A security service that uses machine learning to automatically discover, classify, and protect
+                       sensitive data in AWS.
+               </flag>
+               <flag name="managedblockchain">
+                       Create and manage scalable blockchain networks using popular open source frameworks. Currently,
+                       Managed Blockchain supports the Hyperledger Fabric open source framework.
+               </flag>
+               <flag name="marketplace">
+                       AWS Marketplace is an online store where you can buy or sell software that runs on Amazon Web
+                       Services (AWS).
+                       Marketplace support consists of the marketplacecommerceanalytics module plus:
+                       Marketplace Entitlement Service: A contract verification feature that AWS Marketplace sellers
+                               can use to verify the amount of the seller’s product (for example, end user licenses or
+                               storage, data, or compute capacity) the customer has purchased.
+                       Marketplace Metering Service   : A pricing and metering feature that AWS Marketplace sellers can
+                               use to directly charge for their software along one of four dimensions: users, data,
+                               bandwidth, or hosts.
+                       Also enables pricing.
+               </flag>
+               <flag name="organizations">
+                       Account management service that to consolidate multiple AWS accounts into an organization to be
+                       centrally managed.
+               </flag>
+               <flag name="opsworks">
+                       AWS OpsWorks is a simple and flexible way to create and manage stacks and applications.
+                       Also enables opsworkscm.
+               </flag>
+               <flag name="other">
+                       This is a meta-flag for rarely needed modules that in themselves need not much build time. If
+                       you would like to have any of the following modules to have their own USE flag, please open a
+                       bug report and it will most probably get one.
+                       Alexa for Business      : Manage Alexa devices, enroll users, and assign skills.
+                       AWS Migration Hub       : A single location to track migration tasks across multiple AWS tools
+                               and partner solutions.
+                       Amazon Cloud Directory  : Store hundreds of millions of application-specific objects with
+                               multiple relationships and schemas.
+                       Amazon Comprehend       : Natural language processing (NLP) to extract insights about the
+                               content of documents without the need of any special preprocessing.
+                       Comprehend Medical      : Specialized Amazon Comprehend variant to extract insights from
+                               clinical documents such as doctor’s notes or clinical trial reports.
+                       Amazon Connect          : A contact center as a service (CCaS) solution that offers easy, self-
+                               service configuration and enables dynamic, personal, and natural customer engagement at
+                               any scale.
+                       AWS Data Pipeline       : A web service to automate the movement and transformation of data.
+                       AWS Data Sync           : A data-transfer service that simplifies, automates, and accelerates
+                               moving and replicating data between on-premises storage systems and AWS storage services
+                               over the internet or AWS Direct Connect.
+                       AWS Direct Connect      : Link your internal network to an AWS Direct Connect location over a
+                               standard 1 gigabit or 10 gigabit Ethernet fiber-optic cable.
+                       Application Discovery   : Automatically identify applications running in on-premises data
+                               centers, their associated dependencies, and their performance profile.
+                       Database Migration (DMS): Migrate data from a database that is on-premises, on an Amazon
+                               Relational Database Service (Amazon RDS) DB instance, or in a database on an Amazon
+                               Elastic Compute Cloud (Amazon EC2) instance to a database on an AWS service.
+                       Amazon DocumentDB       : Fully managed database service to set up, operate, and scale MongoDB-
+                               compatible databases.
+                       AWS Directory Service   : A web service to setup and run directories in the AWS cloud, or
+                               connect AWS resources with an existing on-premises Microsoft Active Directory.
+                       Amazon DynamoDB         : A fully managed NoSQL database with seamless scalability. Also enables
+                               dax and dynamodbstreams.
+                       Amazon GameLift         : A fully managed service for deploying, operating, and scaling session-
+                               based multiplayer game servers in the cloud.
+                       Amazon Glue             : Fully managed ETL (extract, transform, and load) service to categorize
+                               data, clean it, enrich it, and move it reliably between various data stores.
+                       Amazon Ground Statíon   : Fully managed service that enables you to control satellite
+                               communications, process satellite data, and scale your satellite operations.
+                       AWS Import/Export       : Accelerates transferring large amounts of data between the AWS cloud
+                               and portable storage devices that are mailed to Amazon.
+                       Amazon Kafka            : Amazon Managed Streaming for Apache Kafka (Amazon MSK)
+                       AWS Lake Formation      : A managed service to set up, secure, and manage your data lakes.
+                       Amazon MQ               : A managed message broker service for Apache ActiveMQ to set up and
+                               operate message brokers in the cloud.
+                       Amazon Mechanical Turk  : Request on-demand, scalable, human workforce to complete jobs that
+                               humans can do better than computers, such as recognizing objects in photographs.
+                       Amazon Neptune          : Fast and reliable fully managed graph database service. Supports
+                               Apache TinkerPop Gremlin and W3C’s SPARQL
+                       Amazon QuickSight       : A fast business analytics service to build visualizations, perform ad
+                               hoc analysis, and quickly get business insights from your data.
+                       Amazon Redshift         : Fully managed petabyte-scale data warehouse service.
+                       Amazon Robomaker        : A service to develop, simulate, and deploy intelligent robotics
+                               applications at scale.
+                       AWS ServiceCatalog      : Create, manage, and distribute portfolios of approved products to end
+                               users, who can then access the products they need in a personalized portal.
+                       AWS ServiceDiscovery    : Use AWS Cloud Map to configure public DNS, private DNS, or HTTP
+                               namespaces that microservice applications run in.
+                       AWS Service Quotas      : Service for viewing and managing quotas
+                       AWS Simple DB (SDB)     : A web service providing the core database functions of data indexing
+                               and querying in the cloud.
+                       AWS Code Signer         : Use AWS Signer for FreeRTOS to sign code that you created for any of
+                               the IoT devices that Amazon Web Services supports.
+                       Server Migration Service: (SMS) Combines data collection tools with automated server replication
+                               to speed the migration of on-premises servers to AWS.
+                       AWS Snowball            : A service to transport terabytes or petabytes of data to and from AWS
+                       AWS Systems Manager     : (SSM) Organize, monitor, and automate management tasks on AWS
+                               resources.
+                       AWS Step Functions      : (states) A service to coordinate the components of distributed
+                               applications and microservices using visual workflows.
+                       AWS Storage Gateway     : Connect on-premises software with cloud-based storage.
+                       Amazon Support          : Provides support for users of Amazon Web Services.
+                       Simple Workflow Service : (SWF) Build applications that coordinate work across distributed
+                               components.
+               </flag>
+               <flag name="personalize">
+                       Real-time personalization and recommendations, based on the same technology used at Amazon.com.
+                       Also enables personalize-events and personalize-runtime.
+               </flag>
+               <flag name="polly">
+                       Amazon Polly
+                       A Text-to-Speech (TTS) cloud service that converts text into lifelike speech.
+                       Also enables text-to-speech.
+               </flag>
+               <flag name="queues">
+                       AWS Queues is a simple queue class.
+                       Allows standard queue operations top, delete, and push. Also has higher level, asynchronous
+                       interface with callbacks.
+               </flag>
+               <flag name="rds">
+                       Amazon Relational Database Service (RDS) is a web service to set up, operate, and scale a
+                       relational database in the cloud.
+                       Also enables pi (Performance Insights) and rds-data.
+               </flag>
+               <flag name="route53">
+                       AWS Route 53 is a highly available and scalable Domain Name System (DNS) web service.
+                       Also enables route53domains and route53resolver.
+               </flag>
+               <flag name="rekognition">Add image and video analysis to applications.</flag>
+               <flag name="resource-groups">
+                       AWS Resource Groups and Tag Editor
+                       Organize AWS resources into groups, tag resources using virtually any criteria, and manage,
+                       monitor, and automate tasks on grouped resources.
+                       Also enables resourcegroupstaggingapi. (Resource Groups Tagging API)
+               </flag>
+               <flag name="s3">
+                       Amazon Simple Storage Service Storage for the internet.
+                       Additionally to the s3 module, the following modules are activated:
+                       Athena           : Interactive query service to analyze data in Amazon S3 using standard SQL.
+                       Glacier          : Storage solution for 'cold data'.
+                       Transfer for SFTP: Transfer files directly into and out of Amazon S3 using SFTP.
+                       Also enables s3-encryption, s3control and transfer.
+               </flag>
+               <flag name="sagemaker">
+                       Amazon SageMaker
+                       Fully managed machine learning service. With Amazon SageMaker, data scientists and developers
+                       can quickly and easily build and train machine learning models, and then directly deploy them
+                       into a production-ready hosted environment.
+                       Also enables sagemaker-runtime.
+               </flag>
+               <flag name="secretsmanager">
+                       Encrypt, store, and retrieve credentials for databases and other services.
+               </flag>
+               <flag name="securityhub">Provides a comprehensive view of the security state of AWS resources.</flag>
+               <flag name="serverlessrepo">
+                       AWS Serverless Application Repository
+                       Enables teams, organizations, and individual developers to find, deploy, publish, share, store,
+                       and easily assemble serverless architectures.
+               </flag>
+               <flag name="shield">AWS Shield, protection against DDoS attacks</flag>
+               <flag name="sns">
+                       Amazon Simple Notification Service (SNS) is a web service that enables applications, end-users,
+                       and devices to instantly send and receive notifications from the cloud.
+               </flag>
+               <flag name="sqs">
+                       Amazon Simple Queue Service (SQS): Fully managed message queuing service that makes it easy to
+                       decouple and scale microservices, distributed systems, and serverless applications.
+               </flag>
+               <flag name="textract">
+                       Amazon Textract to add document text detection and analysis to applications.
+               </flag>
+               <flag name="transcribe">
+                       A transcription services for audio files. It uses advanced machine learning technologies to
+                       recognize spoken words and transcribe them into text.
+                       Also enables transcribestreaming.
+               </flag>
+               <flag name="translate">
+                       A neural machine translation service for translating text to and from English across a breadth
+                       of supported languages.
+               </flag>
+               <flag name="waf">
+                       The Web Application Firewall (WAF) can monitor web requests that are forwarded to Amazon
+                       CloudFront distributions or an Application Load Balancer. Can also be used to block or allow
+                       requests based on conditions such as the IP addresses that requests originate from or values in
+                       the requests.
+                       Also enables fms and waf-regional.
+               </flag>
        </use>
 </pkgmetadata>