dev-ruby/pg_array_parser: fix many issues.
authorHans de Graaff <graaff@gentoo.org>
Wed, 9 Sep 2015 05:48:57 +0000 (07:48 +0200)
committerHans de Graaff <graaff@gentoo.org>
Wed, 9 Sep 2015 05:49:29 +0000 (07:49 +0200)
Fix LICENSE.
Fix USE=doc and FEATURES=test.
Actually compile and install the compiled extension.

Package-Manager: portage-2.2.20.1

dev-ruby/pg_array_parser/pg_array_parser-0.0.9-r1.ebuild [moved from dev-ruby/pg_array_parser/pg_array_parser-0.0.9.ebuild with 75% similarity]

similarity index 75%
rename from dev-ruby/pg_array_parser/pg_array_parser-0.0.9.ebuild
rename to dev-ruby/pg_array_parser/pg_array_parser-0.0.9-r1.ebuild
index c1f969168ae564f77ba8f86026f85546c07ae087..e70da980807593cb8a601b2613dfe32ad18fd76f 100644 (file)
@@ -1,21 +1,24 @@
 # Copyright 1999-2015 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: Exp $
+# $Id$
 
 EAPI=5
-USE_RUBY="ruby19 ruby20 ruby21"
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
 
 inherit ruby-fakegem versionator
 
 DESCRIPTION="Simple library to parse PostgreSQL arrays into a array of strings"
 HOMEPAGE="https://github.com/dockyard/pg_array_parser"
-SRC_URI="mirror://rubygems/${P}.gem"
 
-LICENSE="BSD"
+LICENSE="MIT"
 SLOT="$(get_version_component_range 1-3)"
 KEYWORDS="~amd64 ~arm ~x86"
 IUSE=""
-RESTRICT=test
 
 ruby_add_bdepend "dev-ruby/bundler"
 
@@ -40,3 +43,12 @@ each_ruby_prepare() {
                BUNDLE_GEMFILE=Gemfile ${RUBY} -S bundle check || die
        fi
 }
+
+each_ruby_configure() {
+       ${RUBY} -Cext/pg_array_parser extconf.rb || die
+}
+
+each_ruby_compile() {
+       emake -Cext/pg_array_parser V=1
+       cp ext/pg_array_parser/pg_array_parser.so lib/
+}