sys-apps/roccat-tools: Bump to version 5.9.0
authorLars Wendler <polynomial-c@gentoo.org>
Wed, 17 Jul 2019 12:55:57 +0000 (14:55 +0200)
committerLars Wendler <polynomial-c@gentoo.org>
Wed, 17 Jul 2019 13:10:35 +0000 (15:10 +0200)
Closes: https://bugs.gentoo.org/660396
Closes: https://bugs.gentoo.org/689968
Package-Manager: Portage-2.3.69, Repoman-2.3.16
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
sys-apps/roccat-tools/Manifest
sys-apps/roccat-tools/roccat-tools-5.9.0.ebuild [new file with mode: 0644]

index 2dc0fc275825dfa436006d1493beb961ebefa05f..518d6dba87b8838ac5ef227189820cba9251dbbf 100644 (file)
@@ -1 +1,2 @@
 DIST roccat-tools-5.7.0.tar.bz2 3737735 BLAKE2B fdd86cef425f1f33309165673be52c8297380a1f0a722e827c2b3697c59dd787f4b473186ab5b8ff8fadcfc851f3bb5e76c8407d831b31f82cd360679d3c1a09 SHA512 209f9fa5302806a2d2681077e990a39a4913d47b82e73f9acd86f734affd8b3a7c0087e815e5cc1dfec1787d868d09b87211d9c2a90f2ced67c150eec1b2d290
+DIST roccat-tools-5.9.0.tar.bz2 3736671 BLAKE2B 4cdd0c6b50021cfae127a692d5a2a7fff5e7e1281da7add0cf9cd8f5fbfd8882186142d56982bf929867bde2950440f26ced167b52707c9d810ab53a62a4bded SHA512 d825fc372654257f330abbc7e611e87c4888924288ad56c8e57c9db5c8c25426d454ae1ab4dd591ef3b930bed410497c0aa88095d5319e2708f4b263d16eca00
diff --git a/sys-apps/roccat-tools/roccat-tools-5.9.0.ebuild b/sys-apps/roccat-tools/roccat-tools-5.9.0.ebuild
new file mode 100644 (file)
index 0000000..85d6255
--- /dev/null
@@ -0,0 +1,112 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit readme.gentoo-r1 cmake-utils udev user xdg
+
+DESCRIPTION="Utility for advanced configuration of Roccat devices"
+
+HOMEPAGE="http://roccat.sourceforge.net/"
+SRC_URI="mirror://sourceforge/roccat/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE_INPUT_DEVICES=(
+       input_devices_roccat_arvo
+       input_devices_roccat_isku
+       input_devices_roccat_iskufx
+       input_devices_roccat_kiro
+       input_devices_roccat_kone
+       input_devices_roccat_koneplus
+       input_devices_roccat_konepure
+       input_devices_roccat_konepuremilitary
+       input_devices_roccat_konepureoptical
+       input_devices_roccat_konextd
+       input_devices_roccat_konextdoptical
+       input_devices_roccat_kovaplus
+       input_devices_roccat_kova2016
+       input_devices_roccat_lua
+       input_devices_roccat_nyth
+       input_devices_roccat_pyra
+       input_devices_roccat_ryosmk
+       input_devices_roccat_ryosmkfx
+       input_devices_roccat_ryostkl
+       input_devices_roccat_savu
+       input_devices_roccat_skeltr
+       input_devices_roccat_sova
+       input_devices_roccat_suora
+       input_devices_roccat_tyon
+)
+
+IUSE="${IUSE_INPUT_DEVICES[@]}"
+
+RDEPEND="
+       dev-libs/dbus-glib
+       dev-libs/glib:2
+       >=dev-libs/libgaminggear-0.15.1
+       sys-apps/dbus
+       x11-libs/cairo
+       x11-libs/gtk+:2
+       x11-libs/libX11
+       virtual/libgudev:=
+       virtual/libusb:1
+       input_devices_roccat_ryosmk? ( || ( dev-lang/lua:5.1 dev-lang/lua:0 ) )
+       input_devices_roccat_ryosmkfx? ( || ( dev-lang/lua:5.1 dev-lang/lua:0 ) )
+       input_devices_roccat_ryostkl? ( || ( dev-lang/lua:5.1 dev-lang/lua:0 ) )
+"
+
+DEPEND="
+       ${RDEPEND}
+"
+
+DOCS=( Changelog KNOWN_LIMITATIONS README )
+
+pkg_setup() {
+       enewgroup roccat
+
+       local model
+       for model in ${IUSE_INPUT_DEVICES[@]} ; do
+               use ${model} && USED_MODELS+="${model/input_devices_roccat_/;}"
+       done
+}
+
+# Required because xdg.eclass overrides src_prepare() from cmake-utils.eclass
+src_prepare() {
+       cmake-utils_src_prepare
+}
+
+src_configure() {
+       mycmakeargs=(
+               -DDEVICES="${USED_MODELS/;/}"
+               -DUDEVDIR="${EPREFIX}/$(get_udevdir)/rules.d"
+       )
+       cmake-utils_src_configure
+}
+
+src_install() {
+       cmake-utils_src_install
+       local stat_dir=/var/lib/roccat
+       keepdir ${stat_dir}
+       fowners root:roccat ${stat_dir}
+       fperms 2770 ${stat_dir}
+       readme.gentoo_create_doc
+}
+
+pkg_preinst() {
+       xdg_pkg_preinst
+}
+
+pkg_postinst() {
+       xdg_pkg_postinst
+       readme.gentoo_print_elog
+       ewarn
+       ewarn "This version breaks stored data for some devices. Before reporting bugs please delete"
+       ewarn "affected folder(s) in /var/lib/roccat"
+       ewarn
+}
+
+pkg_postrm() {
+       xdg_pkg_postrm
+}