net-vpn/strongswan: tweak for gcc-10, bug #706408
authorSergei Trofimovich <slyfox@gentoo.org>
Wed, 26 Feb 2020 08:47:33 +0000 (08:47 +0000)
committerSergei Trofimovich <slyfox@gentoo.org>
Wed, 26 Feb 2020 08:51:31 +0000 (08:51 +0000)
Closes: https://bugs.gentoo.org/706408
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
net-vpn/strongswan/files/strongswan-5.8.2-gcc-10.patch [new file with mode: 0644]
net-vpn/strongswan/strongswan-5.8.2.ebuild

diff --git a/net-vpn/strongswan/files/strongswan-5.8.2-gcc-10.patch b/net-vpn/strongswan/files/strongswan-5.8.2-gcc-10.patch
new file mode 100644 (file)
index 0000000..a7be117
--- /dev/null
@@ -0,0 +1,45 @@
+https://bugs.gentoo.org/706408
+https://github.com/strongswan/strongswan/pull/163
+
+From a1f73a67aed56628c4655caa1ae50a6a2e4ec639 Mon Sep 17 00:00:00 2001
+From: Sergei Trofimovich <slyfox@gentoo.org>
+Date: Sun, 26 Jan 2020 11:03:27 +0000
+Subject: [PATCH] swanctl: fix build failure against gcc-10
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+On gcc-10 (and gcc-9 -fno-common) build fails as:
+
+```
+libtool: link: gcc ... -o .libs/swanctl ...
+ld: commands/load_authorities.o:strongswan/src/swanctl/./swanctl.h:33:
+  multiple definition of `swanctl_dir'; commands/load_all.o:strongswan/src/swanctl/./swanctl.h:33: first defined here
+```
+
+gcc-10 will change the default from -fcommon to fno-common:
+https://gcc.gnu.org/PR85678.
+
+The error also happens if CFLAGS=-fno-common passed explicitly.
+
+Reported-by: Toralf Förster
+Bug: https://bugs.gentoo.org/706408
+Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
+---
+ src/swanctl/swanctl.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+--- a/src/swanctl/swanctl.h
++++ b/src/swanctl/swanctl.h
+@@ -30,7 +30,7 @@
+ /**
+  * Base directory for credentials and config
+  */
+-char *swanctl_dir;
++extern char *swanctl_dir;
+ /**
+  * Configuration file for connections, etc.
+-- 
+2.25.0
+
index 2ab3a0ed5d3aff0e383e39d417ef6688b50c20ff..bfcd20769ca058221fb858210549800009db2e47 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI="7"
@@ -45,6 +45,8 @@ RDEPEND="${COMMON_DEPEND}
        !net-vpn/libreswan
        selinux? ( sec-policy/selinux-ipsec )"
 
+PATCHES=("${FILESDIR}"/${P}-gcc-10.patch)
+
 UGID="ipsec"
 
 pkg_setup() {