dev-python/lockfile: Remove redundant versions
authorMichał Górny <mgorny@gentoo.org>
Fri, 27 Mar 2020 20:55:53 +0000 (21:55 +0100)
committerMichał Górny <mgorny@gentoo.org>
Fri, 27 Mar 2020 20:55:53 +0000 (21:55 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/lockfile/Manifest
dev-python/lockfile/lockfile-0.11.0-r1.ebuild [deleted file]
dev-python/lockfile/lockfile-0.12.2-r1.ebuild [deleted file]

index ab28cdc09e33ebd8dce3ceff5c464c58ddbdac0b..788b2e59c3f5d492d6c3bb33440c9361b26ed541 100644 (file)
@@ -1,2 +1 @@
-DIST lockfile-0.11.0.tar.gz 20909 BLAKE2B 8e13508312efc7eaa463e8fb80bf0a51ae3bc0adb93dee0eb52273bac40293e729de83aca98f549d12f3e46f9654c1d0f373aaba350acf7a17421c3d1fa9ea52 SHA512 6c4c69e1434194076a99f8134a2558c791675d420a17687dfd5b38c1303564392ecc388ec285d55a20027bcbcbc1b3475a489b70390796c46346b89d4b18ad89
 DIST lockfile-0.12.2.tar.gz 20874 BLAKE2B 8a1e49e8799516b44b219fb28101f3985d75fea842456e69c4357b71eb6a7be21cc56c0f9e885df8da3fb6c584ff4a47c7daad87ba34fc47a8cd40644ece063b SHA512 67b7d651d7e963a497c2604912c61eed90181cdd09c744a0ceaa26e6bbe09d1a871ce48be3949b7da7ea6b366b15492c8c8de589edeca2641ca5e6cb3804df07
diff --git a/dev-python/lockfile/lockfile-0.11.0-r1.ebuild b/dev-python/lockfile/lockfile-0.11.0-r1.ebuild
deleted file mode 100644 (file)
index 6711d5d..0000000
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_6 pypy3 )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Platform-independent file locking module"
-HOMEPAGE="https://launchpad.net/pylockfile https://pypi.org/project/lockfile/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 sparc x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
-       >dev-python/pbr-0.7[${PYTHON_USEDEP}]
-       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-       test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-RDEPEND=""
-
-DOCS=( ACKS AUTHORS ChangeLog README.rst RELEASE-NOTES )
-
-python_prepare_all() {
-       rm requirements.txt || die
-       distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
-       if use doc; then
-               einfo "Generation of documentation"
-               emake -C doc/source html
-       fi
-}
-
-python_test() {
-       # "${PYTHON}" test/test_lockfile.py yeilds no informative coverage output
-       nosetests || die "test_lockfile failed under ${EPYTHON}"
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( doc/source/.build/html/. )
-       distutils-r1_python_install_all
-}
diff --git a/dev-python/lockfile/lockfile-0.12.2-r1.ebuild b/dev-python/lockfile/lockfile-0.12.2-r1.ebuild
deleted file mode 100644 (file)
index 16da186..0000000
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{6,7} pypy3 )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Platform-independent file locking module"
-HOMEPAGE="https://launchpad.net/pylockfile https://pypi.org/project/lockfile/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
-       >dev-python/pbr-1.8[${PYTHON_USEDEP}]
-       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-       test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-RDEPEND=""
-
-DOCS=( ACKS AUTHORS ChangeLog README.rst RELEASE-NOTES )
-
-python_compile_all() {
-       use doc && emake -C doc/source html
-}
-
-python_test() {
-       # "${PYTHON}" test/test_lockfile.py yeilds no informative coverage output
-       nosetests --verbose || die "test_lockfile failed under ${EPYTHON}"
-}
-
-python_install_all() {
-       use doc && dodoc -r doc/source/.build/html
-       distutils-r1_python_install_all
-}