net-ftp/linksys-tftp: refresh & apply header patch
authorMike Frysinger <vapier@gentoo.org>
Mon, 17 Aug 2015 12:47:25 +0000 (08:47 -0400)
committerMike Frysinger <vapier@gentoo.org>
Mon, 17 Aug 2015 12:48:07 +0000 (08:48 -0400)
This was queued a while ago but never actually applied.
Add it and update the patch to fix a few more files.

net-ftp/linksys-tftp/files/linksys-tftp-1.2.1-r1-header.patch
net-ftp/linksys-tftp/linksys-tftp-1.2.1-r3.ebuild

index 386cf7b1e21045d2d4d5d7ec4ac87a61a5fc0957..9944f3c059bc18fd9b82ca89a7120e0c26638e85 100644 (file)
@@ -1,11 +1,13 @@
 --- linksys-tftp-1.2.1/main.c
 +++ linksys-tftp-1.2.1/main.c
-@@ -40,6 +40,8 @@
+@@ -40,6 +40,10 @@
  #include <setjmp.h>
  #include <ctype.h>
  #include <netdb.h>
 +#include <stdlib.h>
-+#include <strings.h>
++#include <string.h>
++#include <unistd.h>
++#include <sys/sendfile.h>
  
  #define       TIMEOUT         5               /* secs between rexmt's */
  
        char *argv[];
  {
        struct sockaddr_in sin;
+--- a/tftp.c
++++ b/tftp.c
+@@ -36,8 +36,8 @@
+ #include <stdio.h>
+ #include <errno.h>
+ #include <setjmp.h>
+-
+-extern        int errno;
++#include <string.h>
++#include <unistd.h>
+ extern  struct sockaddr_in sin;         /* filled in by main */
+ extern  int     f;                      /* the opened socket */
+@@ -69,16 +69,6 @@ void timer(int sig)
+       longjmp(timeoutbuf, 1);
+ }
+-strnlen(s, n)
+-      char *s;
+-      int n;
+-{
+-      int i = 0;
+-
+-      while (n-- > 0 && *s++) i++;
+-      return(i);
+-}
+-
+ /*
+  * Parse an OACK package and set blocksize accordingly
+  */
index 4b23797028304cdeb03c55e5b47bb7d245669e7f..8b635d4d349ca4cc54d306f0ff7a2c7c6d552c90 100644 (file)
@@ -16,6 +16,7 @@ KEYWORDS="amd64 ~ppc x86"
 IUSE=""
 
 src_prepare() {
+       epatch "${FILESDIR}"/${P}-r1-header.patch
        epatch "${FILESDIR}"/${P}-r1-Makefile.patch
 }