x11-wm/blackbox: [QA] inherit ltprune.eclass directly
authorDavid Seifert <soap@gentoo.org>
Sat, 15 Feb 2020 10:03:24 +0000 (11:03 +0100)
committerDavid Seifert <soap@gentoo.org>
Sat, 15 Feb 2020 10:03:24 +0000 (11:03 +0100)
Package-Manager: Portage-2.3.88, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
x11-wm/blackbox/blackbox-0.70.1-r1.ebuild
x11-wm/blackbox/blackbox-0.75.ebuild
x11-wm/blackbox/blackbox-0.76.ebuild

index 0ada0539ffc8e0e5fe5226c8fb22f75d5ea5aee6..1e59f5025522f3083ea162809e764f94919d3872 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=5
 
-inherit autotools eutils
+inherit autotools eutils ltprune
 
 DESCRIPTION="A small, fast, full-featured window manager for X"
 HOMEPAGE="https://github.com/bbidulock/blackboxwm"
index 36f1d3ceeba15825ff76823e96daa9e0708276a1..fdc90e086fc08fce4cdf2af58d7b40a6210bbfa2 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -48,5 +48,5 @@ src_install() {
        emake DESTDIR="${D}" install
        dodoc AUTHORS ChangeLog* COMPLIANCE README* TODO
 
-       prune_libtool_files --all
+       find "${D}" -name '*.la' -delete || die
 }
index 5bd673eb8b63480fd896ab388566f02dc1688742..fdc90e086fc08fce4cdf2af58d7b40a6210bbfa2 100644 (file)
@@ -48,5 +48,5 @@ src_install() {
        emake DESTDIR="${D}" install
        dodoc AUTHORS ChangeLog* COMPLIANCE README* TODO
 
-       prune_libtool_files --all
+       find "${D}" -name '*.la' -delete || die
 }