games-engines/qtads: bump to 3.0.0, update metadata, EAPI 7
authorNikos Chantziaras <realnc@gmail.com>
Mon, 17 Feb 2020 13:18:21 +0000 (15:18 +0200)
committerJames Le Cuirot <chewi@gentoo.org>
Sat, 22 Feb 2020 11:39:20 +0000 (11:39 +0000)
Closes: https://bugs.gentoo.org/709942
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Nikos Chantziaras <realnc@gmail.com>
Closes: https://github.com/gentoo/gentoo/pull/14683
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
games-engines/qtads/Manifest
games-engines/qtads/metadata.xml
games-engines/qtads/qtads-3.0.0.ebuild [new file with mode: 0644]

index 62c2c9e1bbbde2837ce80da433bc9f32c327ee00..a5710ccd4669a3eb4138bcf9fd6d902c2718eff9 100644 (file)
@@ -1 +1,2 @@
 DIST qtads-2.1.7.tar.bz2 2562026 BLAKE2B daa66022db1b187c2d74fc762fdb60beefb0988401464382d14c6f9bc1455a8046e212cdba9d834decb0efe053b3bb430392696b12bd4f94aaa006744c53a65e SHA512 ab88aa20991642df6048af49d2cd7b804dbb98b3f5c6ab38ad974e8b39531d880eac0eae0ba773f332e9568578b76b677bc35753f7d1e6d9a99d919b15f4c6ee
+DIST qtads-3.0.0-source.tar.xz 5325048 BLAKE2B cb60908e71edb32157638891a58bed83aba01d484821473716c17845094be9232f9e989bad474db27c1e06734b073ee301756b0528ca880e4c40c0994e95bc48 SHA512 e7b72350876475e0b5b9b8c8c953aa380f5f25dade25785d15c5004a6866bb614c3ca2a3b34f84989013e350f9e73d339ce8ddd7d36766d80a981cfbfda7d1c6
index b4146b480895c3b8d2638fbcc4afbcdc26deb813..33b59db35f14f0adaff0a716ea884c5f3d9c75a0 100644 (file)
@@ -5,7 +5,12 @@
     <email>games@gentoo.org</email>
     <name>Gentoo Games Project</name>
   </maintainer>
+  <longdescription lang="en">
+    QTads is a cross-platform, multimedia interpreter for playing TADS games. It
+    is fully compatible with HTML TADS (aka "Multimedia TADS.") Both TADS
+    versions in use today (v2 and v3) are supported.
+  </longdescription>
   <upstream>
-    <remote-id type="sourceforge">qtads</remote-id>
+    <remote-id type="github">realnc/qtads</remote-id>
   </upstream>
 </pkgmetadata>
diff --git a/games-engines/qtads/qtads-3.0.0.ebuild b/games-engines/qtads/qtads-3.0.0.ebuild
new file mode 100644 (file)
index 0000000..57d338d
--- /dev/null
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit qmake-utils xdg
+
+DESCRIPTION="Multimedia interpreter for TADS text adventures"
+HOMEPAGE="https://realnc.github.io/qtads"
+SRC_URI="https://github.com/realnc/qtads/releases/download/v${PV}/${P}-source.tar.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+sound"
+
+BDEPEND="
+       virtual/pkgconfig
+"
+DEPEND="
+       dev-qt/qtcore:5
+       dev-qt/qtgui:5
+       dev-qt/qtnetwork:5[ssl]
+       dev-qt/qtwidgets:5
+       sound? (
+               media-libs/libsdl2[sound]
+               media-libs/libsndfile
+               media-libs/libvorbis
+               media-sound/fluidsynth:0=
+               media-sound/mpg123
+       )
+"
+RDEPEND=${DEPEND}
+
+src_configure() {
+       eqmake5 \
+               PREFIX="${EPREFIX}/usr" \
+               $(usex !sound CONFIG+=disable-audio '') \
+               -after CONFIG-=silent
+}
+
+src_install() {
+       emake INSTALL_ROOT="${D}" install
+}