sys-apps/util-linux: Attempt to fix ntfs-3g mount with USE="python"
authorLars Wendler <polynomial-c@gentoo.org>
Wed, 3 Jul 2019 11:06:37 +0000 (13:06 +0200)
committerLars Wendler <polynomial-c@gentoo.org>
Wed, 3 Jul 2019 11:08:17 +0000 (13:08 +0200)
Bug: https://bugs.gentoo.org/689190
Package-Manager: Portage-2.3.68, Repoman-2.3.16
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
sys-apps/util-linux/util-linux-2.34-r2.ebuild [moved from sys-apps/util-linux/util-linux-2.34-r1.ebuild with 99% similarity]

similarity index 99%
rename from sys-apps/util-linux/util-linux-2.34-r1.ebuild
rename to sys-apps/util-linux/util-linux-2.34-r2.ebuild
index b15e6ad1a438cd1bbf66bda8de9e4523418a5da1..2b00a2ad6fa2cca6b6c8395019c8205d3cdfd8a9 100644 (file)
@@ -241,12 +241,13 @@ python_install() {
 }
 
 multilib_src_install() {
-       emake DESTDIR="${D}" install
-
        if multilib_is_native_abi && use python; then
                python_foreach_impl python_install
        fi
 
+       # This needs to be called AFTER python_install call (#689190)
+       emake DESTDIR="${D}" install
+
        if multilib_is_native_abi && use userland_GNU; then
                # need the libs in /
                gen_usr_ldscript -a blkid fdisk mount smartcols uuid